summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-04 16:01:13 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-04 16:01:13 +0000
commit6d07c72b66132da5f6adfdb71ce8dc5475473cab (patch)
treea763eeef858a597a007523a64419793efc39d60e /sci-biology/emboss/emboss-6.1.0.ebuild
parentMarking qt-core-4.6.3-r1 ppc for bug 361401 (diff)
downloadgentoo-2-6d07c72b66132da5f6adfdb71ce8dc5475473cab.tar.gz
gentoo-2-6d07c72b66132da5f6adfdb71ce8dc5475473cab.tar.bz2
gentoo-2-6d07c72b66132da5f6adfdb71ce8dc5475473cab.zip
Dropped old, fix for wrong EAPI version, #361919
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/emboss/emboss-6.1.0.ebuild')
-rw-r--r--sci-biology/emboss/emboss-6.1.0.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/sci-biology/emboss/emboss-6.1.0.ebuild b/sci-biology/emboss/emboss-6.1.0.ebuild
index 9777fe2b24b7..a19181c548d8 100644
--- a/sci-biology/emboss/emboss-6.1.0.ebuild
+++ b/sci-biology/emboss/emboss-6.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.1.0.ebuild,v 1.4 2011/03/09 19:50:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.1.0.ebuild,v 1.5 2011/04/04 16:01:13 jlec Exp $
inherit eutils
@@ -93,20 +93,17 @@ src_install() {
die "Failed to remove duplicated documentation."
# Remove useless dummy files from the image.
- rm "${D}"/usr/share/EMBOSS/data/{AAINDEX,PRINTS,PROSITE,REBASE}/dummyfile \
- || die "Failed to remove dummy files."
+ find emboss/data -name dummyfile -delete || die "Failed to remove dummy files."
# Move the provided codon files to a different directory. This will avoid
# user confusion and file collisions on case-insensitive file systems (see
# bug #115446). This change is documented in "README.Gentoo".
- mv "${D}"/usr/share/EMBOSS/data/CODONS \
- "${D}"/usr/share/EMBOSS/data/CODONS.orig || \
+ mv "${D}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
die "Failed to move CODON directory."
# Move the provided restriction enzyme prototypes file to a different name.
# This avoids file collisions with versions of rebase that install their
# own enzyme prototypes file (see bug #118832).
- mv "${D}"/usr/share/EMBOSS/data/embossre.equ \
- "${D}"/usr/share/EMBOSS/data/embossre.equ.orig || \
+ mv "${D}"/usr/share/EMBOSS/data/embossre.equ{,.orig} || \
die "Failed to move enzyme equivalence file."
}