summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-14 12:54:12 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-14 12:54:12 +0000
commita9561f61fc279d3c95f03dbb932c0ac2f15f6f08 (patch)
treec01a3200dcba975fb0e440eaaefc1f48cd66b790 /sci-biology/bioruby/bioruby-1.4.3.0001.ebuild
parentremove old (diff)
downloadgentoo-2-a9561f61fc279d3c95f03dbb932c0ac2f15f6f08.tar.gz
gentoo-2-a9561f61fc279d3c95f03dbb932c0ac2f15f6f08.tar.bz2
gentoo-2-a9561f61fc279d3c95f03dbb932c0ac2f15f6f08.zip
NMU: Version bump. Migrate to ruby-ng eclass. Cleanup old. See bug #475310.
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'sci-biology/bioruby/bioruby-1.4.3.0001.ebuild')
-rw-r--r--sci-biology/bioruby/bioruby-1.4.3.0001.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild b/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild
new file mode 100644
index 000000000000..2e1edb1a60f2
--- /dev/null
+++ b/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild,v 1.1 2013/09/14 12:54:12 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
+LICENSE="Ruby"
+HOMEPAGE="http://www.bioruby.org/"
+SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -rubygems test/runner.rb || die
+}