summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-09 21:45:48 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-09 21:45:48 +0000
commit617139b26bd8e5bf65ac6c528fa606e2f9d0e74b (patch)
tree73e0a13e717b266e4b70541a7daa2185639fa8d2 /sci-biology/biopython
parentBump to 8.4.0. Fixes #276125 (diff)
downloadgentoo-2-617139b26bd8e5bf65ac6c528fa606e2f9d0e74b.tar.gz
gentoo-2-617139b26bd8e5bf65ac6c528fa606e2f9d0e74b.tar.bz2
gentoo-2-617139b26bd8e5bf65ac6c528fa606e2f9d0e74b.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog8
-rw-r--r--sci-biology/biopython/biopython-1.51.ebuild53
-rw-r--r--sci-biology/biopython/files/biopython-1.51-flex.patch21
3 files changed, 81 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 98efdff1863e..7e79a08d9b25 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.35 2009/08/26 14:45:14 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.36 2009/09/09 21:45:48 weaver Exp $
+
+*biopython-1.51 (09 Sep 2009)
+
+ 09 Sep 2009; Andrey Kislyuk <weaver@gentoo.org>
+ +files/biopython-1.51-flex.patch, +biopython-1.51.ebuild:
+ Version bump
26 Aug 2009; Christian Faulhammer <fauli@gentoo.org> metadata.xml:
remove now unused flag description
diff --git a/sci-biology/biopython/biopython-1.51.ebuild b/sci-biology/biopython/biopython-1.51.ebuild
new file mode 100644
index 000000000000..3614eed87af8
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.51.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.51.ebuild,v 1.1 2009/09/09 21:45:48 weaver Exp $
+
+EAPI="2"
+
+NEED_PYTHON=2.4
+inherit distutils eutils base
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+LICENSE="as-is"
+HOMEPAGE="http://www.biopython.org"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+SLOT="0"
+IUSE="mysql postgres"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="dev-python/numpy
+ >=dev-python/reportlab-2.0
+ sys-devel/flex"
+
+RDEPEND="${DEPEND}
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flex.patch
+)
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CONTRIB DEPRECATED NEWS README"
+ distutils_src_install
+
+ dodir "/usr/share/doc/${PF}"
+ cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
+ die "Failed to install documentation."
+ dodir "/usr/share/${PN}"
+ rm -f Tests/*.pyc || \
+ die "Failed to remove precompiled test files."
+ cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
+ die "Failed to install shared files."
+}
+
+src_test() {
+ cd "${S}/Tests"
+ PYTHONPATH="${PYTHONPATH}:${S}" \
+ python run_tests.py --no-gui || die "Tests failed."
+}
diff --git a/sci-biology/biopython/files/biopython-1.51-flex.patch b/sci-biology/biopython/files/biopython-1.51-flex.patch
new file mode 100644
index 000000000000..afd509444c68
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.51-flex.patch
@@ -0,0 +1,21 @@
+--- setup.py.old 2008-11-25 18:03:16.000000000 +0100
++++ setup.py 2008-11-25 18:04:14.000000000 +0100
+@@ -341,12 +341,12 @@
+ include_dirs=["Bio"]
+ ),
+ #Commented out due to the build dependency on flex, see Bug 2619
+-# Extension('Bio.PDB.mmCIF.MMCIFlex',
+-# ['Bio/PDB/mmCIF/lex.yy.c',
+-# 'Bio/PDB/mmCIF/MMCIFlexmodule.c'],
+-# include_dirs=["Bio"],
+-# libraries=["fl"]
+-# ),
++ Extension('Bio.PDB.mmCIF.MMCIFlex',
++ ['Bio/PDB/mmCIF/lex.yy.c',
++ 'Bio/PDB/mmCIF/MMCIFlexmodule.c'],
++ include_dirs=["Bio"],
++ libraries=["fl"]
++ ),
+ Extension('Bio.Nexus.cnexus',
+ ['Bio/Nexus/cnexus.c']
+ ),