summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2007-05-17 18:47:30 +0000
committerOlivier Fisette <ribosome@gentoo.org>2007-05-17 18:47:30 +0000
commit10aae4d70bf3ccd3afda36939e548a6866b1b969 (patch)
tree0ceb4f3f5a5d78efa6dda9584c7a81c097e47ffd /sci-biology/biopython
parentremoved old versions. (diff)
downloadgentoo-2-10aae4d70bf3ccd3afda36939e548a6866b1b969.tar.gz
gentoo-2-10aae4d70bf3ccd3afda36939e548a6866b1b969.tar.bz2
gentoo-2-10aae4d70bf3ccd3afda36939e548a6866b1b969.zip
New upstream version. Ebuild clean-up. Pruned old version.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog9
-rw-r--r--sci-biology/biopython/biopython-1.40b.ebuild32
-rw-r--r--sci-biology/biopython/biopython-1.43.ebuild43
-rw-r--r--sci-biology/biopython/files/biopython-1.43-buildkdtree.patch28
-rw-r--r--sci-biology/biopython/files/digest-biopython-1.40b3
-rw-r--r--sci-biology/biopython/files/digest-biopython-1.433
6 files changed, 82 insertions, 36 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 5c323bb1a653..92407eef7a2e 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/biopython
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.17 2007/05/16 17:49:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.18 2007/05/17 18:47:30 ribosome Exp $
+
+*biopython-1.43 (17 May 2007)
+
+ 17 May 2007; Olivier Fisette <ribosome@gentoo.org>
+ +files/biopython-1.43-buildkdtree.patch, -biopython-1.40b.ebuild,
+ +biopython-1.43.ebuild:
+ New upstream version. Ebuild clean-up. Pruned old version.
16 May 2007; Raúl Porcel <armin76@gentoo.org> biopython-1.42.ebuild:
alpha stable wrt #153774
diff --git a/sci-biology/biopython/biopython-1.40b.ebuild b/sci-biology/biopython/biopython-1.40b.ebuild
deleted file mode 100644
index 02612ee0a689..000000000000
--- a/sci-biology/biopython/biopython-1.40b.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.40b.ebuild,v 1.4 2005/06/12 15:38:05 kloeri Exp $
-
-inherit distutils
-
-IUSE=""
-
-DESCRIPTION="Biopython - Python modules for computational molecular biology"
-SRC_URI="http://www.biopython.org/files/${P}.tar.gz"
-HOMEPAGE="http://www.biopython.org"
-
-DEPEND=">=dev-lang/python-2.2
- >=dev-python/egenix-mx-base-2.0.3
- >=dev-python/numeric-19.0
- >=dev-python/reportlab-1.11"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="alpha ~ppc sparc x86"
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- DOCS="Doc/* Doc/install/*.txt"
- distutils_src_install
-
- dohtml Doc/install/*.html
- cp -r Doc/examples/ ${D}/usr/share/doc/${PF}/
-}
diff --git a/sci-biology/biopython/biopython-1.43.ebuild b/sci-biology/biopython/biopython-1.43.ebuild
new file mode 100644
index 000000000000..4fb252896011
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.43.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.43.ebuild,v 1.1 2007/05/17 18:47:30 ribosome Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+LICENSE="as-is"
+HOMEPAGE="http://www.biopython.org"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+SLOT="0"
+IUSE="kdtree"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-buildkdtree.patch"
+ if use kdtree; then
+ sed -i -e 's/USE_KDTREE = False/USE_KDTREE = True/' \
+ setup.py || die "Could not apply patch for KDTree support."
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/*.txt Doc/*.tex Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html || die "Failed to install HTML install docs."
+ dohtml Doc/*.html || die "Failed to install HTML docs."
+ cp -r Doc/examples/ Doc/*.pdf ${D}/usr/share/doc/${PF}/ || \
+ die "Failed to install documentation."
+}
diff --git a/sci-biology/biopython/files/biopython-1.43-buildkdtree.patch b/sci-biology/biopython/files/biopython-1.43-buildkdtree.patch
new file mode 100644
index 000000000000..cefb16d7d95d
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.43-buildkdtree.patch
@@ -0,0 +1,28 @@
+--- setup.py.old 2007-03-17 15:21:04.000000000 -0400
++++ setup.py 2007-05-17 14:02:42.000000000 -0400
+@@ -64,6 +64,7 @@
+ _CHECKED = check_dependencies()
+ return _CHECKED
+
++USE_KDTREE = False
+ def check_dependencies():
+ """Return whether the installation should continue."""
+ # There should be some way for the user to tell specify not to
+@@ -112,15 +113,8 @@
+
+
+ # Compile KDTree ? Not compiled by default
+- print "\n*** Bio.KDTree *** NOT built by default "
+- kdtree_msg = """
+-The Bio.PDB.NeighborSearch module depends on the Bio.KDTree module,
+-which in turn, depends on C++ code that does not compile cleanly on
+-all platforms. Hence, Bio.KDTree is not built by default.
+-
+-Would you like to build Bio.KDTree ?"""
+-
+- if get_yes_or_no (kdtree_msg, 0):
++ global USE_KDTREE
++ if USE_KDTREE:
+ NUMPY_PACKAGES.append("Bio.KDTree")
+ NUMPY_EXTENSIONS.append(
+ CplusplusExtension('Bio.KDTree._CKDTree',
diff --git a/sci-biology/biopython/files/digest-biopython-1.40b b/sci-biology/biopython/files/digest-biopython-1.40b
deleted file mode 100644
index 33d945e5176b..000000000000
--- a/sci-biology/biopython/files/digest-biopython-1.40b
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2fb60e6c1e93e15153622c10e5fad7ff biopython-1.40b.tar.gz 627264
-RMD160 6e27ecd50084b58320906bf26574fe510068cc44 biopython-1.40b.tar.gz 627264
-SHA256 591a9f04ac533fd0ec5a1ded108bea897f1019d5ac23337c4bcb39e16d6deb18 biopython-1.40b.tar.gz 627264
diff --git a/sci-biology/biopython/files/digest-biopython-1.43 b/sci-biology/biopython/files/digest-biopython-1.43
new file mode 100644
index 000000000000..759c7a1330c3
--- /dev/null
+++ b/sci-biology/biopython/files/digest-biopython-1.43
@@ -0,0 +1,3 @@
+MD5 3c275b321bb1db7d8bda764913aaedcd biopython-1.43.tar.gz 3867907
+RMD160 d7d326659032f9587b85b339941ecb306b694403 biopython-1.43.tar.gz 3867907
+SHA256 eb424da9efddbf376c31660786ecb34ff893ea752bf7300f4a06d1b8c6ba175b biopython-1.43.tar.gz 3867907