summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-10-13 13:13:59 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-10-13 13:13:59 +0000
commit25a16436ff3d7f6087705997fe109eb9599d1639 (patch)
tree4fa87b21d6ce0e715f10bcdd71cb09f590b56c25 /sci-biology/amap/amap-2.1.ebuild
parentbump to 2.20.0 (diff)
downloadgentoo-2-25a16436ff3d7f6087705997fe109eb9599d1639.tar.gz
gentoo-2-25a16436ff3d7f6087705997fe109eb9599d1639.tar.bz2
gentoo-2-25a16436ff3d7f6087705997fe109eb9599d1639.zip
Version bump (fixes bug #191861).
(Portage version: 2.1.3.12)
Diffstat (limited to 'sci-biology/amap/amap-2.1.ebuild')
-rw-r--r--sci-biology/amap/amap-2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-biology/amap/amap-2.1.ebuild b/sci-biology/amap/amap-2.1.ebuild
new file mode 100644
index 000000000000..75077a393dfb
--- /dev/null
+++ b/sci-biology/amap/amap-2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/amap/amap-2.1.ebuild,v 1.1 2007/10/13 13:13:58 markusle Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}"
+DESCRIPTION="Protein multiple-alignment-based sequence annealing"
+HOMEPAGE="http://bio.math.berkeley.edu/amap/"
+SRC_URI="http://bio.math.berkeley.edu/amap/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-align"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PV}-fix-cxxflags.patch
+}
+
+src_compile() {
+ cd "${S}"/align
+ emake \
+ CXX="$(tc-getCXX)" \
+ OPT_CXXFLAGS="${CXXFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ cd "${S}"
+ dobin align/${PN}
+ dodoc align/README align/PROBCONS.README
+ insinto /usr/share/${PN}/examples
+ doins examples/* || die "Failed to install examples"
+}