summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-11 14:55:23 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-11 14:55:23 +0000
commit572fb74e26fba60b7bd4af3b408ce30f65302ac6 (patch)
treea7938d466972793ee4987d5068d007d5a62e8ee4 /sci-biology/abyss
parentfix doc install dir wrt #480518 (diff)
downloadgentoo-2-572fb74e26fba60b7bd4af3b408ce30f65302ac6.tar.gz
gentoo-2-572fb74e26fba60b7bd4af3b408ce30f65302ac6.tar.bz2
gentoo-2-572fb74e26fba60b7bd4af3b408ce30f65302ac6.zip
sci-biology/abyss: Version BUmp, respect AR, #477580
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/abyss')
-rw-r--r--sci-biology/abyss/ChangeLog9
-rw-r--r--sci-biology/abyss/abyss-1.3.3.ebuild10
-rw-r--r--sci-biology/abyss/abyss-1.3.4.ebuild8
-rw-r--r--sci-biology/abyss/abyss-1.3.6.ebuild46
-rw-r--r--sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch18
-rw-r--r--sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch18
-rw-r--r--sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch15
7 files changed, 118 insertions, 6 deletions
diff --git a/sci-biology/abyss/ChangeLog b/sci-biology/abyss/ChangeLog
index 62ae090239c6..7a534728cf26 100644
--- a/sci-biology/abyss/ChangeLog
+++ b/sci-biology/abyss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/abyss
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/ChangeLog,v 1.18 2013/08/11 13:29:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/ChangeLog,v 1.19 2013/08/11 14:55:22 jlec Exp $
+
+*abyss-1.3.6 (11 Aug 2013)
+
+ 11 Aug 2013; Justin Lecher <jlec@gentoo.org> abyss-1.3.3.ebuild,
+ abyss-1.3.4.ebuild, +abyss-1.3.6.ebuild, +files/abyss-1.3.3-ac_prog_ar.patch,
+ +files/abyss-1.3.6-ac_prog_ar.patch, +files/abyss-1.3.6-gcc-4.7.patch:
+ Version BUmp, respect AR, #477580
11 Aug 2013; Justin Lecher <jlec@gentoo.org> -abyss-1.2.3.ebuild,
-abyss-1.2.7.ebuild, -abyss-1.3.0.ebuild:
diff --git a/sci-biology/abyss/abyss-1.3.3.ebuild b/sci-biology/abyss/abyss-1.3.3.ebuild
index 752a131af6ab..9806da0ba4bb 100644
--- a/sci-biology/abyss/abyss-1.3.3.ebuild
+++ b/sci-biology/abyss/abyss-1.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.4 2013/07/27 22:22:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.5 2013/08/11 14:55:22 jlec Exp $
EAPI="4"
-inherit autotools eutils
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
@@ -24,7 +24,11 @@ RDEPEND="${DEPEND}"
# todo: fix automagic mpi toggling
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ tc-export AR
+ epatch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch \
+ "${FILESDIR}"/${P}-ac_prog_ar.patch
+
sed -i -e "s/-Werror//" configure.ac || die #365195
sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
eautoreconf
diff --git a/sci-biology/abyss/abyss-1.3.4.ebuild b/sci-biology/abyss/abyss-1.3.4.ebuild
index 3e8e7fa36f4e..a6d4ea462569 100644
--- a/sci-biology/abyss/abyss-1.3.4.ebuild
+++ b/sci-biology/abyss/abyss-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.4.ebuild,v 1.2 2013/07/17 07:32:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.4.ebuild,v 1.3 2013/08/11 14:55:22 jlec Exp $
EAPI=5
@@ -25,9 +25,13 @@ RDEPEND="${DEPEND}"
# todo: --enable-maxk=N configure option
# todo: fix automagic mpi toggling
-PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${PN}-1.3.3-ac_prog_ar.patch
+ )
src_prepare() {
+ tc-export AR
sed -i -e "s/-Werror//" configure.ac || die #365195
sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
autotools-utils_src_prepare
diff --git a/sci-biology/abyss/abyss-1.3.6.ebuild b/sci-biology/abyss/abyss-1.3.6.ebuild
new file mode 100644
index 000000000000..fe0006ac4b5b
--- /dev/null
+++ b/sci-biology/abyss/abyss-1.3.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.6.ebuild,v 1.1 2013/08/11 14:55:22 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="http://www.bcgsc.ca/downloads/abyss/${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-cpp/sparsehash
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-ac_prog_ar.patch
+ )
+
+src_prepare() {
+ tc-export AR
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch b/sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch
new file mode 100644
index 000000000000..300868f52b76
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.3-ac_prog_ar.patch
@@ -0,0 +1,18 @@
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 5c6cb92..b99bedd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,6 +12,10 @@ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AN_MAKEVAR([AR], [AC_PROG_AR])
++AN_PROGRAM([ar], [AC_PROG_AR])
++AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])
++AC_PROG_AR
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([dlfcn.h fcntl.h float.h limits.h \
diff --git a/sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch b/sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch
new file mode 100644
index 000000000000..158e9b1262e4
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.6-ac_prog_ar.patch
@@ -0,0 +1,18 @@
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9d4bb66..aa94364 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,6 +12,10 @@ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AN_MAKEVAR([AR], [AC_PROG_AR])
++AN_PROGRAM([ar], [AC_PROG_AR])
++AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])
++AC_PROG_AR
+ AC_CHECK_TOOL(GHC, ghc)
+ AM_CONDITIONAL([HAVE_GHC], [test "$GHC"])
+
diff --git a/sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch b/sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch
new file mode 100644
index 000000000000..c2cc35c31d98
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.6-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ ParseAligns/abyss-fixmate.cc | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/ParseAligns/abyss-fixmate.cc b/ParseAligns/abyss-fixmate.cc
+index 1a169cf..36cc05b 100644
+--- a/ParseAligns/abyss-fixmate.cc
++++ b/ParseAligns/abyss-fixmate.cc
+@@ -16,6 +16,7 @@
+ #include <iterator>
+ #include <sstream>
+ #include <string>
++#include <unistd.h>
+
+ using namespace std;
+