summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-09-13 14:07:34 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-09-13 14:07:34 +0000
commitdd54e6ed9624ec0a424ea1e8c1d2ed8e2670efb1 (patch)
treede736fe5d242c76a252123ceaf215565af2ca78d /sci-biology/aaindex/aaindex-9.1.ebuild
parentMark 1.19.2-r1 stable on ia64. #146509 (diff)
downloadgentoo-2-dd54e6ed9624ec0a424ea1e8c1d2ed8e2670efb1.tar.gz
gentoo-2-dd54e6ed9624ec0a424ea1e8c1d2ed8e2670efb1.tar.bz2
gentoo-2-dd54e6ed9624ec0a424ea1e8c1d2ed8e2670efb1.zip
New upstream version
(Portage version: 2.1.1)
Diffstat (limited to 'sci-biology/aaindex/aaindex-9.1.ebuild')
-rw-r--r--sci-biology/aaindex/aaindex-9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/aaindex/aaindex-9.1.ebuild b/sci-biology/aaindex/aaindex-9.1.ebuild
new file mode 100644
index 000000000000..0e5cc7bf5b65
--- /dev/null
+++ b/sci-biology/aaindex/aaindex-9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/aaindex-9.1.ebuild,v 1.1 2006/09/13 14:07:34 ribosome Exp $
+
+DESCRIPTION="Amino acid indices and similarity matrices"
+LICENSE="public-domain"
+HOMEPAGE="http://www.genome.ad.jp/aaindex"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+src_compile() {
+ if use emboss; then
+ mkdir AAINDEX
+ echo
+ einfo "Indexing AAindex for usage with EMBOSS."
+ EMBOSS_DATA="." aaindexextract -auto -infile ${PN}1 || die \
+ "Indexing AAindex failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins ${PN}{1,2,3} || die "Failed to install raw database."
+ fi
+ dodoc ${PN}.doc || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/AAINDEX
+ doins AAINDEX/* || die "Failed to install EMBOSS data files."
+ fi
+}