summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-07 08:02:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-07 08:02:50 +0000
commitff0e3cc87ddef672119935019602e6ce1a6e8213 (patch)
tree2b758afbb53878bdc1b0c2ba6d740c3ad2e9017a /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-ff0e3cc87ddef672119935019602e6ce1a6e8213.tar.gz
gentoo-2-ff0e3cc87ddef672119935019602e6ce1a6e8213.tar.bz2
gentoo-2-ff0e3cc87ddef672119935019602e6ce1a6e8213.zip
Include zlib.h for Z_BEST_COMPRESSION (required by libpng15 porting) wrt #355079 by Lars Wendler
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog7
-rw-r--r--sci-astronomy/celestia/celestia-1.6.1.ebuild4
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch14
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 52ca901974b8..7472fdf1b658 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.72 2011/08/04 18:27:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.73 2011/08/07 08:02:49 ssuominen Exp $
+
+ 07 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> celestia-1.6.1.ebuild,
+ +files/celestia-1.6.1-libpng15.patch:
+ Include zlib.h for Z_BEST_COMPRESSION (required by libpng15 porting) wrt
+ #355079 by Lars Wendler
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/celestia/celestia-1.6.1.ebuild b/sci-astronomy/celestia/celestia-1.6.1.ebuild
index 2ac03027cd31..e21212e0868f 100644
--- a/sci-astronomy/celestia/celestia-1.6.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.2 2011/07/16 17:47:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.3 2011/08/07 08:02:49 ssuominen Exp $
EAPI=2
@@ -60,6 +60,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-gcc46.patch
# underlinking fix with USE="-gnome -gtk"
epatch "${FILESDIR}"/${P}-gold.patch
+ # missing zlib.h include with libpng15
+ epatch "${FILESDIR}"/${P}-libpng15.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch b/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch
new file mode 100644
index 000000000000..5dffbab246ef
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch
@@ -0,0 +1,14 @@
+imagecapture.cpp:184:40: error: ‘Z_BEST_COMPRESSION’ was not declared in this scope
+
+--- src/celestia/imagecapture.cpp
++++ src/celestia/imagecapture.cpp
+@@ -31,6 +31,9 @@
+ #include "png.h"
+ #endif
+
++// Z_BEST_COMPRESSION
++#include <zlib.h>
++
+ // Define png_jmpbuf() in case we are using a pre-1.0.6 version of libpng
+ #ifndef png_jmpbuf
+ #define png_jmpbuf(png_ptr) png_ptr->jmpbuf