summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-24 04:37:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-24 04:37:19 +0000
commitddef7e5f0e24fb45e440180adb1edd7ab1d5993c (patch)
tree0124d5ba5ca02d6812f6ebe6293ece72bbc1b50d /sci-astronomy
parentBug #331753 - Add missing dependency on openssl-0.9.8*. (diff)
downloadgentoo-2-ddef7e5f0e24fb45e440180adb1edd7ab1d5993c.tar.gz
gentoo-2-ddef7e5f0e24fb45e440180adb1edd7ab1d5993c.tar.bz2
gentoo-2-ddef7e5f0e24fb45e440180adb1edd7ab1d5993c.zip
Version bump
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/swarp/ChangeLog7
-rw-r--r--sci-astronomy/swarp/swarp-2.19.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sci-astronomy/swarp/ChangeLog b/sci-astronomy/swarp/ChangeLog
index 7a8c730d93e1..6f35b41ac427 100644
--- a/sci-astronomy/swarp/ChangeLog
+++ b/sci-astronomy/swarp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/swarp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/ChangeLog,v 1.4 2010/06/08 20:22:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/ChangeLog,v 1.5 2010/09/24 04:37:19 bicatali Exp $
+
+*swarp-2.19.1 (24 Sep 2010)
+
+ 24 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> +swarp-2.19.1.ebuild:
+ Version bump
08 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org> swarp-2.17.6.ebuild,
+files/swarp-nodoc.patch:
diff --git a/sci-astronomy/swarp/swarp-2.19.1.ebuild b/sci-astronomy/swarp/swarp-2.19.1.ebuild
new file mode 100644
index 000000000000..e48542cb1aeb
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.19.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/swarp-2.19.1.ebuild,v 1.1 2010/09/24 04:37:19 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://astromatic.iap.fr/software/swarp"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nodoc.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/* || die
+ fi
+}