summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-05-03 16:52:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-05-03 16:52:50 +0000
commitd7a2a663ff6628ae5c92df905e4ff077c6a42037 (patch)
treebe97cf8e54e5eb24a77e86040ec01c77f5fd10a3 /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-d7a2a663ff6628ae5c92df905e4ff077c6a42037.tar.gz
gentoo-2-d7a2a663ff6628ae5c92df905e4ff077c6a42037.tar.bz2
gentoo-2-d7a2a663ff6628ae5c92df905e4ff077c6a42037.zip
Version bump
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/ChangeLog9
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index 28346b5e8ce7..1f3b2cc5f828 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/pyephem
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.10 2010/05/26 15:34:44 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.11 2011/05/03 16:52:50 bicatali Exp $
+
+*pyephem-3.7.4.1 (03 May 2011)
+
+ 03 May 2011; Sébastien Fabbro <bicatali@gentoo.org> +pyephem-3.7.4.1.ebuild:
+ Version bump
26 May 2010; Kacper Kowalik <xarthisius@gentoo.org>
pyephem-3.7.3.4.ebuild:
diff --git a/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild b/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild
new file mode 100644
index 000000000000..29e2f701fbf8
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild,v 1.1 2011/05/03 16:52:50 bicatali Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+DESCRIPTION="Astronomical routines for the python programming language"
+LICENSE="LGPL-3"
+HOMEPAGE="http://rhodesmill.org/pyephem/pyephem.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+src_prepare() {
+ # don't install rst files
+ sed -i -e "s:'doc/\*\.rst',::" "${S}"/setup.py || die
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd src/ephem/doc
+ PYTHONPATH=../../.. emake html || die "Building of documentation failed"
+ fi
+}
+
+src_test() {
+ # remove a buggy test (it's a doc test), check next version.
+ mv src/ephem/tests/test_rst.py{,orig}
+ distutils_src_test
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r src/ephem/doc/.build/html/* || die "Installation of documentation failed"
+ fi
+}