summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-12 22:44:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-12 22:44:20 +0000
commitc66a295cff5742446c270a3bb5e11236ecf21875 (patch)
tree9d1396ca7955c138bc4b4932612230a40cb33c65 /sci-astronomy
parentmark ~amd64 after applying patch from David Watzke; bug 156144 (diff)
downloadgentoo-2-c66a295cff5742446c270a3bb5e11236ecf21875.tar.gz
gentoo-2-c66a295cff5742446c270a3bb5e11236ecf21875.tar.bz2
gentoo-2-c66a295cff5742446c270a3bb5e11236ecf21875.zip
celestia-1.4.1-r2 with a bunch of fixes
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog13
-rw-r--r--sci-astronomy/celestia/celestia-1.4.1-r2.ebuild (renamed from sci-astronomy/celestia/celestia-1.4.1-r1.ebuild)58
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-3dsmodels.patch14
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-as-needed.patch10
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch18
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-locale.patch203
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch12
-rw-r--r--sci-astronomy/celestia/files/digest-celestia-1.4.1-r2 (renamed from sci-astronomy/celestia/files/digest-celestia-1.4.1-r1)0
8 files changed, 290 insertions, 38 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 4d47859d295b..cc560f7eeda8 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.27 2007/02/06 10:18:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.28 2007/02/12 22:44:20 bicatali Exp $
+
+*celestia-1.4.1-r2 (12 Feb 2007)
+
+ 12 Feb 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/celestia-1.4.1-3dsmodels.patch,
+ +files/celestia-1.4.1-as-needed.patch,
+ files/celestia-1.4.1-kde-datadir.patch,
+ +files/celestia-1.4.1-locale.patch, files/celestia-1.4.1-lua51.patch,
+ -celestia-1.4.1-r1.ebuild, +celestia-1.4.1-r2.ebuild:
+ Fix for bug #130091 (real this time), bug #166362. Cleaned the ebuild
+ and removed older buggy revision.
06 Feb 2007; Sébastien Fabbro <bicatali@gentoo.org>
-files/celestia-1.4.1-lua.patch, celestia-1.4.1-r1.ebuild:
diff --git a/sci-astronomy/celestia/celestia-1.4.1-r1.ebuild b/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild
index 4cdc86afff66..9f8b21bc29ec 100644
--- a/sci-astronomy/celestia/celestia-1.4.1-r1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.1-r1.ebuild,v 1.3 2007/02/06 10:18:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild,v 1.1 2007/02/12 22:44:20 bicatali Exp $
-#WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="1.9"
inherit eutils flag-o-matic gnome2 kde-functions autotools
-DESCRIPTION="Space 3D simulator"
+DESCRIPTION="OpenGL 3D space simulator"
HOMEPAGE="http://www.shatters.net/celestia/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -65,36 +64,49 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
+
# some lua patches to make it work for lua-5.1
has_version ">=dev-lang/lua-5.1.1" && \
epatch "${FILESDIR}/${P}-lua51.patch"
- cd "${S}"
+
# standard set of gcc-4.1 patches
epatch "${FILESDIR}/${P}-gcc-4.1.patch"
+
# fix kde datadir in makefile.am and .desktop location
epatch "${FILESDIR}/${P}-kde-datadir.patch"
+
# add a ~/.celestia for extra directories
epatch "${FILESDIR}/${P}-cfg.patch"
- # strict aliasing from mandriva
+
+ # strict aliasing from fedora
epatch "${FILESDIR}/${P}-strictalias.patch"
- # remove agressive flags to let the user decide
- sed -i \
- -e 's/-ffast-math -fexpensive-optimizations//g' \
- configure.in || die "sed failed"
+ # install 3ds models by requests
+ epatch "${FILESDIR}/${P}-3dsmodels.patch"
+
+ # fix po/Makefile.in.in to regenerate
+ epatch "${FILESDIR}/${P}-locale.patch"
- # remove an unused gconf macro killing autoconf
+ # fix for as-needed (bug #130091)
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # remove flags to let the user decide
+ for cf in -O2 -ffast-math \
+ -fexpensive-optimizations \
+ -fomit-frame-pointer; do
+ sed -i \
+ -e "s/${cf}//g" \
+ configure.in || die "sed failed"
+ done
+
+ # remove an unused gconf macro killing autoconf when no gnome
if ! use gnome; then
sed -i \
-e '/AM_GCONF_SOURCE_2/d' \
configure.in || die "sed failed"
fi
- # nasty hack for gettext generated file
- sed -i \
- -e 's:@MKINSTALLDIRS@:$(top_builddir)/admin/mkinstalldirs:' \
- po/Makefile.in.in || die "sed failed"
-
eautoreconf
}
@@ -103,7 +115,7 @@ src_compile() {
if [[ "${mygui}" == "kde" ]]; then
set-kdedir 3
set-qtdir 3
- export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
+ export kde_widgetdir="${KDEDIR}/lib/kde3/plugins/designer"
fi
addwrite ${QTDIR}/etc/settings
@@ -123,22 +135,16 @@ src_compile() {
}
src_install() {
- #dodir /usr/share/celestia
if [[ "${mygui}" == "gnome" ]]; then
gnome2_src_install
else
- #einstall || die "einstall failed"
emake DESTDIR="${D}" install || die "emake install failed"
for size in 16 22 32 48 ; do
- insinto /usr/share/icons/hicolor/${size}x${size}/apps/
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
newins ${S}/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
done
fi
- dodoc AUTHORS README TODO NEWS TRANSLATORS ChangeLog \
- CelestiaKeyAssignments.txt KbdMouseJoyControls.txt devguide.txt
- dohtml coding-standards.html manual/*.html manual/*.css
- insinto /usr/share/celestia/models/
- for m in models/*.3ds; do
- doins ${m}
- done
+ dodoc AUTHORS README TODO NEWS TRANSLATORS *.txt
+ dohtml coding-standards.html
+ dosym "${PORTDIR}"/licenses/GPL-2 /usr/share/${PN}/COPYING
}
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-3dsmodels.patch b/sci-astronomy/celestia/files/celestia-1.4.1-3dsmodels.patch
new file mode 100644
index 000000000000..d7287c69680f
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-3dsmodels.patch
@@ -0,0 +1,14 @@
+--- models/Makefile.am 2006-02-02 04:12:26.000000000 +0000
++++ models/Makefile.am.new 2007-02-12 14:20:19.000000000 +0000
+@@ -3,8 +3,8 @@
+ pkgdata_DATA = \
+ $(wildcard *.cms) \
+ $(wildcard *.cmod) \
+- $(wildcard *.pts)
++ $(wildcard *.pts) \
++ $(wildcard *.3ds)
+
+ EXTRA_DIST = \
+- $(pkgdata_DATA) \
+- $(wildcard *.3ds)
++ $(pkgdata_DATA)
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-as-needed.patch b/sci-astronomy/celestia/files/celestia-1.4.1-as-needed.patch
new file mode 100644
index 000000000000..e9ab3faacd7b
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-as-needed.patch
@@ -0,0 +1,10 @@
+--- src/celestia/Makefile.am 2006-01-16 02:05:25.000000000 +0000
++++ src/celestia/Makefile.am.new 2007-02-12 21:23:56.000000000 +0000
+@@ -11,6 +11,7 @@
+ celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
+ $(LIBSOCKET) kde/libkdegui.a
+ celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
++LIBS += $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE)
+ endif
+
+ if ENABLE_GTK
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch b/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch
index 48912f2e2c15..8b4edc9663bb 100644
--- a/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch
@@ -1,26 +1,34 @@
diff -Nur ../celestia-1.4.1.orig/Makefile.am ./Makefile.am
--- ../celestia-1.4.1.orig/Makefile.am 2006-02-03 18:04:33.000000000 +0000
-+++ ./Makefile.am 2007-02-03 12:46:33.000000000 +0000
-@@ -66,11 +66,11 @@
++++ ./Makefile.am 2007-02-12 19:49:21.000000000 +0000
+@@ -15,7 +15,6 @@
+ pkgdata_DATA = \
+ celestia.cfg \
+ controls.txt \
+- COPYING \
+ $(wildcard *.cel)
+
+ EXTRA_DIST = \
+@@ -66,11 +65,11 @@
)
install-data-hook:
- if [ "$(kde_datadir)" -a -d $(kde_datadir)/@PACKAGE@ -a ! -h $(kde_datadir)/@PACKAGE@ ] ; then \
- mv -f -b $(kde_datadir)/@PACKAGE@/* $(datadir)/@PACKAGE@/ ; \
- rmdir $(kde_datadir)/@PACKAGE@ ; \
-+ if [ "$(DESTDIR)$(kde_datadir)" -a -d $(DESTDIR)$(kde_datadir)/@PACKAGE@ -a ! -h $(DESTDIR)$(kde_datadir)/@PACKAGE@ ] ; then \
++ if [ -n "$(kde_datadir)" -a "$(DESTDIR)$(kde_datadir)" -a -d $(DESTDIR)$(kde_datadir)/@PACKAGE@ -a ! -h $(DESTDIR)$(kde_datadir)/@PACKAGE@ ] ; then \
+ mv -f -b $(DESTDIR)$(kde_datadir)/@PACKAGE@/* $(DESTDIR)$(datadir)/@PACKAGE@/ ; \
+ rmdir $(DESTDIR)$(kde_datadir)/@PACKAGE@ ; \
fi
- if [ "$(kde_datadir)" -a ! -h $(kde_datadir)/@PACKAGE@ ] ; then \
- ln -s $(datadir)/@PACKAGE@ $(kde_datadir)/@PACKAGE@ ; \
-+ if [ "$(DESTDIR)$(kde_datadir)" -a ! -h $(DESTDIR)$(kde_datadir)/@PACKAGE@ ] ; then \
++ if [ -n "$(kde_datadir)" -a "$(DESTDIR)$(kde_datadir)" -a ! -h $(DESTDIR)$(kde_datadir)/@PACKAGE@ ] ; then \
+ ln -s $(datadir)/@PACKAGE@ $(DESTDIR)$(kde_datadir)/@PACKAGE@ ; \
fi
diff -Nur ../celestia-1.4.1.orig/src/celestia/kde/data/Makefile.am ./src/celestia/kde/data/Makefile.am
--- ../celestia-1.4.1.orig/src/celestia/kde/data/Makefile.am 2006-01-07 11:15:48.000000000 +0000
-+++ ./src/celestia/kde/data/Makefile.am 2007-02-03 12:49:04.000000000 +0000
++++ ./src/celestia/kde/data/Makefile.am 2007-02-12 19:26:45.000000000 +0000
@@ -14,7 +14,7 @@
mimedir = $(kde_mimedir)/application
mime_DATA = x-celestia-script.desktop
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-locale.patch b/sci-astronomy/celestia/files/celestia-1.4.1-locale.patch
new file mode 100644
index 000000000000..f2340dd2ce72
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-locale.patch
@@ -0,0 +1,203 @@
+--- po/Makefile.in.in 2005-07-19 21:18:52.000000000 +0100
++++ po/Makefile.in.in.new 2007-02-12 17:51:55.000000000 +0000
+@@ -1,5 +1,5 @@
+ # Makefile for PO directory in any package using GNU gettext.
+-# Copyright (C) 1995-1997, 2000-2004 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
++# Copyright (C) 1995-1997, 2000-2006 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
+ #
+ # This file can be copied and used freely without restrictions. It can
+ # be used in projects which are not available under the GNU General Public
+@@ -8,10 +8,11 @@
+ # Please note that the actual code of GNU gettext is covered by the GNU
+ # General Public License and is *not* in the public domain.
+ #
+-# Origin: gettext-0.14
++# Origin: gettext-0.15
+
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
++PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+
+ SHELL = /bin/sh
+ @SET_MAKE@
+@@ -22,18 +23,28 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++datarootdir = @datarootdir@
+ datadir = @datadir@
+ localedir = $(datadir)/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = $(SHELL) @install_sh@ -d
++mkdir_p = @mkdir_p@
+
+-GMSGFMT = @GMSGFMT@
+-MSGFMT = @MSGFMT@
+-XGETTEXT = @XGETTEXT@
++GMSGFMT_ = @GMSGFMT@
++GMSGFMT_no = @GMSGFMT@
++GMSGFMT_yes = @GMSGFMT_015@
++GMSGFMT = $(GMSGFMT_$(USE_MSGCTXT))
++MSGFMT_ = @MSGFMT@
++MSGFMT_no = @MSGFMT@
++MSGFMT_yes = @MSGFMT_015@
++MSGFMT = $(MSGFMT_$(USE_MSGCTXT))
++XGETTEXT_ = @XGETTEXT@
++XGETTEXT_no = @XGETTEXT@
++XGETTEXT_yes = @XGETTEXT_015@
++XGETTEXT = $(XGETTEXT_$(USE_MSGCTXT))
+ MSGMERGE = msgmerge
+ MSGMERGE_UPDATE = @MSGMERGE@ --update
+ MSGINIT = msginit
+@@ -46,7 +57,7 @@
+ DUMMYPOFILES = @DUMMYPOFILES@
+ DISTFILES.common = Makefile.in.in remove-potcdate.sin \
+ $(DISTFILES.common.extra1) $(DISTFILES.common.extra2) $(DISTFILES.common.extra3)
+-DISTFILES = $(DISTFILES.common) Makevars POTFILES.in $(DOMAIN).pot stamp-po \
++DISTFILES = $(DISTFILES.common) Makevars POTFILES.in \
+ $(POFILES) $(GMOFILES) \
+ $(DISTFILES.extra1) $(DISTFILES.extra2) $(DISTFILES.extra3)
+
+@@ -79,6 +90,12 @@
+ all-yes: stamp-po
+ all-no:
+
++# $(srcdir)/$(DOMAIN).pot is only created when needed. When xgettext finds no
++# internationalized messages, no $(srcdir)/$(DOMAIN).pot is created (because
++# we don't want to bother translators with empty POT files). We assume that
++# LINGUAS is empty in this case, i.e. $(POFILES) and $(GMOFILES) are empty.
++# In this case, stamp-po is a nop (i.e. a phony target).
++
+ # stamp-po is a timestamp denoting the last time at which the CATALOGS have
+ # been loosely updated. Its purpose is that when a developer or translator
+ # checks out the package via CVS, and the $(DOMAIN).pot file is not in CVS,
+@@ -88,10 +105,13 @@
+ # $(POFILES) has been designed to not touch files that don't need to be
+ # changed.
+ stamp-po: $(srcdir)/$(DOMAIN).pot
+- test -z "$(GMOFILES)" || $(MAKE) $(GMOFILES)
+- @echo "touch stamp-po"
+- @echo timestamp > stamp-poT
+- @mv stamp-poT stamp-po
++ test ! -f $(srcdir)/$(DOMAIN).pot || \
++ test -z "$(GMOFILES)" || $(MAKE) $(GMOFILES)
++ @test ! -f $(srcdir)/$(DOMAIN).pot || { \
++ echo "touch stamp-po" && \
++ echo timestamp > stamp-poT && \
++ mv stamp-poT stamp-po; \
++ }
+
+ # Note: Target 'all' must not depend on target '$(DOMAIN).pot-update',
+ # otherwise packages like GCC can not be built if only parts of the source
+@@ -100,11 +120,16 @@
+ # This target rebuilds $(DOMAIN).pot; it is an expensive operation.
+ # Note that $(DOMAIN).pot is not touched if it doesn't need to be changed.
+ $(DOMAIN).pot-update: $(POTFILES) $(srcdir)/POTFILES.in remove-potcdate.sed
++ if test -n '$(MSGID_BUGS_ADDRESS)' || test '$(PACKAGE_BUGREPORT)' = '@'PACKAGE_BUGREPORT'@'; then \
++ msgid_bugs_address='$(MSGID_BUGS_ADDRESS)'; \
++ else \
++ msgid_bugs_address='$(PACKAGE_BUGREPORT)'; \
++ fi; \
+ $(XGETTEXT) --default-domain=$(DOMAIN) --directory=$(top_srcdir) \
+ --add-comments=TRANSLATORS: $(XGETTEXT_OPTIONS) \
+ --files-from=$(srcdir)/POTFILES.in \
+ --copyright-holder='$(COPYRIGHT_HOLDER)' \
+- --msgid-bugs-address='$(MSGID_BUGS_ADDRESS)'
++ --msgid-bugs-address="$$msgid_bugs_address"
+ test ! -f $(DOMAIN).po || { \
+ if test -f $(srcdir)/$(DOMAIN).pot; then \
+ sed -f remove-potcdate.sed < $(srcdir)/$(DOMAIN).pot > $(DOMAIN).1po && \
+@@ -143,7 +168,7 @@
+ install-exec:
+ install-data: install-data-@USE_NLS@
+ if test "$(PACKAGE)" = "gettext-tools"; then \
+- $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
++ $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
+ for file in $(DISTFILES.common) Makevars.template; do \
+ $(INSTALL_DATA) $(srcdir)/$$file \
+ $(DESTDIR)$(gettextsrcdir)/$$file; \
+@@ -156,13 +181,13 @@
+ fi
+ install-data-no: all
+ install-data-yes: all
+- $(mkinstalldirs) $(DESTDIR)$(datadir)
++ $(mkdir_p) $(DESTDIR)$(datadir)
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkinstalldirs) $(DESTDIR)$$dir; \
++ $(mkdir_p) $(DESTDIR)$$dir; \
+ if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
+ $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
+ echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
+@@ -202,19 +227,19 @@
+ installdirs-exec:
+ installdirs-data: installdirs-data-@USE_NLS@
+ if test "$(PACKAGE)" = "gettext-tools"; then \
+- $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
++ $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
+ else \
+ : ; \
+ fi
+ installdirs-data-no:
+ installdirs-data-yes:
+- $(mkinstalldirs) $(DESTDIR)$(datadir)
++ $(mkdir_p) $(DESTDIR)$(datadir)
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkinstalldirs) $(DESTDIR)$$dir; \
++ $(mkdir_p) $(DESTDIR)$$dir; \
+ for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
+ if test -n "$$lc"; then \
+ if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
+@@ -289,11 +314,14 @@
+ $(MAKE) update-po
+ @$(MAKE) dist2
+ # This is a separate target because 'update-po' must be executed before.
+-dist2: $(DISTFILES)
++dist2: stamp-po $(DISTFILES)
+ dists="$(DISTFILES)"; \
+ if test "$(PACKAGE)" = "gettext-tools"; then \
+ dists="$$dists Makevars.template"; \
+ fi; \
++ if test -f $(srcdir)/$(DOMAIN).pot; then \
++ dists="$$dists $(DOMAIN).pot stamp-po"; \
++ fi; \
+ if test -f $(srcdir)/ChangeLog; then \
+ dists="$$dists ChangeLog"; \
+ fi; \
+@@ -305,9 +333,9 @@
+ if test -f $(srcdir)/LINGUAS; then dists="$$dists LINGUAS"; fi; \
+ for file in $$dists; do \
+ if test -f $$file; then \
+- cp -p $$file $(distdir); \
++ cp -p $$file $(distdir) || exit 1; \
+ else \
+- cp -p $(srcdir)/$$file $(distdir); \
++ cp -p $(srcdir)/$$file $(distdir) || exit 1; \
+ fi; \
+ done
+
+@@ -354,10 +382,9 @@
+ update-gmo: Makefile $(GMOFILES)
+ @:
+
+-Makefile: Makefile.in.in $(top_builddir)/config.status @POMAKEFILEDEPS@
++Makefile: Makefile.in.in Makevars $(top_builddir)/config.status @POMAKEFILEDEPS@
+ cd $(top_builddir) \
+- && CONFIG_FILES=$(subdir)/$@.in CONFIG_HEADERS= \
+- $(SHELL) ./config.status
++ && $(SHELL) ./config.status $(subdir)/$@.in po-directories
+
+ force:
+
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch b/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch
index 7c02999116fe..e3933a0d6c7f 100644
--- a/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch
@@ -1,6 +1,6 @@
-diff -Nur celestia-1.4.1.orig/configure.in celestia-1.4.1/configure.in
---- celestia-1.4.1.orig/configure.in 2006-02-03 18:09:54.000000000 +0000
-+++ celestia-1.4.1/configure.in 2006-09-19 10:04:57.000000000 +0100
+diff -Nur ../celestia-1.4.1/configure.in ./configure.in
+--- ../celestia-1.4.1/configure.in 2006-02-03 18:09:54.000000000 +0000
++++ ./configure.in 2007-02-12 16:27:42.000000000 +0000
@@ -383,7 +383,7 @@
AC_MSG_CHECKING([whether to enable Celestia Extension Language])
if (test "$enable_lua" != "no"); then
@@ -10,9 +10,9 @@ diff -Nur celestia-1.4.1.orig/configure.in celestia-1.4.1/configure.in
if (test "$lua_includes" != "no"); then
CXXFLAGS="$CXXFLAGS -I$lua_includes"
-diff -Nur celestia-1.4.1.orig/src/celestia/celx.cpp celestia-1.4.1/src/celestia/celx.cpp
---- celestia-1.4.1.orig/src/celestia/celx.cpp 2006-01-07 00:01:51.000000000 +0000
-+++ celestia-1.4.1/src/celestia/celx.cpp 2006-09-19 10:05:06.000000000 +0100
+diff -Nur ../celestia-1.4.1/src/celestia/celx.cpp ./src/celestia/celx.cpp
+--- ../celestia-1.4.1/src/celestia/celx.cpp 2006-01-07 00:01:51.000000000 +0000
++++ ./src/celestia/celx.cpp 2007-02-12 16:27:42.000000000 +0000
@@ -32,9 +32,7 @@
#include "celx.h"
diff --git a/sci-astronomy/celestia/files/digest-celestia-1.4.1-r1 b/sci-astronomy/celestia/files/digest-celestia-1.4.1-r2
index b75d1f3ff9d0..b75d1f3ff9d0 100644
--- a/sci-astronomy/celestia/files/digest-celestia-1.4.1-r1
+++ b/sci-astronomy/celestia/files/digest-celestia-1.4.1-r2