summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-04 22:57:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-04 22:57:51 +0000
commitb4d5b0db13101c812c273f95aef144dd90e03120 (patch)
tree9c72dc7844bf0af07add91191abfc9cace59af77 /sci-astronomy
parentAdd missing multilib inherit. (diff)
downloadgentoo-2-b4d5b0db13101c812c273f95aef144dd90e03120.tar.gz
gentoo-2-b4d5b0db13101c812c273f95aef144dd90e03120.tar.bz2
gentoo-2-b4d5b0db13101c812c273f95aef144dd90e03120.zip
Version bump
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/esorex/ChangeLog11
-rw-r--r--sci-astronomy/esorex/esorex-3.9.6.ebuild (renamed from sci-astronomy/esorex/esorex-3.8.3-r1.ebuild)23
-rw-r--r--sci-astronomy/esorex/files/esorex-3.8.3-cfitsio.patch37
-rw-r--r--sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch20
4 files changed, 39 insertions, 52 deletions
diff --git a/sci-astronomy/esorex/ChangeLog b/sci-astronomy/esorex/ChangeLog
index eaf2f78547ba..a6ca631e90ae 100644
--- a/sci-astronomy/esorex/ChangeLog
+++ b/sci-astronomy/esorex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/esorex
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/ChangeLog,v 1.4 2011/08/04 18:30:14 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/ChangeLog,v 1.5 2012/06/04 22:57:51 bicatali Exp $
+
+*esorex-3.9.6 (04 Jun 2012)
+
+ 04 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> -esorex-3.8.3-r1.ebuild,
+ -files/esorex-3.8.3-cfitsio.patch, +esorex-3.9.6.ebuild,
+ +files/esorex-3.9.6-use-shared-libs.patch:
+ Version bump
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/esorex/esorex-3.8.3-r1.ebuild b/sci-astronomy/esorex/esorex-3.9.6.ebuild
index 6c7267eb97c1..50bec7c66c5a 100644
--- a/sci-astronomy/esorex/esorex-3.8.3-r1.ebuild
+++ b/sci-astronomy/esorex/esorex-3.9.6.ebuild
@@ -1,33 +1,30 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/esorex-3.8.3-r1.ebuild,v 1.2 2011/02/24 17:25:03 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/esorex-3.9.6.ebuild,v 1.1 2012/06/04 22:57:51 bicatali Exp $
-EAPI=2
+EAPI=4
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
HOMEPAGE="http://www.eso.org/sci/software/cpl/esorex.html"
-SRC_URI="ftp://ftp.eso.org/pub/cpl/${P}.tar.gz"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND=">=sci-astronomy/cpl-5.2"
+DEPEND=">=sci-astronomy/cpl-6"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cfitsio.patch
- eautoreconf
-}
+PATCHES=( "${FILESDIR}"/${P}-use-shared-libs.patch )
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README AUTHORS NEWS TODO BUGS ChangeLog || die
+ autotools-utils_src_install
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r examples || die
+ doins -r examples
fi
}
diff --git a/sci-astronomy/esorex/files/esorex-3.8.3-cfitsio.patch b/sci-astronomy/esorex/files/esorex-3.8.3-cfitsio.patch
deleted file mode 100644
index 0bc1b7f763c8..000000000000
--- a/sci-astronomy/esorex/files/esorex-3.8.3-cfitsio.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Use pkg-config for cfitsio
-
-http://bugs.gentoo.org/show_bug.cgi?id=339460
-
---- configure.ac
-+++ configure.ac
-@@ -69,7 +69,7 @@
- ESOREX_FUNC_GETOPT
-
- # Check for CPL/CFITSIO presence and usability
--CPL_CHECK_CFITSIO
-+PKG_CHECK_MODULES([CFITSIO], [cfitsio >= 3.09])
- #CPL_CHECK_CEXT
- CPL_CHECK_LIBS
- ESO_CHECK_EXTRA_LIBS
---- src/Makefile.am
-+++ src/Makefile.am
-@@ -33,7 +33,7 @@
-
- CPPFLAGS = -DCX_LOG_DOMAIN=\"EsoRex\"
-
--INCLUDES = $(CFITSIO_INCLUDES) $(CPL_INCLUDES) $(CX_INCLUDES) $(INCLTDL)
-+INCLUDES = $(CFITSIO_CFLAGS) $(CPL_INCLUDES) $(CX_INCLUDES) $(INCLTDL)
-
- noinst_HEADERS = er_fileutils.h er_help.h er_main.h er_params.h \
- er_paramutils.h er_plugin.h er_pluginlist.h \
-@@ -51,8 +51,8 @@
-
- config_DATA =
-
--esorex_LDFLAGS = $(CPL_LDFLAGS) $(CFITSIO_LDFLAGS) $(LIBLTDL)
--esorex_LDADD = @GETOPT@ $(LIBCPLUI) $(LIBCPLDFS) $(LIBLTDL)
-+esorex_LDFLAGS = $(CPL_LDFLAGS) $(LIBLTDL)
-+esorex_LDADD = @GETOPT@ $(CFITSIO_LIBS) $(LIBCPLUI) $(LIBCPLDFS) $(LIBLTDL)
- esorex_DEPENDENCIES = @GETOPT@ $(LIBLTDL)
-
- if PURIFY
diff --git a/sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch b/sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch
new file mode 100644
index 000000000000..0cd348eaa446
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch
@@ -0,0 +1,20 @@
+--- esorex-3.9.6/m4/cpl.m4.orig 2012-06-04 23:47:50.000000000 +0100
++++ esorex-3.9.6/m4/cpl.m4 2012-06-04 23:48:45.000000000 +0100
+@@ -455,7 +455,7 @@
+ AC_MSG_CHECKING([for libcext])
+
+ cpl_cext_check_header="cxtypes.h"
+- cpl_cext_check_lib="libcext.a"
++ cpl_cext_check_lib="libcext.so"
+
+ cpl_cext_incdirs=""
+ cpl_cext_libdirs=""
+@@ -1314,7 +1314,7 @@
+ AC_MSG_CHECKING([for CPL])
+
+ cpl_check_cpl_header="cpl.h"
+- cpl_check_cpl_lib="libcplcore.a"
++ cpl_check_cpl_lib="libcplcore.so"
+
+ cpl_incdirs=""
+ cpl_libdirs=""