summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-05 22:35:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-05 22:35:34 +0000
commitb240f8dab6b8b63c34e98326f40d0baf2d786ff0 (patch)
tree08cbd8908874fb4ec987499bd1c06fbf14c044b0 /sci-astronomy
parentFix libcmis version (diff)
downloadgentoo-2-b240f8dab6b8b63c34e98326f40d0baf2d786ff0.tar.gz
gentoo-2-b240f8dab6b8b63c34e98326f40d0baf2d786ff0.tar.bz2
gentoo-2-b240f8dab6b8b63c34e98326f40d0baf2d786ff0.zip
Version bump. Now adds the data package
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/casacore/ChangeLog9
-rw-r--r--sci-astronomy/casacore/casacore-1.5.0.ebuild (renamed from sci-astronomy/casacore/casacore-1.3.0.ebuild)35
-rw-r--r--sci-astronomy/casacore/files/1.5.0-gcc47.patch22
-rw-r--r--sci-astronomy/casacore/files/1.5.0-sysdep.patch17
-rw-r--r--sci-astronomy/casacore/metadata.xml17
5 files changed, 84 insertions, 16 deletions
diff --git a/sci-astronomy/casacore/ChangeLog b/sci-astronomy/casacore/ChangeLog
index 47318f9c2e60..114dd6719096 100644
--- a/sci-astronomy/casacore/ChangeLog
+++ b/sci-astronomy/casacore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/casacore
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/casacore/ChangeLog,v 1.3 2012/05/11 21:51:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/casacore/ChangeLog,v 1.4 2012/06/05 22:35:34 bicatali Exp $
+
+*casacore-1.5.0 (05 Jun 2012)
+
+ 05 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/1.5.0-gcc47.patch, +files/1.5.0-sysdep.patch, -casacore-1.3.0.ebuild,
+ +casacore-1.5.0.ebuild, metadata.xml:
+ Version bump. Now adds the data package
*casacore-1.4.0 (11 May 2012)
diff --git a/sci-astronomy/casacore/casacore-1.3.0.ebuild b/sci-astronomy/casacore/casacore-1.5.0.ebuild
index 7c13257579cf..241e0d654267 100644
--- a/sci-astronomy/casacore/casacore-1.3.0.ebuild
+++ b/sci-astronomy/casacore/casacore-1.5.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/casacore/casacore-1.3.0.ebuild,v 1.3 2012/05/11 21:51:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/casacore/casacore-1.5.0.ebuild,v 1.1 2012/06/05 22:35:34 bicatali Exp $
EAPI=4
-inherit cmake-utils eutils
+inherit cmake-utils eutils toolchain-funcs fortran-2
DESCRIPTION="Core libraries for the Common Astronomy Software Applications"
HOMEPAGE="http://code.google.com/p/casacore/"
@@ -13,30 +13,47 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="doc fftw hdf5 threads test"
+IUSE="+data doc fftw hdf5 openmp threads test"
RDEPEND="sci-libs/cfitsio
sci-astronomy/wcslib
+ sys-libs/readline
virtual/blas
+ virtual/fortran
virtual/lapack
- sys-libs/readline
- hdf5? ( sci-libs/hdf5 )
- fftw? ( >=sci-libs/fftw-3 )"
+ data? ( sci-astronomy/casa-data )
+ fftw? ( >=sci-libs/fftw-3 )
+ hdf5? ( sci-libs/hdf5 )"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+ test? ( sci-astronomy/casa-data )"
-PATCHES=( "${FILESDIR}"/${PV}-{headers,implicits,libdir}.patch )
+PATCHES=(
+ "${FILESDIR}"/1.3.0-implicits.patch
+ "${FILESDIR}"/1.3.0-libdir.patch
+ "${FILESDIR}"/1.5.0-sysdep.patch
+ "${FILESDIR}"/1.5.0-gcc47.patch
+)
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc but without OpenMP capabilities"
+ die "Need an OpenMP capable compiler"
+ fi
+ fortran-2_pkg_setup
+}
src_configure() {
has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
mycmakeargs+=(
-DENABLE_SHARED=ON
- -DCMAKE_SKIP_RPATH=ON
+ -DDATA_DIR="${EPREFIX}/usr/share/casa/data"
$(cmake-utils_use_build test TESTING)
$(cmake-utils_use_use fftw FFTW3)
$(cmake-utils_use_use hdf5 HDF5)
$(cmake-utils_use_use threads THREADS)
+ $(cmake-utils_use_use openmp OPENMP)
)
cmake-utils_src_configure
}
diff --git a/sci-astronomy/casacore/files/1.5.0-gcc47.patch b/sci-astronomy/casacore/files/1.5.0-gcc47.patch
new file mode 100644
index 000000000000..30295d8d0701
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.5.0-gcc47.patch
@@ -0,0 +1,22 @@
+diff -Nur casacore-1.5.0.orig/casa/Arrays/IPosition.h casacore-1.5.0/casa/Arrays/IPosition.h
+--- casacore-1.5.0.orig/casa/Arrays/IPosition.h 2012-03-14 14:30:48.000000000 +0000
++++ casacore-1.5.0/casa/Arrays/IPosition.h 2012-06-05 22:07:39.000000000 +0100
+@@ -34,6 +34,7 @@
+ #include <casa/BasicSL/String.h>
+ #include <vector>
+ #include <cstddef> // for ptrdiff_t
++#include <unistd.h> // for ssize_t
+
+ namespace casa { //# NAMESPACE CASA - BEGIN
+
+diff -Nur casacore-1.5.0.orig/casa/System/Casarc.cc casacore-1.5.0/casa/System/Casarc.cc
+--- casacore-1.5.0.orig/casa/System/Casarc.cc 2011-10-18 08:39:05.000000000 +0100
++++ casacore-1.5.0/casa/System/Casarc.cc 2012-06-05 22:11:31.000000000 +0100
+@@ -34,6 +34,7 @@
+ #include <fcntl.h>
+ #include <sys/mman.h>
+ #include <cstdio>
++#include <unistd.h>
+
+ #define USE_FLOCK 0
+ #define CASARC_DEBUG 0
diff --git a/sci-astronomy/casacore/files/1.5.0-sysdep.patch b/sci-astronomy/casacore/files/1.5.0-sysdep.patch
new file mode 100644
index 000000000000..35eef56daf08
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.5.0-sysdep.patch
@@ -0,0 +1,17 @@
+--- casacore-1.5.0/mirlib/sysdep.h.orig 2012-06-05 05:35:29.000000000 +0100
++++ casacore-1.5.0/mirlib/sysdep.h 2012-06-05 05:37:07.000000000 +0100
+@@ -28,7 +28,8 @@
+ * removed 'trace' clutter from the old multiflow
+ * pjt 24jun01 PPC/powerpc is a BIGENDIAN (linux) machine
+ */
+-
++#ifndef MIRIAD_SYSDEP_H
++#define MIRIAD_SYSDEP_H
+ #ifndef Null
+ #define Null '\0'
+ #endif
+@@ -133,3 +134,4 @@
+ # define unpack32_c(a,b,c) memcpy((char *)(b),(a),sizeof(int)*(c))
+ #endif
+ #endif
++#endif /* MIRIAD_SYSDEP_H */
diff --git a/sci-astronomy/casacore/metadata.xml b/sci-astronomy/casacore/metadata.xml
index 5e6d69344baa..3f17c8233202 100644
--- a/sci-astronomy/casacore/metadata.xml
+++ b/sci-astronomy/casacore/metadata.xml
@@ -1,11 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-astronomy</herd>
- <longdescription lang="en">A set of libraries for the the Common Astronomy Software
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ A set of libraries for the the Common Astronomy Software
Applications for radioastronomy. This project contains C++ libraries
- which were the code of the discontinued AIPS++ package.</longdescription>
- <upstream>
- <remote-id type="google-code">casacore</remote-id>
- </upstream>
+ which were the code of the discontinued AIPS++ package.
+</longdescription>
+<upstream>
+ <remote-id type="google-code">casacore</remote-id>
+</upstream>
+<use>
+ <flag name="data">Installs measures and data (pulls <pkg>sci-astronomy/casa-data</pkg>)</flag>
+</use>
</pkgmetadata>