summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-26 12:06:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-26 12:06:17 +0000
commit9cf7b4fc98b407c75c8c7f2c635a2b6b5b923285 (patch)
treeb0cda2c20991499468c14d4fc41be0b6ee2f9ddd /sci-astronomy
parentalpha/sparc stable wrt #221197 (diff)
downloadgentoo-2-9cf7b4fc98b407c75c8c7f2c635a2b6b5b923285.tar.gz
gentoo-2-9cf7b4fc98b407c75c8c7f2c635a2b6b5b923285.tar.bz2
gentoo-2-9cf7b4fc98b407c75c8c7f2c635a2b6b5b923285.zip
Version bump. No more examples.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/ChangeLog8
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.2.4.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index f942d954fbe1..d640abe90cae 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/pyephem
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.5 2008/01/29 12:59:56 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.6 2008/06/26 12:06:17 bicatali Exp $
+
+*pyephem-3.7.2.4 (26 Jun 2008)
+
+ 26 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +pyephem-3.7.2.4.ebuild:
+ Version bump. No more examples.
*pyephem-3.7.2.3 (29 Jan 2008)
diff --git a/sci-astronomy/pyephem/pyephem-3.7.2.4.ebuild b/sci-astronomy/pyephem/pyephem-3.7.2.4.ebuild
new file mode 100644
index 000000000000..a4ad417111ff
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7.2.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.2.4.ebuild,v 1.1 2008/06/26 12:06:17 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="Astronomical routines for the python programming language"
+LICENSE="LGPL-3"
+HOMEPAGE="http://rhodesmill.org/pyephem/pyephem.html"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+
+src_test() {
+ # remove a buggy test (it's a doc test), check next version.
+ mv src/ephem/tests/test_rst.py{,orig}
+ ${python} setup.py test || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ mv "${D}"/usr/lib*/${python}*/site-packages/ephem/doc \
+ "${D}"/usr/share/doc/${PF}/html || die "Failed to install doc"
+}