summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2013-06-18 17:50:18 +0000
committerJosé María Alonso <nimiux@gentoo.org>2013-06-18 17:50:18 +0000
commit87b0b6d12b0b24efe19e9916a9795aff90f68182 (patch)
tree9835734b072680481e9cf7f7ad4391e41e27ee1e /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-87b0b6d12b0b24efe19e9916a9795aff90f68182.tar.gz
gentoo-2-87b0b6d12b0b24efe19e9916a9795aff90f68182.tar.bz2
gentoo-2-87b0b6d12b0b24efe19e9916a9795aff90f68182.zip
Add earthtrack patch wrt bug 472686
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/predict/ChangeLog6
-rw-r--r--sci-astronomy/predict/files/predict-2.2.3-earthtrack.patch27
-rw-r--r--sci-astronomy/predict/predict-2.2.3-r1.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/sci-astronomy/predict/ChangeLog b/sci-astronomy/predict/ChangeLog
index 39b01cbda0e9..73331cbdb116 100644
--- a/sci-astronomy/predict/ChangeLog
+++ b/sci-astronomy/predict/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/predict
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.18 2013/06/11 17:38:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.19 2013/06/18 17:50:17 nimiux Exp $
+
+ 18 Jun 2013; Chema Alonso <nimiux@gentoo.org> predict-2.2.3-r1.ebuild,
+ +files/predict-2.2.3-earthtrack.patch:
+ Add earthtrack patch wrt bug 472686
11 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> predict-2.2.3-r1.ebuild:
Fixed earthtrack and cleaning, bug #472686 thanks Chema Alonso
diff --git a/sci-astronomy/predict/files/predict-2.2.3-earthtrack.patch b/sci-astronomy/predict/files/predict-2.2.3-earthtrack.patch
new file mode 100644
index 000000000000..65f18bf9512d
--- /dev/null
+++ b/sci-astronomy/predict/files/predict-2.2.3-earthtrack.patch
@@ -0,0 +1,27 @@
+diff -Nur a/clients/earthtrack/earthtrack.c b/clients/earthtrack/earthtrack.c
+--- a/clients/earthtrack/earthtrack.c 2013-06-08 20:03:55.629967192 +0200
++++ b/clients/earthtrack/earthtrack.c 2013-06-08 20:05:15.559966743 +0200
+@@ -495,11 +495,11 @@
+
+ fprintf(fd,"marker_file=%s\n",markerfile);
+ fprintf(fd,"arc_file=%s\n",greatarcfile);
+- fprintf(fd,"marker_font=/usr/local/share/xplanet/fonts/FreeMonoBold.ttf\n");
+- fprintf(fd,"\n## Your \"/usr/local/share/xplanet/config/default\" configuration file follows:\n\n");
++ fprintf(fd,"marker_font=/usr/share/xplanet/fonts/FreeMonoBold.ttf\n");
++ fprintf(fd,"\n## Your \"/usr/share/xplanet/config/default\" configuration file follows:\n\n");
+ fclose(fd);
+
+- x=AppendFile("/usr/local/share/xplanet/config/default",configfile);
++ x=AppendFile("/usr/share/xplanet/config/default",configfile);
+
+ if (x==1)
+ {
+@@ -509,7 +509,7 @@
+
+ if (x==2)
+ {
+- fprintf(stderr,"%c*** Error: Could not read \"/usr/local/share/xplanet/config/default\"\nIs xplanet installed?\n\n",7);
++ fprintf(stderr,"%c*** Error: Could not read \"/usr/share/xplanet/config/default\"\nIs xplanet installed?\n\n",7);
+ exit(-1);
+ }
+ }
diff --git a/sci-astronomy/predict/predict-2.2.3-r1.ebuild b/sci-astronomy/predict/predict-2.2.3-r1.ebuild
index 66a153a62a8f..648495fa29d6 100644
--- a/sci-astronomy/predict/predict-2.2.3-r1.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3-r1.ebuild,v 1.4 2013/06/11 17:38:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3-r1.ebuild,v 1.5 2013/06/18 17:50:17 nimiux Exp $
EAPI=4
@@ -26,6 +26,7 @@ RDEPEND="sys-libs/ncurses
DEPEND="${RDEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-earthtrack.patch
epatch -p1 "${WORKDIR}"/${DEB_P}-${DEB_PR}.diff
sed -i -e 's:predict\(.*\)/:predict-2.2.3\1/:g' \
debian/patches/140*.diff || die