summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-25 17:58:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-25 17:58:45 +0000
commit56958d5a8c6fcc6e6322139bae7b281b766320a4 (patch)
treeee31ca1d1bb5309d8ed470e949072a6a5264923a /sci-astronomy
parentInstall documentation. Run tests. Add ree18. (diff)
downloadgentoo-2-56958d5a8c6fcc6e6322139bae7b281b766320a4.tar.gz
gentoo-2-56958d5a8c6fcc6e6322139bae7b281b766320a4.tar.bz2
gentoo-2-56958d5a8c6fcc6e6322139bae7b281b766320a4.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ast/ChangeLog11
-rw-r--r--sci-astronomy/ast/ast-5.7.2.ebuild40
-rw-r--r--sci-astronomy/ast/files/5.7.2-as-needed.patch65
-rw-r--r--sci-astronomy/ast/files/5.7.2-no-emsrep.patch19
4 files changed, 133 insertions, 2 deletions
diff --git a/sci-astronomy/ast/ChangeLog b/sci-astronomy/ast/ChangeLog
index f5aab993ceb5..bcb9e977832d 100644
--- a/sci-astronomy/ast/ChangeLog
+++ b/sci-astronomy/ast/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/ast
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.13 2010/11/26 07:25:01 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.14 2011/07/25 17:58:44 bicatali Exp $
+
+*ast-5.7.2 (25 Jul 2011)
+
+ 25 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/5.7.2-as-needed.patch, +files/5.7.2-no-emsrep.patch,
+ +ast-5.7.2.ebuild:
+ Version bump
26 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org> ast-5.3.1-r1.ebuild:
Add blocker for x11-libs/libast wrt bug 277649. Cosmetics
diff --git a/sci-astronomy/ast/ast-5.7.2.ebuild b/sci-astronomy/ast/ast-5.7.2.ebuild
new file mode 100644
index 000000000000..077444641ab7
--- /dev/null
+++ b/sci-astronomy/ast/ast-5.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ast-5.7.2.ebuild,v 1.1 2011/07/25 17:58:44 bicatali Exp $
+
+EAPI=4
+inherit eutils versionator
+
+MYP=${PN}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="Library for handling World Coordinate Systems in astronomy"
+HOMEPAGE="http://starlink.jach.hawaii.edu/starlink/AST"
+SRC_URI="${HOMEPAGE}?action=AttachFile&do=get&target=${MYP}.tar.gz -> ${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs"
+RDEPEND="sci-libs/pgplot
+ !x11-libs/libast"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MYP}
+
+src_prepare() {
+ # dont patch/sed Makefile.am
+ # requires special upstream automake not shipped
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+ epatch "${FILESDIR}"/${PV}-no-emsrep.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"usr/{docs,help,manifests,news,share} || die
+ dodoc ast.news fac_1521_err
+ use doc && dodoc *.ps
+}
diff --git a/sci-astronomy/ast/files/5.7.2-as-needed.patch b/sci-astronomy/ast/files/5.7.2-as-needed.patch
new file mode 100644
index 000000000000..7419d9e21fb6
--- /dev/null
+++ b/sci-astronomy/ast/files/5.7.2-as-needed.patch
@@ -0,0 +1,65 @@
+--- Makefile.in.orig 2011-06-14 19:39:50.068268598 +0100
++++ Makefile.in 2011-06-14 20:29:20.498268485 +0100
+@@ -77,7 +77,20 @@
+ "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libast_la_LIBADD =
++libast_la_LIBADD = \
++ libast_err.la \
++ libast_ems.la \
++ libast_drama.la \
++ libast_grf3d.la \
++ libast_grf_2.0.la \
++ libast_grf_3.2.la \
++ libast_grf_5.6.la \
++ libast_pgplot.la \
++ libast_pgplot3d.la \
++ libast_pal.la \
++ libast_wcslib.la \
++ libast_levmar.la
++
+ am__objects_1 = libast_la-axis.lo libast_la-box.lo libast_la-c2f77.lo \
+ libast_la-channel.lo libast_la-circle.lo libast_la-cmpframe.lo \
+ libast_la-cmpmap.lo libast_la-cmpregion.lo \
+@@ -153,31 +166,31 @@
+ libast_err_la_LIBADD =
+ am_libast_err_la_OBJECTS = libast_err_la-err_null.lo
+ libast_err_la_OBJECTS = $(am_libast_err_la_OBJECTS)
+-libast_grf3d_la_LIBADD =
++libast_grf3d_la_DEPENDENCIES = libast_err.la
+ am_libast_grf3d_la_OBJECTS = libast_grf3d_la-grf3d.lo
+ libast_grf3d_la_OBJECTS = $(am_libast_grf3d_la_OBJECTS)
+-libast_grf_2_0_la_LIBADD =
++libast_grf_2_0_la_DEPENDENCIES = libast_err.la
+ am_libast_grf_2_0_la_OBJECTS = libast_grf_2_0_la-grf_2.0.lo
+ libast_grf_2_0_la_OBJECTS = $(am_libast_grf_2_0_la_OBJECTS)
+-libast_grf_3_2_la_LIBADD =
++libast_grf_3_2_la_DEPENDENCIES = libast_err.la
+ am_libast_grf_3_2_la_OBJECTS = libast_grf_3_2_la-grf_3.2.lo
+ libast_grf_3_2_la_OBJECTS = $(am_libast_grf_3_2_la_OBJECTS)
+-libast_grf_5_6_la_LIBADD =
++libast_grf_5_6_la_DEPENDENCIES = libast_err.la
+ am_libast_grf_5_6_la_OBJECTS = libast_grf_5_6_la-grf_5.6.lo
+ libast_grf_5_6_la_OBJECTS = $(am_libast_grf_5_6_la_OBJECTS)
+-libast_levmar_la_LIBADD =
++libast_levmar_la_DEPENDENCIES = libast_err.la
+ am_libast_levmar_la_OBJECTS = libast_levmar_la-levmar.lo
+ libast_levmar_la_OBJECTS = $(am_libast_levmar_la_OBJECTS)
+-libast_pal_la_LIBADD =
++libast_pal_la_LIBADD = -lm
+ am_libast_pal_la_OBJECTS = libast_pal_la-pal.lo
+ libast_pal_la_OBJECTS = $(am_libast_pal_la_OBJECTS)
+-libast_pgplot_la_LIBADD =
++libast_pgplot_la_LIBADD = -lpgplot
+ am_libast_pgplot_la_OBJECTS = libast_pgplot_la-grf_pgplot.lo
+ libast_pgplot_la_OBJECTS = $(am_libast_pgplot_la_OBJECTS)
+-libast_pgplot3d_la_LIBADD =
++libast_pgplot3d_la_LIBADD = -lpgplot
+ am_libast_pgplot3d_la_OBJECTS = libast_pgplot3d_la-grf3d_pgplot.lo
+ libast_pgplot3d_la_OBJECTS = $(am_libast_pgplot3d_la_OBJECTS)
+-libast_wcslib_la_LIBADD =
++libast_wcslib_la_LIBADD =
+ am_libast_wcslib_la_OBJECTS = libast_wcslib_la-proj.lo \
+ libast_wcslib_la-wcstrig.lo libast_wcslib_la-tpn.lo
+ libast_wcslib_la_OBJECTS = $(am_libast_wcslib_la_OBJECTS)
diff --git a/sci-astronomy/ast/files/5.7.2-no-emsrep.patch b/sci-astronomy/ast/files/5.7.2-no-emsrep.patch
new file mode 100644
index 000000000000..c856a4d2e50f
--- /dev/null
+++ b/sci-astronomy/ast/files/5.7.2-no-emsrep.patch
@@ -0,0 +1,19 @@
+--- err_ems.c.orig 2011-06-14 21:34:58.148268362 +0100
++++ err_ems.c 2011-06-14 21:55:41.638273967 +0100
+@@ -57,6 +57,7 @@
+ /* ---------------------- */
+ #include "err.h" /* Interface to this module */
+ #include "ems.h" /* Interface to the EMS system */
++#include <stdio.h>
+
+ /* Function implementations. */
+ /* ========================= */
+@@ -104,5 +105,7 @@
+ report the error message through EMS and to associate the error
+ status with it. Ignore any returned status value. */
+ local_status = status;
+- emsRep( "AST_ERROR", message, &local_status );
++ /* not in ast-5.7.1 tar ball */
++ /* emsRep( "AST_ERROR", message, &local_status ); */
++ fprintf(stderr, "AST_ERROR: %s ", message);
+ }