summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 18:24:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 18:24:08 +0000
commit5339f0396053d9d2fe19a71cf69d647d15f14f7c (patch)
tree61ba34c4b957544edef79b8e5155c9fb7c2e2d1b /sci-astronomy
parentavoid errors for non *-darwin* CHOSTS (diff)
downloadgentoo-2-5339f0396053d9d2fe19a71cf69d647d15f14f7c.tar.gz
gentoo-2-5339f0396053d9d2fe19a71cf69d647d15f14f7c.tar.bz2
gentoo-2-5339f0396053d9d2fe19a71cf69d647d15f14f7c.zip
Fix building with libpng14 wrt #307429 by Lars Wendler.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog6
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild3
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-libpng14.patch14
3 files changed, 21 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 4c31d947c154..62248df510e2 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.61 2010/01/12 02:18:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.62 2010/03/08 18:24:08 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> celestia-1.6.0.ebuild,
+ +files/celestia-1.6.0-libpng14.patch:
+ Fix building with libpng14 wrt #307429 by Lars Wendler.
12 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
-files/celestia-1.4.1-cfg.patch, -celestia-1.5.1.ebuild,
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
index dd6e3faf3b6d..6d328679280e 100644
--- a/sci-astronomy/celestia/celestia-1.6.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.10 2010/01/11 22:13:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.11 2010/03/08 18:24:08 ssuominen Exp $
EAPI=2
inherit eutils flag-o-matic gnome2 autotools
@@ -59,6 +59,7 @@ src_prepare() {
# needed for proper detection of kde-3.5 in the presence
# of kde4
epatch "${FILESDIR}"/${P}-kde-3.5.patch
+ epatch "${FILESDIR}"/${P}-libpng14.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-libpng14.patch b/sci-astronomy/celestia/files/celestia-1.6.0-libpng14.patch
new file mode 100644
index 000000000000..ac6f07aeac0d
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.0-libpng14.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/show_bug.cgi?id=307429
+http://repos.archlinux.org/wsvn/packages/celestia/trunk/libpng14.patch
+
+--- src/celengine/image.cpp
++++ src/celengine/image.cpp
+@@ -737,7 +737,7 @@
+
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))