summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-04-24 22:32:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-04-24 22:32:19 +0000
commit49141e9bc24802955815f6c4b074fd97b7da7be4 (patch)
tree0c811ecdc559790726e2ced306fcebee9a8971f1 /sci-astronomy
parentfix deps (diff)
downloadgentoo-2-49141e9bc24802955815f6c4b074fd97b7da7be4.tar.gz
gentoo-2-49141e9bc24802955815f6c4b074fd97b7da7be4.tar.bz2
gentoo-2-49141e9bc24802955815f6c4b074fd97b7da7be4.zip
Switched to distutils-r1 and depend on virtual/pyfits
(Portage version: 2.2.01.21890-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/kapteyn/ChangeLog10
-rw-r--r--sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch2
-rw-r--r--sci-astronomy/kapteyn/kapteyn-2.2-r1.ebuild32
3 files changed, 41 insertions, 3 deletions
diff --git a/sci-astronomy/kapteyn/ChangeLog b/sci-astronomy/kapteyn/ChangeLog
index 5f2229b6e044..ef9a69a7ad9e 100644
--- a/sci-astronomy/kapteyn/ChangeLog
+++ b/sci-astronomy/kapteyn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/kapteyn
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/kapteyn/ChangeLog,v 1.11 2012/08/05 17:57:22 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/kapteyn/ChangeLog,v 1.12 2013/04/24 22:32:19 bicatali Exp $
+
+*kapteyn-2.2-r1 (24 Apr 2013)
+
+ 24 Apr 2013; Sébastien Fabbro <bicatali@gentoo.org> +kapteyn-2.2-r1.ebuild,
+ files/kapteyn-2.2-debundle_wcs.patch:
+ Switched to distutils-r1 and depend on virtual/pyfits
05 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> kapteyn-2.2.ebuild:
keyword amd64-linux, x86-linux
diff --git a/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch b/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch
index d657c27bcc53..035979b80bc7 100644
--- a/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch
+++ b/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch
@@ -45,7 +45,7 @@ Patch written by Kacper Kowalik <xarthisius@gentoo.org>
-include_dirs.append(wcslib_dir)
+
+WCSLIB = pkgconfig('wcslib')
-+WCSVERSION = WCSLIB['version'][0]
++WCSVERSION = Popen(["pkg-config --modversion"],stdout=PIPE, shell=True).communicate()[0].split()
+
+include_dirs += WCSLIB['include_dirs']
diff --git a/sci-astronomy/kapteyn/kapteyn-2.2-r1.ebuild b/sci-astronomy/kapteyn/kapteyn-2.2-r1.ebuild
new file mode 100644
index 000000000000..9ce6042f27b8
--- /dev/null
+++ b/sci-astronomy/kapteyn/kapteyn-2.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/kapteyn/kapteyn-2.2-r1.ebuild,v 1.1 2013/04/24 22:32:19 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Collection of python tools for astronomy"
+HOMEPAGE="http://www.astro.rug.nl/software/kapteyn"
+SRC_URI="http://www.astro.rug.nl/software/kapteyn/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ sci-astronomy/wcslib
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ virtual/pyfits[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES.txt README.txt doc/${PN}.pdf )
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/${P}-debundle_wcs.patch
+ rm -r src/wcslib-4.* || die
+}