summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-04 22:19:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-04 22:19:54 +0000
commit20a789a05b8e5de97138a67fb4d830b3afe941a4 (patch)
tree8e1751c1927ee6fa80adec3827c16e6ce7581071 /sci-astronomy
parent[app-shells/zsh-completion] Works on ~amd64-fbsd (diff)
downloadgentoo-2-20a789a05b8e5de97138a67fb4d830b3afe941a4.tar.gz
gentoo-2-20a789a05b8e5de97138a67fb4d830b3afe941a4.tar.bz2
gentoo-2-20a789a05b8e5de97138a67fb4d830b3afe941a4.zip
Version bump
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/ChangeLog11
-rw-r--r--sci-astronomy/cpl/cpl-6.1.1.ebuild55
-rw-r--r--sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch35
-rw-r--r--sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch46
4 files changed, 145 insertions, 2 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index bc182b88d9c9..6bb3bad07b4f 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/cpl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.7 2011/08/04 18:29:45 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.8 2012/06/04 22:19:54 bicatali Exp $
+
+*cpl-6.1.1 (04 Jun 2012)
+
+ 04 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> +cpl-6.1.1.ebuild,
+ +files/cpl-6.1.1-check-shared-libs.patch,
+ +files/cpl-6.1.1-use-system-ltdl.patch:
+ Version bump
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/cpl/cpl-6.1.1.ebuild b/sci-astronomy/cpl/cpl-6.1.1.ebuild
new file mode 100644
index 000000000000..8bcc44e48d5c
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-6.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-6.1.1.ebuild,v 1.1 2012/06/04 22:19:54 bicatali Exp $
+
+EAPI=4
+
+JAVA_PKG_OPT_USE=gasgano
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils java-pkg-opt-2 autotools-utils
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc gasgano static-libs threads"
+
+RDEPEND=">=sci-libs/cfitsio-3.270
+ >=sci-astronomy/wcslib-4.8.4
+ >=sci-libs/fftw-3.1.2
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-check-shared-libs.patch
+ "${FILESDIR}"/${P}-use-system-ltdl.patch
+)
+
+src_configure() {
+ myeconfargs+=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-ltdl-install
+ --without-included-ltdl
+ $(use_enable threads)
+ )
+ if use gasgano; then
+ myeconfargs+=(
+ --enable-gasgano
+ --with-gasgano="${EPREFIX}/usr"
+ --with-gasgano-classpath="${EPREFIX}/usr/share/gasgano/lib"
+ --with-java="$(java-config -O)"
+ )
+ else
+ myeconfargs+=( --disable-gasgano )
+ fi
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install all $(use doc && echo install-html)
+}
diff --git a/sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch b/sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch
new file mode 100644
index 000000000000..658f2eaefb9e
--- /dev/null
+++ b/sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch
@@ -0,0 +1,35 @@
+Check shared library instead of static ones.
+bicatali@gentoo.org
+
+diff -Nur cpl-6.1.1.orig/m4/cpl.m4 cpl-6.1.1/m4/cpl.m4
+--- cpl-6.1.1.orig/m4/cpl.m4 2012-06-04 18:38:01.000000000 +0100
++++ cpl-6.1.1/m4/cpl.m4 2012-06-04 18:46:37.000000000 +0100
+@@ -8,7 +8,7 @@
+
+ cpl_cfitsio_check_version="$1"
+ cpl_cfitsio_check_header="fitsio.h"
+- cpl_cfitsio_check_lib="libcfitsio.a"
++ cpl_cfitsio_check_lib="libcfitsio.so"
+
+ cpl_cfitsio_incdirs=""
+ cpl_cfitsio_libdirs=""
+@@ -668,7 +668,7 @@
+
+ cpl_wcs_check_version="$1"
+ cpl_wcs_check_header="wcslib/wcslib.h"
+- cpl_wcs_check_lib="libwcs.a"
++ cpl_wcs_check_lib="libwcs.so"
+
+ cpl_wcs_includes=""
+ cpl_wcs_libraries=""
+@@ -900,8 +900,8 @@
+
+ cpl_fftw_check_version="$1"
+ cpl_fftw_check_header="fftw3.h"
+- cpl_fftw_check_lib="libfftw3.a"
+- cpl_fftwf_check_lib="libfftw3f.a"
++ cpl_fftw_check_lib="libfftw3.so"
++ cpl_fftwf_check_lib="libfftw3f.so"
+
+ cpl_fftw_includes=""
+ cpl_fftw_libraries=""
diff --git a/sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch b/sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch
new file mode 100644
index 000000000000..a0c23a75d38c
--- /dev/null
+++ b/sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch
@@ -0,0 +1,46 @@
+use system libtdl from libtool instead of bundled one
+see http://www.flameeyes.eu/autotools-mythbuster/libtool/plugins.html
+bicatali@gentoo.org
+
+diff -Nur cpl-6.1.1.orig/configure.ac cpl-6.1.1/configure.ac
+--- cpl-6.1.1.orig/configure.ac 2012-06-04 18:38:01.000000000 +0100
++++ cpl-6.1.1/configure.ac 2012-06-04 22:14:23.000000000 +0100
+@@ -60,8 +60,12 @@
+ AC_ENABLE_STATIC(yes)
+ AC_ENABLE_SHARED(yes)
+
+-AC_LIBLTDL_CONVENIENCE
+-AC_PROG_LIBTOOL
++LT_INIT([dlopen])
++AC_CHECK_HEADER([ltdl.h],
++ [AC_CHECK_LIB([ltdl], [lt_dladvise_init],
++ [LIBLTDL=-lltdl], [LIBLTDL=])],
++ [LIBLTDL=])
++
+ AC_SUBST(INCLTDL)
+ AC_SUBST(LIBLTDL)
+ AC_SUBST(LIBTOOL_DEPS)
+@@ -131,7 +135,6 @@
+ CPL_CONFIG_FUNC
+
+ # Configure subpackages
+-AC_CONFIG_SUBDIRS(libltdl)
+
+ if test ! x$"cpl_cv_with_system_cext" = xyes; then
+ AC_CONFIG_SUBDIRS([libcext])
+diff -Nur cpl-6.1.1.orig/Makefile.am cpl-6.1.1/Makefile.am
+--- cpl-6.1.1.orig/Makefile.am 2012-06-04 18:38:01.000000000 +0100
++++ cpl-6.1.1/Makefile.am 2012-06-04 19:07:41.000000000 +0100
+@@ -25,11 +25,10 @@
+ DISTCLEANFILES = *~
+
+ if GASGANO_SUPPORT
+-libltdl = libltdl
+ cpljava = cpljava
+ endif
+
+-SUBDIRS = $(libltdl) $(libcext) cplcore cplui cpldrs cpldfs $(cpljava)
++SUBDIRS = $(libcext) cplcore cplui cpldrs cpldfs $(cpljava)
+
+ HTML_SUBDIRS =
+