summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-12-08 11:58:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-12-08 11:58:10 +0000
commit090deb8a755437aa2af9c979efc7540f2077405c (patch)
tree7c5f5cd19ad049c1c60cdabb22aee924a19002b2 /sci-astronomy
parentAfter dicussion with vapier, updated e17 alias to enlightenment@g.o. (diff)
downloadgentoo-2-090deb8a755437aa2af9c979efc7540f2077405c.tar.gz
gentoo-2-090deb8a755437aa2af9c979efc7540f2077405c.tar.bz2
gentoo-2-090deb8a755437aa2af9c979efc7540f2077405c.zip
Install a missing header and propagate LDFLAGS
(Portage version: 2.2_rc17/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog8
-rw-r--r--sci-astronomy/wcslib/wcslib-4.3-r1.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index 62bc57be6fe9..a0ee95a3cdaa 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.2 2008/11/05 21:56:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.3 2008/12/08 11:58:10 bicatali Exp $
+
+*wcslib-4.3-r1 (08 Dec 2008)
+
+ 08 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +wcslib-4.3-r1.ebuild:
+ Install a missing header and propagate LDFLAGS
05 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org> wcslib-4.3.ebuild:
Added some die's
diff --git a/sci-astronomy/wcslib/wcslib-4.3-r1.ebuild b/sci-astronomy/wcslib/wcslib-4.3-r1.ebuild
new file mode 100644
index 000000000000..01c97379f041
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.3-r1.ebuild,v 1.1 2008/12/08 11:58:10 bicatali Exp $
+
+inherit fortran eutils
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="sci-libs/pgplot
+ sci-libs/cfitsio"
+
+FORTRAN="gfortran ifc g77"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/$(SHRLD)/$(SHRLD) $(LDFLAGS)/' \
+ C/GNUmakefile || die
+}
+
+src_install () {
+ # make install from makefile is buggy
+
+ dobin utils/{HPXcvt,fitshdr,wcsgrid} || die "dobin failed"
+
+ dolib.a C/libwcs-${PV}.a pgsbox/libpgsbox-${PV}.a || die
+ dolib.so C/libwcs.so.${PV} || die
+ dosym libwcs.so.${PV} /usr/$(get_libdir)/libwcs.so
+ dosym libwcs-${PV}.a /usr/$(get_libdir)/libwcs.a
+ dosym libpgsbox-${PV}.a /usr/$(get_libdir)/libpgsbox.a
+
+ insinto /usr/include/${P}
+ doins wcsconfig.h wcsconfig_f77.h || die
+ doins pgsbox/*.h C/*.h Fortran/*inc || die
+ dosym ${P} /usr/include/${PN}
+
+ dodoc README
+ newdoc C/CHANGES CHANGES_C
+ newdoc Fortran/CHANGES CHANGES_FORTRAN
+ newdoc pgsbox/CHANGES CHANGES_PGSBOX
+}