summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-06 15:55:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-06 15:55:36 +0000
commit0339073701feec1359ed88ef8d168931c1bc1ffb (patch)
tree794befc0e8e990159012d0d7671356c67282a7a4 /sci-astronomy
parentoptionaly => optionally (diff)
downloadgentoo-2-0339073701feec1359ed88ef8d168931c1bc1ffb.tar.gz
gentoo-2-0339073701feec1359ed88ef8d168931c1bc1ffb.tar.bz2
gentoo-2-0339073701feec1359ed88ef8d168931c1bc1ffb.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog8
-rw-r--r--sci-astronomy/wcslib/wcslib-4.19.ebuild73
-rw-r--r--sci-astronomy/wcslib/wcslib-4.22.ebuild (renamed from sci-astronomy/wcslib/wcslib-4.20.ebuild)31
3 files changed, 23 insertions, 89 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index e2e82867f97b..ee74d9154cae 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.39 2014/04/03 16:38:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.40 2014/05/06 15:55:36 bicatali Exp $
+
+*wcslib-4.22 (06 May 2014)
+
+ 06 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +wcslib-4.22.ebuild,
+ -wcslib-4.19.ebuild, -wcslib-4.20.ebuild:
+ Version bump
*wcslib-4.21 (03 Apr 2014)
diff --git a/sci-astronomy/wcslib/wcslib-4.19.ebuild b/sci-astronomy/wcslib/wcslib-4.19.ebuild
deleted file mode 100644
index 69e4692693c1..000000000000
--- a/sci-astronomy/wcslib/wcslib-4.19.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.19.ebuild,v 1.1 2013/11/22 19:48:22 bicatali Exp $
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-
-inherit eutils fortran-2 multilib
-
-DESCRIPTION="Astronomical World Coordinate System transformations library"
-HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
-SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
-
-SLOT="0/4"
-LICENSE="LGPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc fortran fits pgplot static-libs"
-
-RDEPEND="
- fits? ( sci-libs/cfitsio )
- pgplot? ( sci-libs/pgplot )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig"
-
-src_prepare() {
- sed -i -e 's/COPYING\*//' GNUmakefile || die
-}
-
-src_configure() {
- local myconf=()
- # hacks because cfitsio and pgplot directories are hard-coded
- if use fits; then
- myconf+=(
- --with-cfitsioinc="${EROOT}/usr/include"
- --with-cfitsiolib="${EROOT}/usr/$(get_libdir)"
- )
- else
- myconf+=( --without-cfitsio )
- fi
- if use pgplot; then
- myconf+=(
- --with-pgplotinc="${EROOT}/usr/include"
- --with-pgplotlib="${EROOT}/usr/$(get_libdir)"
- )
- else
- myconf+=( --without-pgplot )
- fi
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable static-libs static) \
- $(use_enable fortran) \
- ${myconf[@]}
-}
-
-src_compile() {
- # nasty makefile, debugging means full rewrite
- emake -j1
-}
-
-src_test() {
- emake -j1 check
-}
-
-src_install () {
- default
- # static libs are same as shared (compiled with PIC)
- # so they are not compiled twice
- use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
- use doc || rm -r "${ED}"/usr/share/doc/${PF}/html \
- "${ED}"/usr/share/doc/${PF}/*.pdf
-}
diff --git a/sci-astronomy/wcslib/wcslib-4.20.ebuild b/sci-astronomy/wcslib/wcslib-4.22.ebuild
index ed05244a5605..504ae861e486 100644
--- a/sci-astronomy/wcslib/wcslib-4.20.ebuild
+++ b/sci-astronomy/wcslib/wcslib-4.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.20.ebuild,v 1.1 2014/01/28 18:23:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.22.ebuild,v 1.1 2014/05/06 15:55:36 bicatali Exp $
EAPI=5
@@ -18,8 +18,8 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc fortran fits pgplot static-libs"
RDEPEND="
- fits? ( sci-libs/cfitsio )
- pgplot? ( sci-libs/pgplot )"
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
DEPEND="${RDEPEND}
sys-devel/flex
virtual/pkgconfig"
@@ -29,33 +29,33 @@ src_prepare() {
}
src_configure() {
- local myconf=()
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable static-libs static)
+ $(use_enable fortran)
+ )
# hacks because cfitsio and pgplot directories are hard-coded
if use fits; then
myconf+=(
- --with-cfitsioinc="${EROOT}/usr/include"
- --with-cfitsiolib="${EROOT}/usr/$(get_libdir)"
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
)
else
myconf+=( --without-cfitsio )
fi
if use pgplot; then
myconf+=(
- --with-pgplotinc="${EROOT}/usr/include"
- --with-pgplotlib="${EROOT}/usr/$(get_libdir)"
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
)
else
myconf+=( --without-pgplot )
fi
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable static-libs static) \
- $(use_enable fortran) \
- ${myconf[@]}
+ econf ${myconf[@]}
}
src_compile() {
- # nasty makefile, debugging means full rewrite
+ # nasty makefile, debugging means probably full rewrite
emake -j1
}
@@ -68,6 +68,7 @@ src_install () {
# static libs are same as shared (compiled with PIC)
# so they are not compiled twice
use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
- use doc || rm -r "${ED}"/usr/share/doc/${PF}/html \
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
"${ED}"/usr/share/doc/${PF}/*.pdf
}