summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-10-11 20:35:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-10-11 20:35:38 +0000
commitfd16c602922b35834c7ec37ef486ded3706c53ca (patch)
tree3ec83283e9ca7754b56ee03f9df1c7ef3a314f09 /sci-astronomy/xephem
parentMake dev-java/gjdoc DEPEND depend on USE=doc by Michel Ganguin (bug #340435). (diff)
downloadgentoo-2-fd16c602922b35834c7ec37ef486ded3706c53ca.tar.gz
gentoo-2-fd16c602922b35834c7ec37ef486ded3706c53ca.tar.bz2
gentoo-2-fd16c602922b35834c7ec37ef486ded3706c53ca.zip
Fix buffer overflow wrt bug 339901. Thanks to Diego for the report. Respect CC. Drop old. Add explicit RDEPEND.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/xephem')
-rw-r--r--sci-astronomy/xephem/ChangeLog10
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch15
-rw-r--r--sci-astronomy/xephem/xephem-3.7.2.ebuild83
-rw-r--r--sci-astronomy/xephem/xephem-3.7.3.ebuild3
-rw-r--r--sci-astronomy/xephem/xephem-3.7.4-r1.ebuild (renamed from sci-astronomy/xephem/xephem-3.7.4.ebuild)11
5 files changed, 34 insertions, 88 deletions
diff --git a/sci-astronomy/xephem/ChangeLog b/sci-astronomy/xephem/ChangeLog
index 252cdfc4474c..d66235f90b99 100644
--- a/sci-astronomy/xephem/ChangeLog
+++ b/sci-astronomy/xephem/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-astronomy/xephem
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.33 2010/10/10 21:13:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.34 2010/10/11 20:35:38 xarthisius Exp $
+
+*xephem-3.7.4-r1 (11 Oct 2010)
+
+ 11 Oct 2010; Kacper Kowalik <xarthisius@gentoo.org> -xephem-3.7.2.ebuild,
+ xephem-3.7.3.ebuild, -xephem-3.7.4.ebuild, +xephem-3.7.4-r1.ebuild,
+ +files/xephem-3.7.4-overflows.patch:
+ Fix buffer overflow wrt bug 339901. Thanks to Diego for the report.
+ Respect CC. Drop old. Add explicit RDEPEND.
10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> xephem-3.7.2.ebuild,
xephem-3.7.3.ebuild, xephem-3.7.4.ebuild:
diff --git a/sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch b/sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch
new file mode 100644
index 000000000000..2dd5e55c3696
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch
@@ -0,0 +1,15 @@
+Fix buffer overflow
+
+http://bugs.gentoo.org/show_bug.cgi?id=339901
+
+--- GUI/xephem/tools/lx200xed/liblx200.c
++++ GUI/xephem/tools/lx200xed/liblx200.c
+@@ -855,7 +855,7 @@
+ return(LX200_FALSE); /*Probably ought to verify all characters are acceptable*/
+ szCmd[1]='L' + iSite;
+ szCmd[2]='\0';
+- snprintf(szSite,6,"%3s",buf);
++ snprintf(szSite,4,"%3s",buf);
+ return(lx200_set_generic(fd,szCmd,szSite));
+ }
+
diff --git a/sci-astronomy/xephem/xephem-3.7.2.ebuild b/sci-astronomy/xephem/xephem-3.7.2.ebuild
deleted file mode 100644
index 2d4279e4b381..000000000000
--- a/sci-astronomy/xephem/xephem-3.7.2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.2.ebuild,v 1.11 2010/10/10 21:13:34 ulm Exp $
-
-EAPI=1
-
-inherit eutils
-
-DESCRIPTION="Interactive tool for astronomical ephemeris and sky simulation"
-SRC_URI="http://www.clearskyinstitute.com/xephem/${P}.tar.gz"
-HOMEPAGE="http://www.clearskyinstitute.com/xephem"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE=""
-SLOT="0"
-LICENSE="as-is"
-DEPEND="!media-gfx/feh
- >=x11-libs/openmotif-2.3:0"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PV}.patch"
- for i in libastro/Makefile libip/Makefile libjpegd/Makefile \
- liblilxml/Makefile GUI/xephem/Makefile GUI/xephem/tools/*/Makefile ; do
- einfo "Fixing CFLAGS in ${i}"
- sed -e "s~^CFLAGS[ ]*=\(.*\)-O2\(.*\)~CFLAGS= \1 \2 ${CFLAGS}~" \
- -i ${i} \
- || die "sed failed"
- done
- sed -e 's~^CFLAGS[ ]*=\(.*\)$(CLDFLAGS)\(.*\)~CFLAGS=\1 \2~' \
- -i GUI/xephem/Makefile \
- || die "sed in GUI/xephem failed"
-}
-
-src_compile() {
-
- cd libastro
- emake || die "emake failed"
- local myldflags
- cd "${S}"
- for dir in libip liblilxml libjpegd GUI/xephem/tools/* GUI/xephem; do
- echo "going into ${dir}"
- cd "${S}"/${dir}
- if [ ${dir:0:3} = "lib" ]; then
- myldflags=""
- else
- myldflags="${CLDFLAGS}"
- fi
- emake \
- MOTIFI="/usr/include" \
- MOTIFL="/usr/$(get_libdir)" \
- CLDFLAGS="${myldflags}" \
- || die "emake in ${dir} failed"
- done
-}
-
-src_install() {
-
- into /usr
- cd "${S}"/GUI/xephem
- dobin xephem || die "dobin xephem failed"
- for file in tools/indi/{evalINDI,getINDI,setINDI,tmount,ota,wx,cam,security,indiserver} \
- tools/{lx200xed/lx200xed,xedb/xedb,xephemdbd/xephemdbd}; do
- dobin ${file} || die "dobin ${file} failed"
- done
- doman xephem.1 tools/*/*.1
- mv tools .. # do not install tool sources into share directory
- for i in $(find . -mindepth 1 -type d); do
- insinto /usr/share/${PN}/${i}
- doins ${i}/*
- done
-
- echo > "${S}/XEphem" "XEphem.ShareDir: /usr/share/${PN}"
- insinto /usr/share/X11/app-defaults
- has_version '<x11-base/xorg-x11-7.0' && \
- insinto /etc/X11/app-defaults
- doins "${S}"/XEphem
-
- cd "${S}"
- dodoc Copyright README INSTALL
- newicon GUI/xephem/XEphem.png ${PN}.png
- make_desktop_entry xephem XEphem ${PN}
-}
diff --git a/sci-astronomy/xephem/xephem-3.7.3.ebuild b/sci-astronomy/xephem/xephem-3.7.3.ebuild
index 46b6f40aa68f..041fb5553ca4 100644
--- a/sci-astronomy/xephem/xephem-3.7.3.ebuild
+++ b/sci-astronomy/xephem/xephem-3.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.3.ebuild,v 1.10 2010/10/10 21:13:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.3.ebuild,v 1.11 2010/10/11 20:35:38 xarthisius Exp $
EAPI=1
@@ -16,6 +16,7 @@ LICENSE="as-is"
DEPEND=">=x11-libs/openmotif-2.3:0
media-libs/jpeg
media-libs/libpng"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
diff --git a/sci-astronomy/xephem/xephem-3.7.4.ebuild b/sci-astronomy/xephem/xephem-3.7.4-r1.ebuild
index bf585c55d02b..72356ccc9f44 100644
--- a/sci-astronomy/xephem/xephem-3.7.4.ebuild
+++ b/sci-astronomy/xephem/xephem-3.7.4-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.4.ebuild,v 1.2 2010/10/10 21:13:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.4-r1.ebuild,v 1.1 2010/10/11 20:35:38 xarthisius Exp $
EAPI=2
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Interactive tool for astronomical ephemeris and sky simulation"
HOMEPAGE="http://www.clearskyinstitute.com/xephem"
@@ -18,9 +18,14 @@ DEPEND=">=x11-libs/openmotif-2.3:0
media-libs/libpng"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ tc-export CC
+}
+
src_prepare() {
# make sure we use system libs and respect user flags
- epatch "${FILESDIR}"/${P}-libs-flags.patch
+ epatch "${FILESDIR}"/${P}-libs-flags.patch \
+ "${FILESDIR}"/${P}-overflows.patch
}
src_compile() {