summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-05-07 16:21:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-05-07 16:21:24 +0000
commitb49a0f3c404f3aeca31249b4aa2b190205e5ac55 (patch)
tree55864adade1efe76020cf07ec88969402f4ed175 /sci-astronomy/xephem
parentMigrate to split-ant. (diff)
downloadgentoo-2-b49a0f3c404f3aeca31249b4aa2b190205e5ac55.tar.gz
gentoo-2-b49a0f3c404f3aeca31249b4aa2b190205e5ac55.tar.bz2
gentoo-2-b49a0f3c404f3aeca31249b4aa2b190205e5ac55.zip
Added a desktop entry (bug #160261, thanks Pacho Ramos <pacho@condmat1.ciencias.uniovi.es>), and some ebuild cleaning. Added longdescription in metadata.xml
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-astronomy/xephem')
-rw-r--r--sci-astronomy/xephem/ChangeLog8
-rw-r--r--sci-astronomy/xephem/metadata.xml8
-rw-r--r--sci-astronomy/xephem/xephem-3.7.2.ebuild46
3 files changed, 43 insertions, 19 deletions
diff --git a/sci-astronomy/xephem/ChangeLog b/sci-astronomy/xephem/ChangeLog
index b0c72aaf84b5..0e33601f3ebf 100644
--- a/sci-astronomy/xephem/ChangeLog
+++ b/sci-astronomy/xephem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/xephem
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.14 2007/02/22 01:32:07 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.15 2007/05/07 16:21:24 bicatali Exp $
+
+ 07 May 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ xephem-3.7.2.ebuild:
+ Added a desktop entry (bug #160261, thanks Pacho Ramos
+ <pacho@condmat1.ciencias.uniovi.es>), and some ebuild cleaning. Added
+ longdescription in metadata.xml
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-astronomy/xephem/metadata.xml b/sci-astronomy/xephem/metadata.xml
index b229aec85b8f..3e5ddba5b8b1 100644
--- a/sci-astronomy/xephem/metadata.xml
+++ b/sci-astronomy/xephem/metadata.xml
@@ -2,4 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+Xephem is an interactive astronomical ephemeris program for X Windows
+systems. It computes heliocentric, geocentric and topocentric
+information for fixed celestial objects and objects in heliocentric
+and geocentric orbits; has built-in support for all planet positions;
+the moons of Jupiter, Saturn and Earth; Mars' and Jupiter's central
+meridian longitude; Saturn's rings; and Jupiter's Great Red Spot.
+</longdescription>
</pkgmetadata>
diff --git a/sci-astronomy/xephem/xephem-3.7.2.ebuild b/sci-astronomy/xephem/xephem-3.7.2.ebuild
index 326568be810b..28e571c432ba 100644
--- a/sci-astronomy/xephem/xephem-3.7.2.ebuild
+++ b/sci-astronomy/xephem/xephem-3.7.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.2.ebuild,v 1.1 2006/11/29 15:22:44 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.2.ebuild,v 1.2 2007/05/07 16:21:24 bicatali Exp $
inherit eutils
-DESCRIPTION="XEphem is the X Windows Ephemeris, and provides a scientific-grade solar system model, star charts, sky views, plus a whole lot more."
+DESCRIPTION="Interactive tool for astronomical ephemeris and sky simulation"
SRC_URI="http://www.clearskyinstitute.com/xephem/${P}.tar.gz"
HOMEPAGE="http://www.clearskyinstitute.com/xephem"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
@@ -16,56 +16,66 @@ DEPEND="virtual/motif"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}.patch"
for i in libastro/Makefile libip/Makefile libjpegd/Makefile \
liblilxml/Makefile GUI/xephem/Makefile GUI/xephem/tools/*/Makefile ; do
einfo "Fixing CFLAGS in ${i}"
- sed -e "s~^CFLAGS[ ]*=\(.*\)-O2\(.*\)~CFLAGS= \1 \2 ${CFLAGS}~" -i ${i} \
+ sed -e "s~^CFLAGS[ ]*=\(.*\)-O2\(.*\)~CFLAGS= \1 \2 ${CFLAGS}~" \
+ -i ${i} \
|| die "sed failed"
done
sed -e 's~^CFLAGS[ ]*=\(.*\)$(CLDFLAGS)\(.*\)~CFLAGS=\1 \2~' \
- -i GUI/xephem/Makefile
+ -i GUI/xephem/Makefile \
+ || die "sed in GUI/xephem failed"
}
src_compile() {
cd libastro
- emake || die
+ emake || die "emake failed"
local myldflags
- cd ${S}
+ cd "${S}"
for dir in libip liblilxml libjpegd GUI/xephem/tools/* GUI/xephem; do
echo "going into ${dir}"
- cd ${S}/${dir}
+ cd "${S}"/${dir}
if [ ${dir:0:3} = "lib" ]; then
myldflags=""
else
myldflags="${CLDFLAGS}"
fi
- emake MOTIFI="/usr/include" MOTIFL="/usr/lib" CLDFLAGS="${myldflags}" || die
+ emake \
+ MOTIFI="/usr/include" \
+ MOTIFL="/usr/$(get_libdir)" \
+ CLDFLAGS="${myldflags}" \
+ || die "emake in ${dir} failed"
done
}
src_install() {
into /usr
- cd ${S}/GUI/xephem
- dobin xephem
+ cd "${S}"/GUI/xephem
+ dobin xephem || die "dobin xephem failed"
for file in tools/indi/{evalINDI,getINDI,setINDI,tmount,ota,wx,cam,security,indiserver} \
tools/{lx200xed/lx200xed,xedb/xedb,xephemdbd/xephemdbd}; do
- dobin ${file}
+ dobin ${file} || die "dobin ${file} failed"
done
doman xephem.1 tools/*/*.1
mv tools .. # do not install tool sources into share directory
- for i in $(find . -type d -mindepth 1); do
+ for i in $(find . -mindepth 1 -type d); do
insinto /usr/share/${PN}/${i}
doins ${i}/*
done
echo > ${S}/XEphem "XEphem.ShareDir: /usr/share/${PN}"
- insinto /usr/lib/X11/app-defaults/
- doins ${S}/XEphem
+ insinto /usr/share/X11/app-defaults
+ has_version '<x11-base/xorg-x11-7.0' && \
+ insinto /etc/X11/app-defaults
+ doins "${S}"/XEphem
- cd ${S}
+ cd "${S}"
dodoc Copyright README INSTALL
+ newicon GUI/xephem/XEphem.png ${PN}.png
+ make_desktop_entry xephem XEphem ${PN}
}