summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-26 12:19:21 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-26 12:19:21 +0000
commit6fb924414afd8c27f407c870eec847606040f138 (patch)
tree35e6b34176d49f3beeeb933dffc1d70a31a0467e /sci-astronomy/wcstools
parentVersion bump (diff)
downloadgentoo-2-6fb924414afd8c27f407c870eec847606040f138.tar.gz
gentoo-2-6fb924414afd8c27f407c870eec847606040f138.tar.bz2
gentoo-2-6fb924414afd8c27f407c870eec847606040f138.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-astronomy/wcstools')
-rw-r--r--sci-astronomy/wcstools/ChangeLog8
-rw-r--r--sci-astronomy/wcstools/wcstools-3.7.4.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sci-astronomy/wcstools/ChangeLog b/sci-astronomy/wcstools/ChangeLog
index 9ca6e8f4c98e..d4ad91b5c29d 100644
--- a/sci-astronomy/wcstools/ChangeLog
+++ b/sci-astronomy/wcstools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcstools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.8 2008/01/15 15:12:06 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.9 2008/06/26 12:19:21 bicatali Exp $
+
+*wcstools-3.7.4 (26 Jun 2008)
+
+ 26 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +wcstools-3.7.4.ebuild:
+ Version bump
*wcstools-3.7.2 (15 Jan 2008)
diff --git a/sci-astronomy/wcstools/wcstools-3.7.4.ebuild b/sci-astronomy/wcstools/wcstools-3.7.4.ebuild
new file mode 100644
index 000000000000..6e442c4fdbd3
--- /dev/null
+++ b/sci-astronomy/wcstools/wcstools-3.7.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/wcstools-3.7.4.ebuild,v 1.1 2008/06/26 12:19:21 bicatali Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="World Coordinate System library for astronomical FITS images"
+HOMEPAGE="http://tdc-www.harvard.edu/software/wcstools"
+SRC_URI="http://tdc-www.harvard.edu/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.7.0-fix-leaks.patch
+ epatch "${FILESDIR}"/${PN}-3.7.1-autotools.patch
+ sed -i -e 's/3.7.x/${PV}/' configure.ac || die "sed failed"
+ eautoreconf
+}
+
+src_test() {
+ einfo "Testing various wcstools programs"
+ ./newfits -a 10 -j 248 41 -p 0.15 test.fits || die "test newfits failed"
+ ./sethead test.fits A=1 B=1 || die "test sethead failed"
+ [[ "$(./gethead test.fits RA)" == "16:32:00.000" ]] \
+ || die "test gethead failed"
+ rm -f test.fits
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman Man/man1/* || die "doman failed"
+ dodoc Readme Programs NEWS libned/NED_client || die "dodoc failed"
+ newdoc libwcs/Readme Readme.libwcs || die "newdoc failed"
+ newdoc libwcs/NEWS NEWS.libwcs || die "newdoc failed"
+}