summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-16 18:59:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-16 18:59:25 +0000
commit647781327255f7504a67836348503e04281f3a71 (patch)
tree74ef07fc2e8c8808fdaaf3da1e4c1865d2a74da1 /sci-astronomy/wcstools
parentMask glibc-2.10 and greater on selinux profiles on behalf of PeBenito (diff)
downloadgentoo-2-647781327255f7504a67836348503e04281f3a71.tar.gz
gentoo-2-647781327255f7504a67836348503e04281f3a71.tar.bz2
gentoo-2-647781327255f7504a67836348503e04281f3a71.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/wcstools')
-rw-r--r--sci-astronomy/wcstools/ChangeLog8
-rw-r--r--sci-astronomy/wcstools/wcstools-3.7.7.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sci-astronomy/wcstools/ChangeLog b/sci-astronomy/wcstools/ChangeLog
index f7456d058522..fd4fd433639d 100644
--- a/sci-astronomy/wcstools/ChangeLog
+++ b/sci-astronomy/wcstools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcstools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.12 2009/01/09 22:44:05 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.13 2009/07/16 18:59:25 bicatali Exp $
+
+*wcstools-3.7.7 (16 Jul 2009)
+
+ 16 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +wcstools-3.7.7.ebuild:
+ Version bump
09 Jan 2009; Joseph Jezak <josejx@gentoo.org> wcstools-3.7.6-r1.ebuild:
Marked ~ppc for bug #253299.
diff --git a/sci-astronomy/wcstools/wcstools-3.7.7.ebuild b/sci-astronomy/wcstools/wcstools-3.7.7.ebuild
new file mode 100644
index 000000000000..1ffce4e752bd
--- /dev/null
+++ b/sci-astronomy/wcstools/wcstools-3.7.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/wcstools-3.7.7.ebuild,v 1.1 2009/07/16 18:59:25 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="World Coordinate System library for astronomical FITS images"
+HOMEPAGE="http://tdc-www.harvard.edu/software/wcstools"
+SRC_URI="http://tdc-www.harvard.edu/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.7.0-fix-leaks.patch
+ epatch "${FILESDIR}"/${PN}-3.7.6-autotools.patch
+ sed -i -e 's/3.7.x/${PV}/' "${S}"/configure.ac || die "sed failed"
+ eautoreconf
+ # avoid colliding with fixdos and getdate (also in autotools patch)
+ sed -i \
+ -e 's/getdate/wcsgetdate/' \
+ -e 's/crlf/wcscrlf/' \
+ wcstools || die
+}
+
+src_test() {
+ einfo "Testing various wcstools programs"
+ ./newfits -a 10 -j 248 41 -p 0.15 test.fits || die "test newfits failed"
+ ./sethead test.fits A=1 B=1 || die "test sethead failed"
+ [[ "$(./gethead test.fits RA)" == "16:32:00.000" ]] \
+ || die "test gethead failed"
+ rm -f test.fits
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman Man/man1/* || die "doman failed"
+ dodoc Readme Programs NEWS libned/NED_client || die "dodoc failed"
+ newdoc libwcs/Readme Readme.libwcs || die "newdoc failed"
+ newdoc libwcs/NEWS NEWS.libwcs || die "newdoc failed"
+}
+
+pkg_postinst() {
+ elog "The following execs have been renamed to avoid colliding"
+ elog "with other packages:"
+ elog " getdate -> wcsgetdate"
+ elog " crlf -> wcscrlf"
+}