summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-10-17 06:25:43 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-10-17 06:25:43 +0000
commitf772670a0eb4ef69a27a34071a355232d7822036 (patch)
tree24fd9e9a0e192508a3dd6d90d375eee60b418859 /sci-astronomy/wcslib
parentAdd patch to fix upstream rename of csync -> ocsync. Fixes bug #438510. (diff)
downloadgentoo-2-f772670a0eb4ef69a27a34071a355232d7822036.tar.gz
gentoo-2-f772670a0eb4ef69a27a34071a355232d7822036.tar.bz2
gentoo-2-f772670a0eb4ef69a27a34071a355232d7822036.zip
Version bump
(Portage version: 2.2.0_alpha138/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/ChangeLog7
-rw-r--r--sci-astronomy/wcslib/wcslib-4.15.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index 5794dc9b36cc..adeefe65c086 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.31 2012/10/14 18:56:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.32 2012/10/17 06:25:43 xarthisius Exp $
+
+*wcslib-4.15 (17 Oct 2012)
+
+ 17 Oct 2012; Kacper Kowalik <xarthisius@gentoo.org> +wcslib-4.15.ebuild:
+ Version bump
14 Oct 2012; Justin Lecher <jlec@gentoo.org> wcslib-4.14.ebuild:
Prepare for fortran2.eclass update
diff --git a/sci-astronomy/wcslib/wcslib-4.15.ebuild b/sci-astronomy/wcslib/wcslib-4.15.ebuild
new file mode 100644
index 000000000000..1ff038239d59
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.15.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.15.ebuild,v 1.1 2012/10/17 06:25:43 xarthisius Exp $
+
+EAPI=4
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs"
+
+RDEPEND="fortran? ( virtual/fortran )
+ fits? ( sci-libs/cfitsio )
+ pgplot? ( sci-libs/pgplot )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ $(use_enable fortran) \
+ $(use_with fits cfitsio) \
+ $(use_with pgplot)
+}
+
+src_compile() {
+ # nasty makefile, debugging means full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}