summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-28 00:00:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-28 00:00:31 +0000
commitea8660b6522b854ff6c498c635b640aecf3b55e7 (patch)
tree9733b1a69061dc609dedf9d4ec73da9b5e4d6218 /sci-astronomy/swarp/swarp-2.17.6.ebuild
parentFix @EULA typo in previous commit. (diff)
downloadgentoo-2-ea8660b6522b854ff6c498c635b640aecf3b55e7.tar.gz
gentoo-2-ea8660b6522b854ff6c498c635b640aecf3b55e7.tar.bz2
gentoo-2-ea8660b6522b854ff6c498c635b640aecf3b55e7.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/swarp/swarp-2.17.6.ebuild')
-rw-r--r--sci-astronomy/swarp/swarp-2.17.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-astronomy/swarp/swarp-2.17.6.ebuild b/sci-astronomy/swarp/swarp-2.17.6.ebuild
new file mode 100644
index 000000000000..cac1db943eb2
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.17.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/swarp-2.17.6.ebuild,v 1.1 2009/07/28 00:00:31 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://astromatic.iap.fr/software/swarp"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/* || die
+ fi
+}