summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-29 00:20:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-29 00:20:36 +0000
commit6f8758361d2cf58fa7d7d2e4ba3f5c508939b27a (patch)
tree7accfa749dd9bb133296e030d7bb84b0053294ff /sci-astronomy/stellarium/stellarium-0.10.4.ebuild
parentWhitespace and var rename. (diff)
downloadgentoo-2-6f8758361d2cf58fa7d7d2e4ba3f5c508939b27a.tar.gz
gentoo-2-6f8758361d2cf58fa7d7d2e4ba3f5c508939b27a.tar.bz2
gentoo-2-6f8758361d2cf58fa7d7d2e4ba3f5c508939b27a.zip
Add gcc45 patch submitted by Philipp via bug #317465
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'sci-astronomy/stellarium/stellarium-0.10.4.ebuild')
-rw-r--r--sci-astronomy/stellarium/stellarium-0.10.4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-astronomy/stellarium/stellarium-0.10.4.ebuild b/sci-astronomy/stellarium/stellarium-0.10.4.ebuild
index 77e48cd3d679..a0e8c1214dbd 100644
--- a/sci-astronomy/stellarium/stellarium-0.10.4.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.10.4.ebuild,v 1.3 2010/04/18 17:15:55 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.10.4.ebuild,v 1.4 2010/04/29 00:20:36 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils
@@ -42,6 +42,10 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
x11-libs/libXt"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch # bug #317465
+}
+
src_configure() {
mycmakeargs="$mycmakeargs $(cmake-utils_use_enable nls NLS)"
CMAKE_IN_SOURCE_BUILD=1 cmake-utils_src_configure