summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-17 08:57:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-17 08:57:32 +0000
commitd85a78b5a08c18b5824019bb0a038e22a0986e24 (patch)
tree58c8d3adbee207700a38102c92a78dadd9e8d6a9 /sci-astronomy/skycat
parentVersion bump, thanks to Matthias Schwarzott (bug #227733). (diff)
downloadgentoo-2-d85a78b5a08c18b5824019bb0a038e22a0986e24.tar.gz
gentoo-2-d85a78b5a08c18b5824019bb0a038e22a0986e24.tar.bz2
gentoo-2-d85a78b5a08c18b5824019bb0a038e22a0986e24.zip
Added gcc-4.3 fix, thanks to Marek Miller, bug #227531, and added missing libXext dependency
(Portage version: 2.1.5.5)
Diffstat (limited to 'sci-astronomy/skycat')
-rw-r--r--sci-astronomy/skycat/ChangeLog8
-rw-r--r--sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch (renamed from sci-astronomy/skycat/files/skycat-3.0.1-gcc41.patch)12
-rw-r--r--sci-astronomy/skycat/skycat-3.0.1.ebuild7
3 files changed, 23 insertions, 4 deletions
diff --git a/sci-astronomy/skycat/ChangeLog b/sci-astronomy/skycat/ChangeLog
index 0a4975777af9..ef30d4563c9b 100644
--- a/sci-astronomy/skycat/ChangeLog
+++ b/sci-astronomy/skycat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/skycat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.1 2008/04/11 11:29:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.2 2008/06/17 08:57:32 bicatali Exp $
+
+ 17 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/skycat-3.0.1-gcc41.patch, +files/skycat-3.0.1-gcc43.patch,
+ skycat-3.0.1.ebuild:
+ Added gcc-4.3 fix, thanks to Marek Miller, bug #227531, and added
+ missing libXext dependency
*skycat-3.0.1 (11 Apr 2008)
diff --git a/sci-astronomy/skycat/files/skycat-3.0.1-gcc41.patch b/sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch
index 53284a650825..c245a0d81fce 100644
--- a/sci-astronomy/skycat/files/skycat-3.0.1-gcc41.patch
+++ b/sci-astronomy/skycat/files/skycat-3.0.1-gcc43.patch
@@ -372,3 +372,15 @@
private:
int socketFd_; // listen socket
+--- cat/generic/AstroQuery.h.orig 2008-06-16 17:14:15.000000000 +0000
++++ cat/generic/AstroQuery.h 2008-06-16 17:14:32.000000000 +0000
+@@ -16,6 +16,8 @@
+ */
+
+
++
++#include <cstring>
+ #include <cstdio>
+ #include "WorldOrImageCoords.h"
+
+
diff --git a/sci-astronomy/skycat/skycat-3.0.1.ebuild b/sci-astronomy/skycat/skycat-3.0.1.ebuild
index 31a7474bcf30..472bff1a6aa1 100644
--- a/sci-astronomy/skycat/skycat-3.0.1.ebuild
+++ b/sci-astronomy/skycat/skycat-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.1.ebuild,v 1.1 2008/04/11 11:29:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.1.ebuild,v 1.2 2008/06/17 08:57:32 bicatali Exp $
inherit eutils autotools
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="threads"
-DEPEND=">=dev-tcltk/tclx-2.4
+DEPEND="x11-libs/libXext
+ >=dev-tcltk/tclx-2.4
>=dev-tcltk/blt-2.4
>=dev-tcltk/itcl-3.3
>=dev-tcltk/iwidgets-4.0.1
@@ -25,7 +26,7 @@ src_unpack() {
# fix buggy tcl.m4 for bash3
epatch "${FILESDIR}"/${P}-m4.patch
# fix old style headers, set as error by new g++
- epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
eautoconf
}