summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-28 17:39:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-28 17:39:02 +0000
commite9c82457807e7abab29fbf45cef41e3bfb8c31ff (patch)
tree8729df9e4bca350b3f0df3355eade9514b96d8b5 /sci-astronomy/sextractor
parentRemove old. (diff)
downloadgentoo-2-e9c82457807e7abab29fbf45cef41e3bfb8c31ff.tar.gz
gentoo-2-e9c82457807e7abab29fbf45cef41e3bfb8c31ff.tar.bz2
gentoo-2-e9c82457807e7abab29fbf45cef41e3bfb8c31ff.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/sextractor')
-rw-r--r--sci-astronomy/sextractor/ChangeLog8
-rw-r--r--sci-astronomy/sextractor/files/sextractor-configure.patch84
-rw-r--r--sci-astronomy/sextractor/sextractor-2.8.6.ebuild52
3 files changed, 143 insertions, 1 deletions
diff --git a/sci-astronomy/sextractor/ChangeLog b/sci-astronomy/sextractor/ChangeLog
index 869ac8652218..ba7cf2893a09 100644
--- a/sci-astronomy/sextractor/ChangeLog
+++ b/sci-astronomy/sextractor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/sextractor
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/sextractor/ChangeLog,v 1.1 2009/02/17 20:44:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/sextractor/ChangeLog,v 1.2 2009/07/28 17:39:02 bicatali Exp $
+
+*sextractor-2.8.6 (28 Jul 2009)
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +sextractor-2.8.6.ebuild, +files/sextractor-configure.patch:
+ Version bump
*sextractor-2.5.0 (17 Feb 2009)
diff --git a/sci-astronomy/sextractor/files/sextractor-configure.patch b/sci-astronomy/sextractor/files/sextractor-configure.patch
new file mode 100644
index 000000000000..dc8957ba0a9b
--- /dev/null
+++ b/sci-astronomy/sextractor/files/sextractor-configure.patch
@@ -0,0 +1,84 @@
+--- configure.ac.orig 2009-04-09 14:28:38.000000000 +0100
++++ configure.ac 2009-07-28 18:25:38.000000000 +0100
+@@ -22,42 +22,19 @@
+ # Include macros
+ sinclude(acx_atlas.m4)
+ sinclude(acx_fftw.m4)
+-sinclude(acx_prog_cc_optim.m4)
+ sinclude(acx_pthread.m4)
+ sinclude(acx_urbi_resolve_dir.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS and LDFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+ # Checks for programs.
+ # GCC is chosen last because it is likely to yield less optimized code
+ AC_LANG(C)
+-AC_PROG_CC([$cclist])
++AC_PROG_CC
+ # C Compiler: Check that it is ANSI C and POSIX-compliant
+ AM_PROG_CC_STDC
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_DISABLE_STATIC
+ #AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
+@@ -160,17 +137,6 @@
+ use_gprof="no"
+ AC_MSG_RESULT([no]))
+
+-# Enable static linking
+-AC_MSG_CHECKING([static linking])
+-AC_ARG_ENABLE(static,
+- [AC_HELP_STRING([--enable-static],
+- [Enable static linking \
+-(off by default)])],
+- use_static="yes"
+- AC_MSG_RESULT([yes]),
+- use_static="no"
+- AC_MSG_RESULT([no]))
+-
+ ################# Actions to complete in case of multhreading ################
+ AC_DEFINE_UNQUOTED(THREADS_NMAX, $n_pthreads,[Maximum number of POSIX threads])
+ if test "$use_pthreads" = "yes"; then
+@@ -205,19 +171,9 @@
+
+ # Link with gprof option
+ if test "$use_gprof" = "yes"; then
+- if test "$use_icc" = "yes"; then
+- CFLAGS="$CFLAGS -pq"
+- else
+- CFLAGS="$CFLAGS -pg"
+- fi
+ use_static="no"
+ fi
+
+-# Static linking option
+-if test "$use_static" = "yes"; then
+- LDFLAGS="-static -shared-libgcc $LDFLAGS"
+-fi
+-
+ # Override automatic CFLAGS and LDFLAGS with those of user
+ #if test -n "$mycflags"; then
+ #CFLAGS="$mycflags"
diff --git a/sci-astronomy/sextractor/sextractor-2.8.6.ebuild b/sci-astronomy/sextractor/sextractor-2.8.6.ebuild
new file mode 100644
index 000000000000..53d04ec30f47
--- /dev/null
+++ b/sci-astronomy/sextractor/sextractor-2.8.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/sextractor/sextractor-2.8.6.ebuild,v 1.1 2009/07/28 17:39:02 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Extract catalogs of sources from astronomical FITS images."
+HOMEPAGE="http://astromatic.iap.fr/software/sextractor"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads"
+
+RDEPEND="virtual/cblas
+ >=sci-libs/lapack-atlas-3.8.0
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ # gentoo uses cblas instead of ptcblas (linked to threaded with eselect)
+ sed -i \
+ -e 's/ptcblas/cblas/g' \
+ acx_atlas.m4 || die "sed acx_atlas.m4 failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-atlas="/usr/$(get_libdir)/lapack/atlas" \
+ $(use_enable threads)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog HISTORY README THANKS
+ CONFDIR=/usr/share/sextractor
+ insinto ${CONFDIR}
+ doins config/* || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/* || die
+ fi
+}
+
+pkg_postinst() {
+ elog "SExtractor examples configuration files are located"
+ elog "in ${CONFDIR} and are not loaded anymore by default."
+}