summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-04-16 16:13:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-04-16 16:13:55 +0000
commitfa39a28be0aceacd61b8ec6df3221dac84d0dba2 (patch)
tree2b9fd2e2e0d687a6f1bd5a62cf8a3a0350e7c8fe /sci-astronomy/ds9
parentAdd ~sparc keyword at developer's request --- Bug #216120, which please see. (diff)
downloadgentoo-2-fa39a28be0aceacd61b8ec6df3221dac84d0dba2.tar.gz
gentoo-2-fa39a28be0aceacd61b8ec6df3221dac84d0dba2.tar.bz2
gentoo-2-fa39a28be0aceacd61b8ec6df3221dac84d0dba2.zip
Version bump, with gcc-4.3 patch and adapted bug #189118 patch to avoid emacs dependency
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'sci-astronomy/ds9')
-rw-r--r--sci-astronomy/ds9/ChangeLog10
-rw-r--r--sci-astronomy/ds9/ds9-5.1.ebuild6
-rw-r--r--sci-astronomy/ds9/ds9-5.2.ebuild67
-rw-r--r--sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch4
-rw-r--r--sci-astronomy/ds9/files/ds9-5.2-Makefile.patch39
-rw-r--r--sci-astronomy/ds9/files/ds9-5.2-gcc43.patch208
6 files changed, 328 insertions, 6 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
index 7e702d4cd8f7..05ea8e739b50 100644
--- a/sci-astronomy/ds9/ChangeLog
+++ b/sci-astronomy/ds9/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-astronomy/ds9
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.8 2008/02/14 23:32:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.9 2008/04/16 16:13:55 bicatali Exp $
+
+*ds9-5.2 (16 Apr 2008)
+
+ 16 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/ds9-5.1-gcc4.2-x86.patch, +files/ds9-5.2-Makefile.patch,
+ +files/ds9-5.2-gcc43.patch, ds9-5.1.ebuild, +ds9-5.2.ebuild:
+ Version bump, with gcc-4.3 patch and adapted bug #189118 patch to avoid
+ emacs dependency
14 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
-files/ds9-5.0-Makefile.patch, +files/ds9-5.1-tk-gif.patch,
diff --git a/sci-astronomy/ds9/ds9-5.1.ebuild b/sci-astronomy/ds9/ds9-5.1.ebuild
index a6e72148ece7..72f3c7647996 100644
--- a/sci-astronomy/ds9/ds9-5.1.ebuild
+++ b/sci-astronomy/ds9/ds9-5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.1.ebuild,v 1.3 2008/02/14 23:32:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.1.ebuild,v 1.4 2008/04/16 16:13:55 bicatali Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -15,7 +15,6 @@ RDEPEND="x11-libs/libX11
x11-libs/libXdmcp
x11-libs/libXau"
DEPEND="${RDEPEND}
- || ( virtual/emacs virtual/xemacs )
app-arch/zip"
RESTRICT="strip test mirror"
@@ -34,6 +33,9 @@ src_unpack() {
fi
# security fix in embedded tk (bug #208464)
epatch "${FILESDIR}"/${P}-tk-gif.patch
+
+ # remove build-time dependency on etags (i.e. emacs or xemacs)
+ sed -i -e '/^all/s/TAGS//' saotk/*/Makefile || die "sed failed"
}
src_compile() {
diff --git a/sci-astronomy/ds9/ds9-5.2.ebuild b/sci-astronomy/ds9/ds9-5.2.ebuild
new file mode 100644
index 000000000000..02ad7c3c6dde
--- /dev/null
+++ b/sci-astronomy/ds9/ds9-5.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.2.ebuild,v 1.1 2008/04/16 16:13:55 bicatali Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Data visualization application for astronomical FITS images"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXau"
+DEPEND="${RDEPEND}
+ app-arch/zip"
+
+S="${WORKDIR}/sao${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+ # patch to fix and speed up compilation (no man pages generation)
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ # fix stack smashing on x86 with gcc-4.2
+ use x86 && epatch "${FILESDIR}"/${P}-gcc4.2-x86.patch
+
+ # remove build-time dependency on etags (i.e. emacs or xemacs)
+ sed -i -e '/^all/s/TAGS//' saotk/*/Makefile || die "sed failed"
+
+ # remove forced compilers and let defined ones propagate
+ sed -i -e '/^CC[[:space:]]/d' '/^CXX[[:space:]]/d' make.*
+}
+
+src_compile() {
+ local ds9arch
+ case ${ARCH} in
+ x86) ds9arch=linux ;;
+ amd64) ds9arch=linux64 ;;
+ ppc) ds9arch=linuxppc ;;
+ x86-fbsd) ds9arch=freebsd ;;
+ *) die "ds9 not supported upstream for this architecture";;
+ esac
+ ln -s make.${ds9arch} make.include
+
+ # This is a long and fragile compilation
+ # which recompiles tcl/tk, tkimg, blt, funtools,
+ # and a lot of other packages
+ emake -j1 OPTS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install () {
+ dobin bin/ds9 || die "failed installing ds9 binary"
+ dobin bin/xpa* || die "failed installing xpa* binaries"
+ doman man/man?/xpa* || die " failed installing man pages"
+ dodoc README acknowledgement || die "failed installing basic doc"
+ if use doc; then
+ dohtml -r doc/* || die "failed installing html doc"
+ fi
+}
diff --git a/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch b/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
index 99465caaec79..ce87e11cde1c 100644
--- a/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
+++ b/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
@@ -1,13 +1,11 @@
diff -Naur saods9/make.linux saods9.new/make.linux
--- saods9/make.linux 2007-12-18 17:54:57.000000000 -0500
+++ saods9.new/make.linux 2008-01-23 08:58:46.000000000 -0500
-@@ -9,15 +9,15 @@
+@@ -9,15 +9,13 @@
# note: bug with gcc 4.1 and 4.2
# can't use -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
-+CXX = g++
+CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
-+CC = gcc
+CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
+
#CXX = g++
diff --git a/sci-astronomy/ds9/files/ds9-5.2-Makefile.patch b/sci-astronomy/ds9/files/ds9-5.2-Makefile.patch
new file mode 100644
index 000000000000..b92a5cf56e75
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.2-Makefile.patch
@@ -0,0 +1,39 @@
+--- Makefile.orig 2008-04-16 13:43:29.417500857 +0000
++++ Makefile 2008-04-16 14:03:38.346474803 +0000
+@@ -237,23 +237,23 @@
+ tcl : FORCE
+ @echo "Installing Tcl..."
+ cd $(TCLDIRDIR); CC='$(CC)' CFLAGS='$(OPTS) $(TCLOPTS)' LDFLAGS='$(LIBS)' ./configure $(TCLFLAGS) --disable-shared
+- cd $(TCLDIRDIR); $(MAKE) install
++ cd $(TCLDIRDIR); $(MAKE) install-binaries install-libraries
+
+ tk : FORCE
+ @echo "Installing Tk..."
+ cd $(TKDIRDIR); CC='$(CC)' CFLAGS='$(OPTS) $(TCLOPTS)' LDFLAGS='$(LIBS)' ./configure $(TCLFLAGS) --disable-shared
+- cd $(TKDIRDIR); $(MAKE) install
++ cd $(TKDIRDIR); $(MAKE) install-binaries install-libraries
+ $(RM) -r lib/$(TKVER)/demos
+
+ tktable : FORCE
+ @echo "Installing TkTable..."
+ cd $(TKTABLEDIR); CC='$(CC)' CFLAGS='$(OPTS)' LDFLAGS='$(LIBS)' ./configure $(TKTABLEFLAGS) --disable-shared
+- cd $(TKTABLEDIR); $(MAKE); $(MAKE) install
++ cd $(TKTABLEDIR); $(MAKE); $(MAKE) install-binaries install-libraries
+
+ tcllib : FORCE
+ @echo "Installing TclLib..."
+ cd $(TCLLIBDIR); ./configure $(TCLLIBFLAGS)
+- cd $(TCLLIBDIR); $(MAKE) install
++ cd $(TCLLIBDIR); $(MAKE) install-libraries
+
+ tkcon : FORCE
+ @echo "Installing TkCon..."
+@@ -295,7 +295,7 @@
+ @echo "Installing XPA..."
+ cd $(XPADIR); CC='$(CC)' CFLAGS='$(OPTS)' LDFLAGS='$(OPTS) $(LIBS)' ./configure $(XPAFLAGS) --disable-shared
+ cd $(XPADIR); $(MAKE); $(MAKE) install
+- cd bin; $(STRIP) xpa*
++
+
+ iis : FORCE
+ @echo "Installing IIS..."
diff --git a/sci-astronomy/ds9/files/ds9-5.2-gcc43.patch b/sci-astronomy/ds9/files/ds9-5.2-gcc43.patch
new file mode 100644
index 000000000000..71d2db77028d
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.2-gcc43.patch
@@ -0,0 +1,208 @@
+--- iis/iistcl.C.orig 2008-04-16 13:53:34.315972056 +0000
++++ iis/iistcl.C 2008-04-16 13:54:57.634895375 +0000
+@@ -4,7 +4,7 @@
+
+ #include <ctype.h>
+ #include <string.h>
+-
++#include <cstdlib>
+ #include <iostream>
+ #include <sstream>
+ using namespace std;
+--- saotk/widget/ps.C.orig 2008-04-16 14:09:20.865993878 +0000
++++ saotk/widget/ps.C 2008-04-16 14:10:04.020453111 +0000
+@@ -4,6 +4,7 @@
+
+ #include "ps.h"
+ #include "util.h"
++#include <cstring>
+
+ Filter::Filter()
+ {
+--- saotk/frame/callback.C.orig 2008-04-16 14:23:03.661659706 +0000
++++ saotk/frame/callback.C 2008-04-16 14:36:52.264879112 +0000
+@@ -2,8 +2,8 @@
+ // Smithsonian Astrophysical Observatory, Cambridge, MA, USA
+ // For conditions of distribution and use, see copyright notice in "copyright"
+
+-#include <string.h>
+-#include <iostream.h>
++#include <cstring>
++#include <iostream>
+
+ #include "callback.h"
+
+--- saotk/frame/ciaoparser.C.orig 2008-04-16 15:12:42.535454290 +0000
++++ saotk/frame/ciaoparser.C 2008-04-16 15:13:18.023725663 +0000
+@@ -128,9 +128,9 @@
+
+ #define FITSPTR (fr->findFits(1))
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "fitsimage.h"
+--- saotk/frame/ds9parser.C.orig 2008-04-16 15:12:42.535454290 +0000
++++ saotk/frame/ds9parser.C 2008-04-16 15:13:40.601718953 +0000
+@@ -333,9 +333,9 @@
+ #define FITSPTR (fr->findFits(globalTile))
+ #define DISCARD_(x) {yyclearin; mkDiscard(x);}
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "fitsimage.h"
+--- saotk/frame/fitsdata.C.orig 2008-04-16 15:09:33.746979438 +0000
++++ saotk/frame/fitsdata.C 2008-04-16 15:11:28.432297279 +0000
+@@ -2,11 +2,11 @@
+ // Smithsonian Astrophysical Observatory, Cambridge, MA, USA
+ // For conditions of distribution and use, see copyright notice in "copyright"
+
+-#include <stdlib.h>
+-#include <limits.h>
+-#include <float.h>
+-#include <iostream.h>
+-#include <math.h>
++#include <cstdlib>
++#include <climits>
++#include <cfloat>
++#include <iostream>
++#include <cmath>
+
+ #include "fitsdata.h"
+ #include "colorscale.h"
+--- saotk/frame/inversescale.C.orig 2008-04-16 15:12:42.539452518 +0000
++++ saotk/frame/inversescale.C 2008-04-16 15:13:56.113594982 +0000
+@@ -2,8 +2,8 @@
+ // Smithsonian Astrophysical Observatory, Cambridge, MA, USA
+ // For conditions of distribution and use, see copyright notice in "copyright"
+
+-#include <iostream.h>
+-#include <math.h>
++#include <iostream>
++#include <cmath>
+
+ #include "inversescale.h"
+ #include "framebase.h"
+--- saotk/frame/parser.C.orig 2008-04-16 15:12:42.539452518 +0000
++++ saotk/frame/parser.C 2008-04-16 15:14:20.254970721 +0000
+@@ -708,9 +708,9 @@
+
+ #define FITSPTR (fr->findFits(1))
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "frame.h"
+--- saotk/frame/prosparser.C.orig 2008-04-16 15:12:42.543450746 +0000
++++ saotk/frame/prosparser.C 2008-04-16 15:14:40.360116448 +0000
+@@ -155,9 +155,9 @@
+ #define FITSPTR (fr->findFits(1))
+ #define DISCARD_(x) {yyclearin; prosDiscard(x);}
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "fitsimage.h"
+--- saotk/frame/saoparser.C.orig 2008-04-16 15:12:42.547448974 +0000
++++ saotk/frame/saoparser.C 2008-04-16 15:14:56.133015294 +0000
+@@ -121,9 +121,9 @@
+ #define FITSPTR (fr->findFits(1))
+ #define DISCARD_(x) {yyclearin; saoDiscard(x);}
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "fitsimage.h"
+--- saotk/frame/tngparser.C.orig 2008-04-16 15:12:42.547448974 +0000
++++ saotk/frame/tngparser.C 2008-04-16 15:15:11.549893852 +0000
+@@ -167,9 +167,9 @@
+ #define FITSPTR (fr->findFits(1))
+ #define DISCARD_(x) {yyclearin; tngDiscard(x);}
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "fitsimage.h"
+--- saotk/frame/xyparser.C.orig 2008-04-16 15:12:42.551447202 +0000
++++ saotk/frame/xyparser.C 2008-04-16 15:15:28.970886617 +0000
+@@ -200,9 +200,9 @@
+
+ #define FITSPTR (fr->findFits(1))
+
+-#include <math.h>
+-#include <string.h>
+-#include <iostream.h>
++#include <cmath>
++#include <cstring>
++#include <iostream>
+
+ #include "framebase.h"
+ #include "fitsimage.h"
+--- saotk/colorbar/colorbarbase.C.orig 2008-04-16 15:41:10.236325709 +0000
++++ saotk/colorbar/colorbarbase.C 2008-04-16 15:33:33.482296780 +0000
+@@ -11,6 +11,7 @@
+ #include <X11/Xutil.h>
+
+ #include "parser.H"
++#include <cstdlib>
+
+ // Parser Stuff
+ #undef yyFlexLexer
+--- saotk/colorbar/colorbar.C.orig 2008-04-16 15:27:48.890467306 +0000
++++ saotk/colorbar/colorbar.C 2008-04-16 15:28:09.291629902 +0000
+@@ -2,8 +2,8 @@
+ // Smithsonian Astrophysical Observatory, Cambridge, MA, USA
+ // For conditions of distribution and use, see copyright notice in "copyright"
+
+-#include <stdlib.h>
+-#include <string.h>
++#include <cstdlib>
++#include <cstring>
+
+ #include "colorbar.h"
+ #include "util.h"
+--- saotk/util/conputs.C.orig 2008-04-16 15:41:48.354497940 +0000
++++ saotk/util/conputs.C 2008-04-16 15:42:01.775262745 +0000
+@@ -1,3 +1,4 @@
++#include <cstring>
+ #include <iostream>
+ using namespace std;
+
+--- ds9/ds9.C.orig 2008-04-16 15:45:04.281663192 +0000
++++ ds9/ds9.C 2008-04-16 15:45:17.622423439 +0000
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include <iostream>
+ using namespace std;
+