summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-17 16:33:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-17 16:33:48 +0000
commitf351178fd99dc5890bc829bda3944d68c74a5419 (patch)
tree52473838885cdb42f72e9ab5e05e3da6a7900130 /sci-astronomy/ds9
parentversion bump (diff)
downloadgentoo-2-f351178fd99dc5890bc829bda3944d68c74a5419.tar.gz
gentoo-2-f351178fd99dc5890bc829bda3944d68c74a5419.tar.bz2
gentoo-2-f351178fd99dc5890bc829bda3944d68c74a5419.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/ds9')
-rw-r--r--sci-astronomy/ds9/ChangeLog9
-rw-r--r--sci-astronomy/ds9/ds9-5.5.ebuild62
-rw-r--r--sci-astronomy/ds9/files/ds9-5.5-main.patch226
-rw-r--r--sci-astronomy/ds9/files/ds9-5.5-makefile.patch27
-rw-r--r--sci-astronomy/ds9/files/ds9-5.5-src.patch50
5 files changed, 373 insertions, 1 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
index c116e8d5a8d6..4a3c9ddd6306 100644
--- a/sci-astronomy/ds9/ChangeLog
+++ b/sci-astronomy/ds9/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/ds9
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.15 2009/01/09 22:45:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.16 2009/02/17 16:33:48 bicatali Exp $
+
+*ds9-5.5 (17 Feb 2009)
+
+ 17 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/ds9-5.5-main.patch, +files/ds9-5.5-makefile.patch,
+ +files/ds9-5.5-src.patch, +ds9-5.5.ebuild:
+ Version bump
09 Jan 2009; Joseph Jezak <josejx@gentoo.org> ds9-5.4.ebuild:
Marked ~ppc for bug #253299.
diff --git a/sci-astronomy/ds9/ds9-5.5.ebuild b/sci-astronomy/ds9/ds9-5.5.ebuild
new file mode 100644
index 000000000000..94520fd5ed14
--- /dev/null
+++ b/sci-astronomy/ds9/ds9-5.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.5.ebuild,v 1.1 2009/02/17 16:33:48 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Data visualization application for astronomical FITS images"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="dev-tcltk/blt
+ >=dev-tcltk/tcllib-1.10
+ >=dev-tcltk/tclxml-3.1
+ dev-tcltk/tkcon
+ >=dev-tcltk/tkimg-1.3.1
+ dev-tcltk/tktable
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/xpa
+ sci-astronomy/ast
+ sci-astronomy/funtools"
+
+DEPEND="${RDEPEND}
+ media-gfx/imagemagick
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/sao${PN}"
+
+src_prepare() {
+ # some patches are adapted from fedora
+ # most of them are to use system libraries instead of bundled-ones
+ epatch "${FILESDIR}"/${PN}-5.4-saotk.patch
+ epatch "${FILESDIR}"/${PN}-5.4-htmlwidget.patch
+ epatch "${FILESDIR}"/${P}-main.patch
+ epatch "${FILESDIR}"/${P}-src.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${PN}-5.4-gcc43.patch
+
+ # remove build-time dependency on etags (i.e. emacs or xemacs)
+ sed -i -e '/^all/s/TAGS//' saotk/*/Makefile || die "sed failed"
+
+ cp "${FILESDIR}"/make.gentoo make.include
+ use amd64 && \
+ export EXTRA_CPPFLAGS="-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+ export OPTS="${CXXFLAGS}"
+}
+
+src_install () {
+ dobin bin/ds9 || die "failed installing ds9 binary"
+ insinto /usr/share/${PN}
+ doins -r ds9/zipdir/zvfsmntpt/* || die
+ dodoc README acknowledgement || die "failed installing basic doc"
+ dosym ../../${PN}/doc /usr/share/doc/${PF}/html
+ convert doc/sun.gif ds9.png
+ doicon ds9.png
+ make_desktop_entry ds9 "SAOImage DS9"
+}
diff --git a/sci-astronomy/ds9/files/ds9-5.5-main.patch b/sci-astronomy/ds9/files/ds9-5.5-main.patch
new file mode 100644
index 000000000000..c97e5010df42
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.5-main.patch
@@ -0,0 +1,226 @@
+diff -Nur saods9.orig/ds9/ds9.C saods9/ds9/ds9.C
+--- saods9.orig/ds9/ds9.C 2009-02-16 17:06:50.000000000 +0000
++++ saods9/ds9/ds9.C 2009-02-16 17:07:42.000000000 +0000
+@@ -11,8 +11,8 @@
+
+ void TclSetStartupScriptFileName(const char*);
+
+- int Zvfs_Init(Tcl_Interp*);
+- int Zvfs_Mount(Tcl_Interp*, char*, char *);
++/* int Zvfs_Init(Tcl_Interp*);
++ int Zvfs_Mount(Tcl_Interp*, char*, char *);*/
+
+ int Blt_Init(Tcl_Interp*);
+ int Tktable_Init(Tcl_Interp*);
+@@ -64,15 +64,15 @@
+ appname = dupstr(argv[0]);
+
+ // set default encoding dir
+- Tcl_SetDefaultEncodingDir("./zvfsmntpt/tcl8.4");
++ //Tcl_SetDefaultEncodingDir("./zvfsmntpt/tcl8.4");
+
+ // so that tcl and tk know where to find their libs
+ // we do it here before InitLibraryPath is called
+- putenv((char*)"TCL_LIBRARY=./zvfsmntpt/tcl8.4");
+- putenv((char*)"TK_LIBRARY=./zvfsmntpt/tk8.4");
++ //putenv((char*)"TCL_LIBRARY=./zvfsmntpt/tcl8.4");
++ //putenv((char*)"TK_LIBRARY=./zvfsmntpt/tk8.4");
+
+ // invoke startup script
+- TclSetStartupScriptFileName("./zvfsmntpt/src/ds9.tcl");
++ TclSetStartupScriptFileName("/usr/share/ds9/src/ds9.tcl");
+ }
+
+ Tcl_Interp *global_interp;
+@@ -91,13 +91,13 @@
+ // We have to initialize the virtual filesystem before calling
+ // Tcl_Init(). Otherwise, Tcl_Init() will not be able to find
+ // its startup script files.
+- if (Zvfs_Init(interp) == TCL_ERROR)
++/* if (Zvfs_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "zvfs", Zvfs_Init,
+ (Tcl_PackageInitProc*)NULL);
+-
++*/
+ // find current working directory, and set as mount point
+- {
++/* {
+ Tcl_DString pwd;
+ Tcl_DStringInit(&pwd);
+ Tcl_GetCwd(interp, &pwd);
+@@ -113,7 +113,7 @@
+ #endif
+ Tcl_DStringFree(&pwd);
+ }
+-
++*/
+ // Initialize Tcl and Tk
+ if (Tcl_Init(interp))
+ return TCL_ERROR;
+@@ -121,7 +121,7 @@
+ // Tk
+ if (Tk_Init(interp))
+ return TCL_ERROR;
+- Tcl_StaticPackage(interp,"Tk", Tk_Init, Tk_SafeInit);
++ //Tcl_StaticPackage(interp,"Tk", Tk_Init, Tk_SafeInit);
+
+ {
+ Tcl_DString pwd;
+@@ -131,7 +131,7 @@
+ }
+
+ // Blt
+- if (Blt_Init(interp) == TCL_ERROR)
++ /*if (Blt_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "BLT", Blt_Init,
+ (Tcl_PackageInitProc*)NULL);
+@@ -140,7 +140,7 @@
+ if (Tktable_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "Tktable", Tktable_Init,
+- (Tcl_PackageInitProc*)NULL);
++ (Tcl_PackageInitProc*)NULL); */
+
+ // Checkdns
+ if (Checkdns_Init(interp) == TCL_ERROR)
+@@ -161,10 +161,10 @@
+ (Tcl_PackageInitProc*)NULL);
+
+ // Tclxpa
+- if (Tclxpa_Init(interp) == TCL_ERROR)
++/* if (Tclxpa_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "Tclxpa", Tclxpa_Init,
+- (Tcl_PackageInitProc*)NULL);
++ (Tcl_PackageInitProc*)NULL);*/
+
+ // IIS
+ if (Iis_Init(interp) == TCL_ERROR)
+@@ -179,7 +179,7 @@
+ (Tcl_PackageInitProc*)NULL);
+
+ // Tkimg
+- if (Tkimg_Init(interp) == TCL_ERROR)
++/* if (Tkimg_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "img",
+ Tkimg_Init,(Tcl_PackageInitProc*)NULL);
+@@ -254,7 +254,7 @@
+ if (Tkimgwindow_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "window", Tkimgwindow_Init,
+- (Tcl_PackageInitProc*)NULL);
++ (Tcl_PackageInitProc*)NULL);*/
+
+ #ifdef _MACOSX
+ if (Tkmacosx_Init(interp) == TCL_ERROR)
+@@ -271,11 +271,11 @@
+ #endif
+
+ // Variables
+- Tcl_SetVar(interp, "auto_path", "./zvfsmntpt/tcl8.4 ./zvfsmntpt/tk8.4 ./zvfsmntpt/blt2.4 ./zvfsmntpt/tcllib1.6 ./zvfsmntpt/src", TCL_GLOBAL_ONLY);
++/* Tcl_SetVar(interp, "auto_path", "./zvfsmntpt/tcl8.4 ./zvfsmntpt/tk8.4 ./zvfsmntpt/blt2.4 ./zvfsmntpt/tcllib1.6 ./zvfsmntpt/src", TCL_GLOBAL_ONLY);
+ Tcl_SetVar(interp, "tcl_libPath", "./zvfsmntpt/tcl8.4", TCL_GLOBAL_ONLY);
+ Tcl_SetVar(interp, "blt_library", "./zvfsmntpt/blt2.4", TCL_GLOBAL_ONLY);
+ Tcl_SetVar(interp, "blt_libPath", "./zvfsmntpt/blt2.4", TCL_GLOBAL_ONLY);
+- Tcl_SetVar2(interp, "env", "TK_TABLE_LIBRARY", "", TCL_GLOBAL_ONLY);
++ Tcl_SetVar2(interp, "env", "TK_TABLE_LIBRARY", "", TCL_GLOBAL_ONLY);*/
+
+ //Tcl_SetVar(interp, "tcl_rcFileName", "~/.wishrc", TCL_GLOBAL_ONLY);
+
+diff -Nur saods9.orig/ds9/Makefile saods9/ds9/Makefile
+--- saods9.orig/ds9/Makefile 2009-02-16 17:06:50.000000000 +0000
++++ saods9/ds9/Makefile 2009-02-16 17:33:47.000000000 +0000
+@@ -4,13 +4,7 @@
+ #--------------------------defines
+
+ ZDIR = zipdir/zvfsmntpt
+-FILES = $(ZDIR)/$(TCLVER) \
+- $(ZDIR)/$(TKVER) \
+- $(ZDIR)/$(BLTVER) \
+- $(ZDIR)/$(TCLLIBVER) \
+- $(ZDIR)/$(TKCONVER) \
+- $(ZDIR)/$(XMLRPCVER) \
+- $(ZDIR)/src \
++FILES = $(ZDIR)/src \
+ $(ZDIR)/msgs \
+ $(ZDIR)/doc \
+ $(ZDIR)/template
+@@ -23,37 +17,13 @@
+ ../lib/libsaotk.a \
+ ../lib/libtkhtml.a \
+ ../lib/libtkmpeg.a \
+- ../lib/$(TKIMGVER)/libtkimgwindow1.3.a \
+- ../lib/$(TKIMGVER)/libtkimgjpeg1.3.a \
+- ../lib/$(TKIMGVER)/libjpegtcl1.0.a \
+- ../lib/$(TKIMGVER)/libtkimgtiff1.3.a \
+- ../lib/$(TKIMGVER)/libtifftcl3.6.1.a \
+- ../lib/$(TKIMGVER)/libtkimgpng1.3.a \
+- ../lib/$(TKIMGVER)/libpngtcl1.2.6.a \
+- ../lib/$(TKIMGVER)/libtkimgppm1.3.a \
+- ../lib/$(TKIMGVER)/libtkimggif1.3.a \
+- ../lib/$(TKIMGVER)/libtkimgbmp1.3.a \
+- ../lib/$(TKIMGVER)/libtkimgxbm1.3.a \
+- ../lib/$(TKIMGVER)/libzlibtcl1.2.1.a \
+- ../lib/$(TKIMGVER)/libtkimg1.3.a \
+- ../lib/$(TKTABLEVER)/libTktable2.9.a \
+- ../lib/libfuntools.a \
+ ../lib/librice.a \
+ ../lib/libhcomp.a \
+ ../lib/libplio.a \
+- ../lib/libast.a \
+ ../lib/libsaotk.a \
+- ../lib/libwcs.a \
+ ../lib/libsla.a \
+- ../lib/libzvfs.a \
+- ../lib/libzip.a \
+- ../lib/libz.a \
+- ../lib/libxpa.a \
+ ../lib/libiis.a \
+- ../lib/libcheckdns.a \
+- ../lib/libBLT24.a \
+- ../lib/libtk8.4.a \
+- ../lib/libtcl8.4.a
++ ../lib/libcheckdns.a
+ endif
+
+ ifeq ($(OS),windows)
+@@ -168,14 +138,9 @@
+ ds9.zip : $(FILES)
+ cd zipdir; zip -r9 ../ds9.zip *
+ else
+-ds9 : null.zip ds9Base $(FILES)
++ds9 : ds9Base $(FILES)
+ $(RM) $@
+- cp ds9Base ds9.zip
+- $(STRIP) ds9.zip
+- cat null.zip >> ds9.zip
+- cd zipdir; zip -rA9 ../ds9.zip *
+- mv ds9.zip ds9
+- cp ds9 ../bin/.
++ cp ds9Base ../bin/ds9
+
+ debug : null.zip ds9Base $(FILES)
+ $(RM) $@
+@@ -382,7 +347,18 @@
+ /usr/lib/amd64/libdl.so
+ rm -f libstdc++.a
+ endif
+-
++# For gentoo
++ifeq ($(ARCH),gentoo)
++ds9Base : $(OBJS) $(LIBS)
++ $(RM) $@
++ $(CXX) ${OPTS} \
++ -o $@ $(OBJS) $(LIBS) \
++ -L$(X11LIB) -lX11 \
++ -ldl -lpthread \
++ -ltk -ltcl -lBLT24 \
++ -lfuntools `pkg-config --libs wcstools` -lz \
++ `ast_link`
++endif
+ #--------------------------linux
+
+ ifneq (,$(findstring linux,$(ARCH)))
diff --git a/sci-astronomy/ds9/files/ds9-5.5-makefile.patch b/sci-astronomy/ds9/files/ds9-5.5-makefile.patch
new file mode 100644
index 000000000000..f165ec831dc6
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.5-makefile.patch
@@ -0,0 +1,27 @@
+--- saods9.orig/Makefile 2009-02-16 17:06:48.000000000 +0000
++++ saods9/Makefile 2009-02-16 18:06:01.000000000 +0000
+@@ -35,8 +35,7 @@
+ --with-tk=$(root)/$(TKDIRDIR) $(XFLAGS)
+ XPAFLAGS = --prefix $(root) --with-tcl=$(root)/$(TCLDIRDIR) \
+ $(XFLAGS)
+- HTMLFLAGS = --prefix $(root) --with-tcl=$(root)/$(TCLDIR) \
+- --with-tk=$(root)/$(TKDIR) $(XFLAGS)
++ HTMLFLAGS = --prefix $(root) $(XFLAGS)
+ FUNTOOLSFLAGS = --prefix $(root) --with-zlib=../../lib/libz.a \
+ --with-wcslib=../lib/libwcs.a --enable-mainlib
+ endif
+@@ -197,11 +196,9 @@
+ all : build
+
+ build : dirs \
+- tcl tk \
+- tktable tcllib tkcon xmlrpc blt \
+- zlib \
+- tkimg tkmpeg html xpa iis checkdns \
+- funtools sla ast wcssubs rice hcompress plio $(OPTDIR) saotk zip zvfs ds9
++ xmlrpc \
++ tkmpeg html iis checkdns \
++ sla rice hcompress plio $(OPTDIR) saotk ds9
+
+ doc : FORCE
+ @echo "Making Documentation..."
diff --git a/sci-astronomy/ds9/files/ds9-5.5-src.patch b/sci-astronomy/ds9/files/ds9-5.5-src.patch
new file mode 100644
index 000000000000..559dc01e29cb
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.5-src.patch
@@ -0,0 +1,50 @@
+--- saods9.orig/src/ds9.tcl 2009-02-16 17:06:47.000000000 +0000
++++ saods9/src/ds9.tcl 2009-02-16 18:37:18.000000000 +0000
+@@ -224,25 +224,29 @@
+ # initialize, depending on how we are running: choices are zvfs, or wish
+ # for now, its not possible to change the current work directory since
+ # all of the paths are relative
+-if {![catch {package present zvfs}]} {
+- set ds9(root) "zvfsmntpt"
++if {![catch {package present checkdns}]} {
++ set ds9(root) "/usr/share/ds9"
+
+- source $ds9(root)/tcl8.4/msgcat1.3/msgcat.tcl
+- source $ds9(root)/tcl8.4/http2.5/http.tcl
+-
+- source $ds9(root)/tk8.4/tearoff.tcl
+-
+- source $ds9(root)/tcllib1.10/base64/base64.tcl
+- source $ds9(root)/tcllib1.10/log/log.tcl
+- source $ds9(root)/tcllib1.10/ftp/ftp.tcl
+- source $ds9(root)/tcllib1.10/textutil/repeat.tcl
+- source $ds9(root)/tcllib1.10/textutil/tabify.tcl
+-
+- source $ds9(root)/tkcon2.5/tkcon.tcl
+- source $ds9(root)/xmlrpc0.3/xmlrpc.tcl
+-
+- source $ds9(root)/blt2.4/graph.tcl
+- source $ds9(root)/blt2.4/tabset.tcl
++ package require msgcat
++ package require http
++ package require base64
++ package require log
++ package require ftp
++ package require textutil::repeat
++ package require textutil::tabify
++ package require tkcon
++ package require BLT
++ package require Tktable
++ package require tclxpa
++ package require img::base
++ package require img::jpeg
++ package require img::tiff
++ package require img::png
++ package require img::gif
++ package require img::ppm
++ package require img::bmp
++ package require img::xbm
++ package require img::window
+
+ source $ds9(root)/src/source.tcl
+