summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-29 18:09:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-29 18:09:11 +0000
commit508ee30f369ff943cb61e74e9ffe9b4997c9f489 (patch)
tree132d626824812a96ccfd16837bb7d23ace41dc0f /sci-astronomy/ds9
parentVersion bump, remove old. Bit-stream compatible with previous version this time. (diff)
downloadgentoo-2-508ee30f369ff943cb61e74e9ffe9b4997c9f489.tar.gz
gentoo-2-508ee30f369ff943cb61e74e9ffe9b4997c9f489.tar.bz2
gentoo-2-508ee30f369ff943cb61e74e9ffe9b4997c9f489.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/ds9')
-rw-r--r--sci-astronomy/ds9/ChangeLog10
-rw-r--r--sci-astronomy/ds9/ds9-6.0.ebuild64
-rw-r--r--sci-astronomy/ds9/files/ds9-6.0-main.patch326
3 files changed, 398 insertions, 2 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
index d15090adf90a..bcf836a61e4d 100644
--- a/sci-astronomy/ds9/ChangeLog
+++ b/sci-astronomy/ds9/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/ds9
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.22 2009/11/25 07:32:54 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.23 2010/01/29 18:09:11 bicatali Exp $
+
+*ds9-6.0 (29 Jan 2010)
+
+ 29 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> +ds9-6.0.ebuild,
+ +files/ds9-6.0-main.patch:
+ Version bump
*ds9-5.7-r2 (25 Nov 2009)
diff --git a/sci-astronomy/ds9/ds9-6.0.ebuild b/sci-astronomy/ds9/ds9-6.0.ebuild
new file mode 100644
index 000000000000..05bbc974fd97
--- /dev/null
+++ b/sci-astronomy/ds9/ds9-6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-6.0.ebuild,v 1.1 2010/01/29 18:09:11 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Data visualization application for astronomical FITS images"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="dev-tcltk/blt
+ >=dev-tcltk/tcllib-1.10
+ >=dev-tcltk/tclxml-3.1
+ dev-tcltk/tkcon
+ dev-tcltk/tkimg
+ dev-tcltk/tktable
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/xpa
+ sci-astronomy/ast
+ sci-astronomy/funtools"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/sao${PN}"
+
+src_prepare() {
+ # some patches are adapted from fedora
+ # most of them are to use system libraries instead of bundled-ones
+ epatch "${FILESDIR}"/${PN}-5.4-htmlwidget.patch
+ epatch "${FILESDIR}"/${PN}-5.7-makefile.patch
+ epatch "${FILESDIR}"/${PN}-5.7-src.patch
+ epatch "${FILESDIR}"/${PN}-6.0-main.patch
+ epatch "${FILESDIR}"/${PN}-5.7-saotk.patch
+ epatch "${FILESDIR}"/${PN}-5.7-tcl85.patch
+
+ # remove build-time dependency on etags (i.e. emacs or xemacs)
+ sed -i -e '/^all/s/TAGS//' saotk/*/Makefile || die "sed failed"
+
+ cp "${FILESDIR}"/make.gentoo make.include
+ use amd64 && \
+ export EXTRA_CPPFLAGS="-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+ export OPTS="${CXXFLAGS}"
+}
+
+src_install () {
+ newbin bin/ds9 ds9.exe || die "failed installing ds9 binary"
+ echo "#!/bin/sh" > ds9
+ echo "LD_LIBRARY_PATH=$(dir -d ${ROOT}usr/$(get_libdir)/Tclxml?.?):\${LD_LIBRARY_PATH} ds9.exe" >> ds9.sh
+ exeinto /usr/bin
+ newexe ds9.sh ds9
+ insinto /usr/share/${PN}
+ doins -r ds9/zipdir/zvfsmntpt/* || die
+ dodoc README acknowledgement || die "failed installing basic doc"
+ dosym ../../${PN}/doc /usr/share/doc/${PF}/html
+ doicon "${FILESDIR}"/${PN}.png
+ make_desktop_entry ds9 "SAOImage DS9"
+}
diff --git a/sci-astronomy/ds9/files/ds9-6.0-main.patch b/sci-astronomy/ds9/files/ds9-6.0-main.patch
new file mode 100644
index 000000000000..d941c341d374
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-6.0-main.patch
@@ -0,0 +1,326 @@
+diff -Nur saods9.orig/ds9/ds9.C saods9/ds9/ds9.C
+--- saods9.orig/ds9/ds9.C 2009-10-01 17:53:59.000000000 +0100
++++ saods9/ds9/ds9.C 2010-01-29 17:46:20.000000000 +0000
+@@ -13,8 +13,6 @@
+
+ void TclSetStartupScriptFileName(const char*);
+
+- int Zvfs_Init(Tcl_Interp*);
+- int Zvfs_Mount(Tcl_Interp*, char*, char *);
+
+ int Blt_Init(Tcl_Interp*);
+ int Tktable_Init(Tcl_Interp*);
+@@ -73,15 +71,13 @@
+ appname = dupstr(argv[0]);
+
+ // set default encoding dir
+- Tcl_SetDefaultEncodingDir("./zvfsmntpt/tcl8.4");
+
+ // so that tcl and tk know where to find their libs
+ // we do it here before InitLibraryPath is called
+- putenv((char*)"TCL_LIBRARY=./zvfsmntpt/tcl8.4");
+- putenv((char*)"TK_LIBRARY=./zvfsmntpt/tk8.4");
++
+
+ // invoke startup script
+- TclSetStartupScriptFileName("./zvfsmntpt/src/ds9.tcl");
++ TclSetStartupScriptFileName("/usr/share/ds9/src/ds9.tcl");
+ }
+
+ Tcl_Interp *global_interp;
+@@ -100,31 +96,8 @@
+ // We have to initialize the virtual filesystem before calling
+ // Tcl_Init(). Otherwise, Tcl_Init() will not be able to find
+ // its startup script files.
+- if (Zvfs_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "zvfs", Zvfs_Init,
+- (Tcl_PackageInitProc*)NULL);
+
+ // find current working directory, and set as mount point
+- {
+- Tcl_DString pwd;
+- Tcl_DStringInit(&pwd);
+- Tcl_GetCwd(interp, &pwd);
+-#ifdef ZIPFILE
+- ostringstream str;
+- str << (char *)Tcl_GetNameOfExecutable()
+- << "/../ds9.zip"
+- << ends;
+- if( Zvfs_Mount(interp, (char*)str.str().c_str(), Tcl_DStringValue(&pwd)) != TCL_OK ){
+- cerr << "ERROR: The auxiliary ds9 file 'ds9.zip' is missing. If you moved the ds9 program from its original location, please also move the zip file to the same place." << endl;
+- exit(1);
+- }
+-#else
+- Zvfs_Mount(interp, (char *)Tcl_GetNameOfExecutable(),
+- Tcl_DStringValue(&pwd));
+-#endif
+- Tcl_DStringFree(&pwd);
+- }
+
+ // Initialize Tcl and Tk
+ if (Tcl_Init(interp))
+@@ -133,7 +106,6 @@
+ // Tk
+ if (Tk_Init(interp))
+ return TCL_ERROR;
+- Tcl_StaticPackage(interp,"Tk", Tk_Init, Tk_SafeInit);
+
+ {
+ Tcl_DString pwd;
+@@ -142,18 +114,6 @@
+ Tcl_DStringFree(&pwd);
+ }
+
+- // Blt
+- if (Blt_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "BLT", Blt_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tktable
+- if (Tktable_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "Tktable", Tktable_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+ // Checkdns
+ if (Checkdns_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+@@ -171,13 +131,6 @@
+ return TCL_ERROR;
+ Tcl_StaticPackage (interp, "tkhtml", Tkhtml_Init,
+ (Tcl_PackageInitProc*)NULL);
+-
+- // Tclxpa
+- if (Tclxpa_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "Tclxpa", Tclxpa_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+ // IIS
+ if (Iis_Init(interp) == TCL_ERROR)
+ return TCL_ERROR;
+@@ -190,88 +143,6 @@
+ Tcl_StaticPackage (interp, "tkmpeg", Tkmpeg_Init,
+ (Tcl_PackageInitProc*)NULL);
+
+- // Tclxml
+- if (Tclxml_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+-
+- // Tkimg
+- if (Tkimg_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "img",
+- Tkimg_Init,(Tcl_PackageInitProc*)NULL);
+-
+- // zlibtcl
+- if (Zlibtcl_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "zlibtcl", Zlibtcl_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // jpegtcl
+- if (Jpegtcl_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "jpegtcl", Jpegtcl_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgjpeg
+- if (Tkimgjpeg_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "jpeg", Tkimgjpeg_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tifftcl
+- if (Tifftcl_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "tifftcl", Tifftcl_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgtiff
+- if (Tkimgtiff_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "tiff", Tkimgtiff_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Pngtcl
+- if (Pngtcl_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "pngtcl", Pngtcl_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgpng
+- if (Tkimgpng_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "png", Tkimgpng_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimggif
+- if (Tkimggif_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "gif", Tkimggif_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgppm
+- if (Tkimgppm_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "ppm", Tkimgppm_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgbmp
+- if (Tkimgbmp_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "bmp", Tkimgbmp_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgxbm
+- if (Tkimgxbm_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "xbm", Tkimgxbm_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+- // Tkimgwindow
+- if (Tkimgwindow_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+- Tcl_StaticPackage (interp, "window", Tkimgwindow_Init,
+- (Tcl_PackageInitProc*)NULL);
+-
+ // Signal_Ext
+ #ifndef _WIN32
+ if (Signal_ext_Init(interp) == TCL_ERROR)
+@@ -294,15 +165,6 @@
+ (Tcl_PackageInitProc*)NULL);
+ #endif
+
+- // Variables
+- Tcl_SetVar(interp, "auto_path", "./zvfsmntpt/tcl8.4 ./zvfsmntpt/tk8.4 ./zvfsmntpt/blt2.4 ./zvfsmntpt/tcllib1.6 ./zvfsmntpt/src", TCL_GLOBAL_ONLY);
+- Tcl_SetVar(interp, "tcl_libPath", "./zvfsmntpt/tcl8.4", TCL_GLOBAL_ONLY);
+- Tcl_SetVar(interp, "blt_library", "./zvfsmntpt/blt2.4", TCL_GLOBAL_ONLY);
+- Tcl_SetVar(interp, "blt_libPath", "./zvfsmntpt/blt2.4", TCL_GLOBAL_ONLY);
+- Tcl_SetVar2(interp, "env", "TK_TABLE_LIBRARY", "", TCL_GLOBAL_ONLY);
+-
+- //Tcl_SetVar(interp, "tcl_rcFileName", "~/.wishrc", TCL_GLOBAL_ONLY);
+-
+ return TCL_OK;
+ }
+
+diff -Nur saods9.orig/ds9/Makefile saods9/ds9/Makefile
+--- saods9.orig/ds9/Makefile 2010-01-12 21:24:30.000000000 +0000
++++ saods9/ds9/Makefile 2010-01-29 17:53:29.000000000 +0000
+@@ -4,12 +4,7 @@
+ #--------------------------defines
+
+ ZDIR = zipdir/zvfsmntpt
+-FFILES = $(ZDIR)/$(TCLVER) \
+- $(ZDIR)/$(TKVER) \
+- $(ZDIR)/$(BLTVER) \
+- $(ZDIR)/$(TCLLIBVER) \
+- $(ZDIR)/$(TKCONVER) \
+- $(ZDIR)/$(XMLRPCVER) \
++FFILES = \
+ $(ZDIR)/src \
+ $(ZDIR)/msgs \
+ $(ZDIR)/doc \
+@@ -30,43 +25,14 @@
+ ../lib/libsaotk.a \
+ ../lib/libtkhtml.a \
+ ../lib/libtkmpeg.a \
+- ../lib/$(TCLXMLVER)/libTclxml3.2.a \
+- ../lib/$(TKIMGVER)/libtkimgwindow1.3.a \
+- ../lib/$(TKIMGVER)/libtkimgjpeg1.3.a \
+- ../lib/$(TKIMGVER)/libjpegtcl1.0.a \
+- ../lib/$(TKIMGVER)/libtkimgtiff1.3.a \
+- ../lib/$(TKIMGVER)/libtifftcl3.6.1.a \
+- ../lib/$(TKIMGVER)/libtkimgpng1.3.a \
+- ../lib/$(TKIMGVER)/libpngtcl1.2.6.a \
+- ../lib/$(TKIMGVER)/libtkimgppm1.3.a \
+- ../lib/$(TKIMGVER)/libtkimggif1.3.a \
+- ../lib/$(TKIMGVER)/libtkimgbmp1.3.a \
+- ../lib/$(TKIMGVER)/libtkimgxbm1.3.a \
+- ../lib/$(TKIMGVER)/libzlibtcl1.2.1.a \
+- ../lib/$(TKIMGVER)/libtkimg1.3.a \
+- ../lib/$(TKTABLEVER)/libTktable2.9.a \
+- ../lib/libfuntools.a \
+ ../lib/librice.a \
+ ../lib/libhcomp.a \
+ ../lib/libplio.a \
+- ../lib/libast.a \
+- ../lib/libast_err.a \
+- ../lib/libast_grf3d.a \
+- ../lib/libast_pal.a \
+- ../lib/libast_wcslib.a \
+ ../lib/libsaotk.a \
+- ../lib/libwcs.a \
+ ../lib/libsla.a \
+- ../lib/libzvfs.a \
+- ../lib/libzip.a \
+- ../lib/libz.a \
+- ../lib/libxpa.a \
+ ../lib/libiis.a \
+ ../lib/libcheckdns.a \
+- ../lib/libsignal_ext.a \
+- ../lib/libBLT24.a \
+- ../lib/libtk8.4.a \
+- ../lib/libtcl8.4.a
++ ../lib/libsignal_ext.a
+ endif
+
+ ifeq ($(OS),windows)
+@@ -178,12 +144,9 @@
+
+ all: ds9
+
+-ds9 : ds9Base ds9.zip
++ds9 : ds9Base
+ $(RM) $@
+- cp ds9Base ds9
+- strip ds9
+- cp ds9 ../bin/.
+- cp ds9.zip ../bin/.
++ cp ds9Base ../bin/ds9
+ cd ../bin; $(CODESIGN) -s "SAOImage DS9" ds9
+
+ debug : ds9Base ds9.zip
+@@ -199,14 +162,9 @@
+
+ all: ds9
+
+-ds9 : null.zip ds9Base $(FILES)
++ds9 : ds9Base $(FILES)
+ $(RM) $@
+- cp ds9Base ds9.zip
+- strip ds9.zip
+- cat null.zip >> ds9.zip
+- cd zipdir; zip -rA9 ../ds9.zip *
+- mv ds9.zip ds9
+- cp ds9 ../bin/.
++ cp ds9Base ../bin/ds9
+
+ debug : null.zip ds9Base $(FILES)
+ $(RM) $@
+@@ -377,6 +335,23 @@
+
+ #--------------------------linux
+
++# for gentoo: get rid of bundled libs
++ifneq (,$(findstring gentoo,$(ARCH)))
++ds9Base : $(OBJS) $(LIBS)
++ $(RM) $@
++ rm -f libstdc++.a
++ ln -s `$(CXX) -print-file-name=libstdc++.a` .
++ $(CXX) $(LDFLAGS) \
++ $(OBJS) $(LIBS) -o $@ \
++ -Wl,-Bstatic -L. -lstdc++ \
++ -Wl,-Bdynamic -L$(X11LIB) -lX11 \
++ -ldl -lpthread -lxml2 \
++ -ltk -ltcl -lBLT24 \
++ -lfuntools `pkg-config --libs wcstools` -lz \
++ `ast_link`
++ rm -f libstdc++.a
++endif
++
+ ifneq (,$(findstring linux,$(ARCH)))
+ ds9Base : $(OBJS) $(LIBS)
+ $(RM) $@