summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-26 19:02:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-26 19:02:45 +0000
commita97e24ecb61c5bcb99f3cecd567b340d202238ea (patch)
treedd70085f133ec79353db9ab04f1e0cc9596a20b5 /sci-astronomy/cpl
parentstable amd64, bug 316395 (diff)
downloadgentoo-2-a97e24ecb61c5bcb99f3cecd567b340d202238ea.tar.gz
gentoo-2-a97e24ecb61c5bcb99f3cecd567b340d202238ea.tar.bz2
gentoo-2-a97e24ecb61c5bcb99f3cecd567b340d202238ea.zip
Import to the main tree and bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/cpl')
-rw-r--r--sci-astronomy/cpl/ChangeLog38
-rw-r--r--sci-astronomy/cpl/cpl-5.2.0.ebuild53
-rw-r--r--sci-astronomy/cpl/metadata.xml22
3 files changed, 113 insertions, 0 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
new file mode 100644
index 000000000000..2a8fe84f3742
--- /dev/null
+++ b/sci-astronomy/cpl/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for sci-astronomy/cpl
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.1 2010/05/26 19:02:45 bicatali Exp $
+
+*cpl-5.2.0 (26 May 2010)
+
+ 26 May 2010; Sébastien Fabbro <bicatali@gentoo.org> +cpl-5.2.0.ebuild,
+ +metadata.xml:
+ Import to the main tree and bump
+
+*cpl-5.0.1 (23 Jul 2009)
+
+ 23 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +cpl-5.0.1.ebuild:
+ Version bump
+
+*cpl-4.2.0-r2 (26 Feb 2009)
+
+ 26 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> -cpl-4.2.0-r1.ebuild,
+ +cpl-4.2.0-r2.ebuild:
+ QA and doc building
+
+ 02 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ sci-astronomy/cpl/metadata.xml:
+ Added wcs and gasgano support
+
+ 02 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org> +cpl-4.1.0.ebuild:
+ Version bump, thanks to Marek Miller
+
+ 26 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org> -cpl-3.0.ebuild,
+ +cpl-3.1.ebuild:
+ Version bump.
+
+*cpl-3.0 (15 Oct 2006)
+
+ 15 Oct 2006; Sebastien Fabbro <seb@ist.utl.pt>;
+ +cpl-3.0.ebuild, +metadata.xml.
+ Initial import.
+
diff --git a/sci-astronomy/cpl/cpl-5.2.0.ebuild b/sci-astronomy/cpl/cpl-5.2.0.ebuild
new file mode 100644
index 000000000000..bb17a56bc481
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-5.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-5.2.0.ebuild,v 1.1 2010/05/26 19:02:45 bicatali Exp $
+
+EAPI=2
+JAVA_PKG_OPT_USE=gasgano
+inherit java-pkg-opt-2
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/data-processing/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc gasgano"
+
+RDEPEND=">=sci-libs/cfitsio-3.09
+ sci-astronomy/wcslib
+ sci-libs/fftw:3.0
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+ gasgano? ( >=virtual/jdk-1.5 )"
+
+src_configure() {
+ local myconf="--without-gasgano"
+ use gasgano && \
+ myconf="--with-gasgano=/usr
+ --with-gasgano-classpath=/usr/share/gasgano/lib"
+ econf \
+ --with-cfitsio="/usr" \
+ --with-wcs="/usr" \
+ --with-fftw="/usr" \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS NEWS TODO BUGS ChangeLog
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r html || die
+ fi
+}
diff --git a/sci-astronomy/cpl/metadata.xml b/sci-astronomy/cpl/metadata.xml
new file mode 100644
index 000000000000..1b34a43fa1a1
--- /dev/null
+++ b/sci-astronomy/cpl/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The Common Pipeline Library (CPL) comprises a set of ISO-C libraries
+ that provide a comprehensive, efficient and robust software
+ toolkit. It forms a basis for the creation of automated astronomical
+ data-reduction tasks (known as "pipelines"). CPL Title Graphic The CPL
+ was developed to standardise the way VLT instrument pipelines are
+ built, to shorten their development cycle and to ease their
+ maintenance. However, it may be more generally applied to any similar
+ application, and the details of the CPL code have been engineered in a
+ way to make the library portable and flexible, as well as minimising
+ external dependencies.
+</longdescription>
+<use>
+ <flag name='gasgano'>
+ Enable support for <pkg>sci-astronomy/gasgano</pkg> file organizer
+ </flag>
+</use>
+</pkgmetadata>