summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2006-10-02 13:32:20 +0000
committerJim Ramsay <lack@gentoo.org>2006-10-02 13:32:20 +0000
commit9382b2aaaa599531e8d9cf960a74929424bb14cb (patch)
treee36d3e3e4a777c1cf8ffe531342cfef53dec0218 /rox-extra/roxiso
parentRemove the ALSA mask, as the packages are gone already. (diff)
downloadgentoo-2-9382b2aaaa599531e8d9cf960a74929424bb14cb.tar.gz
gentoo-2-9382b2aaaa599531e8d9cf960a74929424bb14cb.tar.bz2
gentoo-2-9382b2aaaa599531e8d9cf960a74929424bb14cb.zip
Removed missing dependency, added a patch to change the config file location, and accepting maintainer role.
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'rox-extra/roxiso')
-rw-r--r--rox-extra/roxiso/ChangeLog10
-rw-r--r--rox-extra/roxiso/files/digest-roxiso-050508-r13
-rw-r--r--rox-extra/roxiso/files/roxiso-050508-config_location.patch18
-rw-r--r--rox-extra/roxiso/metadata.xml6
-rw-r--r--rox-extra/roxiso/roxiso-050508-r1.ebuild29
5 files changed, 64 insertions, 2 deletions
diff --git a/rox-extra/roxiso/ChangeLog b/rox-extra/roxiso/ChangeLog
index 8bebd76c3e20..d0f56d674421 100644
--- a/rox-extra/roxiso/ChangeLog
+++ b/rox-extra/roxiso/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for rox-extra/roxiso
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-extra/roxiso/ChangeLog,v 1.2 2006/05/24 17:56:29 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/roxiso/ChangeLog,v 1.3 2006/10/02 13:32:20 lack Exp $
+
+*roxiso-050508-r1 (02 Oct 2006)
+
+ 02 Oct 2006; <lack@gentoo.org> +files/roxiso-050508-config_location.patch,
+ metadata.xml, -roxiso-050508.ebuild, +roxiso-050508-r1.ebuild:
+ Removed missing dependency (cdrtools now works for DVDs, too). Added local
+ patch which migrates settings to new-style ~/.config/ directory (also sent
+ upstream).
24 May 2006; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove svyatogor from metadata.xml, bug 131936.
diff --git a/rox-extra/roxiso/files/digest-roxiso-050508-r1 b/rox-extra/roxiso/files/digest-roxiso-050508-r1
new file mode 100644
index 000000000000..4a2e2b2558f7
--- /dev/null
+++ b/rox-extra/roxiso/files/digest-roxiso-050508-r1
@@ -0,0 +1,3 @@
+MD5 4acbc71906577bf138259c9f7b4744b1 RoxISO-050508.tar.bz2 18639
+RMD160 d79a7c36570e973578c77867d754947f5ea8f9d8 RoxISO-050508.tar.bz2 18639
+SHA256 8682e89008294aa97dbf9d3023b926efeec29ed121568acda08a627984c50369 RoxISO-050508.tar.bz2 18639
diff --git a/rox-extra/roxiso/files/roxiso-050508-config_location.patch b/rox-extra/roxiso/files/roxiso-050508-config_location.patch
new file mode 100644
index 000000000000..d5217c8e27e2
--- /dev/null
+++ b/rox-extra/roxiso/files/roxiso-050508-config_location.patch
@@ -0,0 +1,18 @@
+diff -ur RoxISO.orig/AppRun RoxISO/AppRun
+--- RoxISO.orig/AppRun 2005-05-08 10:22:26.000000000 -0600
++++ RoxISO/AppRun 2006-04-26 20:47:46.000000000 -0600
+@@ -10,8 +10,10 @@
+ from rox.options import Option
+
+ appname='RoxISO'
++sitename='kymatica.bitminds.net'
+
+-rox.setup_app_options(appname)
++rox.choices.migrate(appname, sitename)
++rox.setup_app_options(appname, site=sitename)
+ import mkimage
+ import burner
+
+Only in RoxISO: burner.pyc
+Only in RoxISO: findrox.pyc
+Only in RoxISO: mkimage.pyc
diff --git a/rox-extra/roxiso/metadata.xml b/rox-extra/roxiso/metadata.xml
index 20ce219711a2..e8761671e3a5 100644
--- a/rox-extra/roxiso/metadata.xml
+++ b/rox-extra/roxiso/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
</pkgmetadata>
diff --git a/rox-extra/roxiso/roxiso-050508-r1.ebuild b/rox-extra/roxiso/roxiso-050508-r1.ebuild
new file mode 100644
index 000000000000..2baff267baa4
--- /dev/null
+++ b/rox-extra/roxiso/roxiso-050508-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/roxiso/roxiso-050508-r1.ebuild,v 1.1 2006/10/02 13:32:20 lack Exp $
+
+inherit rox eutils
+
+MY_PN="RoxISO"
+
+DESCRIPTION="RoxISO. A graphical frontend to mkisofs and cdrecord."
+HOMEPAGE="http://kymatica.bitminds.net/software.html"
+SRC_URI="http://kymatica.bitminds.net/rox/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="app-cdr/cdrtools"
+
+ROX_CLIB_VER=1.9.13
+
+APPNAME=RoxISO
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-config_location.patch
+}