summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-12-14 18:08:49 +0000
committerJim Ramsay <lack@gentoo.org>2007-12-14 18:08:49 +0000
commitcce90ab96a26a9a8864fc7946555ea950a541db0 (patch)
tree239f298b1a2cc3bc4e98b698d3a03b515466ac18 /rox-base
parentStable on ppc wrt bug 202120 (diff)
downloadgentoo-2-cce90ab96a26a9a8864fc7946555ea950a541db0.tar.gz
gentoo-2-cce90ab96a26a9a8864fc7946555ea950a541db0.tar.bz2
gentoo-2-cce90ab96a26a9a8864fc7946555ea950a541db0.zip
Now installs zero-install native feed (Bug 202275)
(Portage version: 2.1.3.19)
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/rox/ChangeLog7
-rw-r--r--rox-base/rox/files/digest-rox-2.7-r13
-rw-r--r--rox-base/rox/rox-2.7-r1.ebuild144
3 files changed, 153 insertions, 1 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index b3b00f4a75f4..3223a4ccd5a7 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.48 2007/11/30 21:36:26 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.49 2007/12/14 18:08:49 lack Exp $
+
+*rox-2.7-r1 (14 Dec 2007)
+
+ 14 Dec 2007; Jim Ramsay <lack@gentoo.org> +rox-2.7-r1.ebuild:
+ Now installs zero-install native feed (Bug 202275)
*rox-2.7 (30 Nov 2007)
diff --git a/rox-base/rox/files/digest-rox-2.7-r1 b/rox-base/rox/files/digest-rox-2.7-r1
new file mode 100644
index 000000000000..b0b67dd7b832
--- /dev/null
+++ b/rox-base/rox/files/digest-rox-2.7-r1
@@ -0,0 +1,3 @@
+MD5 6bdebb307c56173a0031ae3b0df6c6ac rox-filer-2.7.tar.bz2 1829001
+RMD160 f378129073b00e388559380fc551b23437cd4cbf rox-filer-2.7.tar.bz2 1829001
+SHA256 c43ad72760e5ef2c9150d00c7beae24c99c1df102443e87e6ccd969427a47c92 rox-filer-2.7.tar.bz2 1829001
diff --git a/rox-base/rox/rox-2.7-r1.ebuild b/rox-base/rox/rox-2.7-r1.ebuild
new file mode 100644
index 000000000000..e7d7ad80467b
--- /dev/null
+++ b/rox-base/rox/rox-2.7-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.7-r1.ebuild,v 1.1 2007/12/14 18:08:49 lack Exp $
+
+inherit eutils multilib
+
+MY_P="rox-filer-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="ROX is a desktop environment and filer based on RISC OS."
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="svg"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
+ svg? ( gnome-base/librsvg )
+ !ppc? ( rox-base/mime-editor
+ rox-base/thumbs
+ rox-extra/videothumbnail )"
+
+DEPEND="${RDEPEND}
+ >=rox-base/zeroinstall-injector-0.31-r1
+ >=dev-util/pkgconfig-0.20"
+
+APPNAME="ROX-Filer"
+APPDIR="/usr/$(get_libdir)/rox"
+LIBDIR="/usr/$(get_libdir)/"
+WRAPPERNAME="rox"
+MIMEDIR="/usr/share/mime"
+MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+}
+
+src_compile() {
+
+ cd ${APPNAME}
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
+ ./AppRun --compile || die "make failed"
+ (cd src; make clean) > /dev/null
+ # don't need these directories anymore
+ if [ -n "${KEEP_SRC}" ]; then
+ (cd src; make clean) > /dev/null
+ else
+ rm -rf src
+ fi
+ rm -fr build
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
+}
+
+# new streamlined install
+
+src_install() {
+ doman rox.1
+
+ dodir ${APPDIR}
+ cp -r ${APPNAME}/ "${D}/${APPDIR}"
+
+ # add documentation to be proper
+ ( cd ${APPNAME}/Help
+ dodoc Changes README README-es TODO
+ )
+
+ # install shell script
+ dodir /usr/bin
+
+ cat >"${D}/usr/bin/${WRAPPERNAME}" <<EOF
+#!/bin/sh
+if [[ "\${LIBDIRPATH}" ]]; then
+ export LIBDIRPATH="\${LIBDIRPATH}:${LIBDIR}"
+else
+ export LIBDIRPATH="${LIBDIR}"
+fi
+
+if [[ "\${APPDIRPATH}" ]]; then
+ export APPDIRPATH="\${APPDIRPATH}:${APPDIR}"
+else
+ export APPDIRPATH="${APPDIR}"
+fi
+exec "${APPDIR}/${APPNAME}/AppRun" "\$@"
+EOF
+
+ cat >"${D}/usr/bin/${WRAPPERNAME}uri" <<EOF
+#!/bin/sh
+exec "${APPDIR}/${APPNAME}/AppRun" -U "\$@"
+EOF
+
+ chmod 0755 "${D}/usr/bin/${WRAPPERNAME}"
+ chmod 0755 "${D}/usr/bin/${WRAPPERNAME}uri"
+
+ # install rox.xml
+ insinto ${MIMEDIR}/packages
+ doins rox.xml
+
+ # CHOICES system is gone. Now use XDG only
+ # these are shell scripts and must be +x.
+ exeinto ${MIMECONFDIR}/MIME-types
+ doexe Choices/MIME-types/*
+
+ insinto /usr/share/pixmaps
+ newins ${APPNAME}/.DirIcon ${APPNAME}.png
+
+ make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME}.png "System;Utility;Core;ROX"
+
+ # Install the 0install feed
+ local NATIVE_FEED_DIR="/usr/share/0install.net/native_feeds"
+ local ICON_CACHE_DIR="/var/cache/0install.net/interface_icons"
+
+ 0distutils ${APPNAME}.xml > tmp.native_feed || die "0distutils feed edit failed"
+ insinto "${APPDIR}/${APPNAME}"
+ newins tmp.native_feed ${APPNAME}.xml
+
+ local feedname
+ feedname=$(0distutils -e tmp.native_feed) || die "0distutils URI escape failed"
+ dosym "${APPDIR}/${APPNAME}/${APPNAME}.xml" "${NATIVE_FEED_DIR}/${feedname}"
+
+ local cachedname
+ cachedname=$(0distutils -c tmp.native_feed) || die "0distutils URI escape failed"
+ dosym "${APPDIR}/${APPNAME}/.DirIcon" "${ICON_CACHE_DIR}/${cachedname}"
+}
+
+pkg_postinst() {
+ update-mime-database ${MIMEDIR}
+ einfo "${APPNAME} has been installed in ${APPDIR}."
+ einfo "To run, you may type ${WRAPPERNAME} at a prompt (within a WM) or"
+ einfo "add it to an .xinit or other script during WM startup."
+}