summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-11-29 15:23:45 +0000
committerJim Ramsay <lack@gentoo.org>2007-11-29 15:23:45 +0000
commit5adac610209c4972c33b97a2bc06b53bc1a0ab86 (patch)
treeaf397869f09ae5235bc515276d0d4d213899ab52 /rox-base/rox
parentCleaning out old versions (diff)
downloadgentoo-2-5adac610209c4972c33b97a2bc06b53bc1a0ab86.tar.gz
gentoo-2-5adac610209c4972c33b97a2bc06b53bc1a0ab86.tar.bz2
gentoo-2-5adac610209c4972c33b97a2bc06b53bc1a0ab86.zip
Version cleanup
(Portage version: 2.1.3.19)
Diffstat (limited to 'rox-base/rox')
-rw-r--r--rox-base/rox/ChangeLog5
-rw-r--r--rox-base/rox/files/digest-rox-2.63
-rw-r--r--rox-base/rox/rox-2.6.ebuild124
3 files changed, 4 insertions, 128 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index 0efa1fd9a38d..8b9a60e707b0 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.46 2007/11/04 14:15:54 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.47 2007/11/29 15:23:44 lack Exp $
+
+ 29 Nov 2007; Jim Ramsay <lack@gentoo.org> -rox-2.6.ebuild:
+ Version cleanup
04 Nov 2007; Christoph Mende <angelos@gentoo.org> rox-2.6.1.ebuild:
Stable on amd64 wrt bug #197509
diff --git a/rox-base/rox/files/digest-rox-2.6 b/rox-base/rox/files/digest-rox-2.6
deleted file mode 100644
index 3ac517283faf..000000000000
--- a/rox-base/rox/files/digest-rox-2.6
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fe4fca077e05257772f2eeaf5be38379 rox-filer-2.6.tar.bz2 1815735
-RMD160 1b4e8c65208ba84b78584471b1a7b711609c7623 rox-filer-2.6.tar.bz2 1815735
-SHA256 c1f8d7535528de3badf8762ba88bb1f41700f5117788abc575959effb6939960 rox-filer-2.6.tar.bz2 1815735
diff --git a/rox-base/rox/rox-2.6.ebuild b/rox-base/rox/rox-2.6.ebuild
deleted file mode 100644
index 6d2e8b8a2c7b..000000000000
--- a/rox-base/rox/rox-2.6.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.6.ebuild,v 1.6 2007/04/23 05:46:06 opfer Exp $
-
-inherit eutils
-
-MY_P="rox-filer-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="ROX is a desktop environment and filer based on RISC OS."
-HOMEPAGE="http://rox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc sparc x86"
-IUSE="svg"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=dev-libs/glib-2.2
- >=dev-libs/libxml2-2.4.23
- >=x11-misc/shared-mime-info-0.14
- svg? ( gnome-base/librsvg )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.20"
-
-APPNAME="ROX-Filer"
-APPDIR="/usr/lib/rox"
-LIBDIR="/usr/lib/"
-WRAPPERNAME="rox"
-MIMEDIR="/usr/share/mime"
-MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}"/${P}-nostrip.patch
-}
-
-src_compile() {
-
- cd ${APPNAME}
-
- # Most rox self-compiles have a 'read' call to wait for the user to
- # press return if the compile fails.
- # Find and remove this:
- sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
-
- ./AppRun --compile || die "make failed"
- (cd src; make clean) > /dev/null
- # don't need these directories anymore
- if [ -n "${KEEP_SRC}" ]; then
- (cd src; make clean) > /dev/null
- else
- rm -rf src
- fi
- rm -fr build
-
- # Restore the original AppRun
- mv AppRun.bak AppRun
-}
-
-# new streamlined install
-
-src_install() {
- doman rox.1
-
- dodir ${APPDIR}
- cp -r ${APPNAME}/ ${D}/${APPDIR}
-
- # add documentation to be proper
- ( cd ${APPNAME}/Help
- dodoc Changes COPYING README README-es TODO
- )
-
- # install shell script
- dodir /usr/bin
-
- cat >"${D}/usr/bin/${WRAPPERNAME}" <<EOF
-#!/bin/sh
-if [[ "\${LIBDIRPATH}" ]]; then
- export LIBDIRPATH="\${LIBDIRPATH}:${LIBDIR}"
-else
- export LIBDIRPATH="${LIBDIR}"
-fi
-
-if [[ "\${APPDIRPATH}" ]]; then
- export APPDIRPATH="\${APPDIRPATH}:${APPDIR}"
-else
- export APPDIRPATH="${APPDIR}"
-fi
-exec "${APPDIR}/${APPNAME}/AppRun" "\$@"
-EOF
-
- cat >"${D}/usr/bin/${WRAPPERNAME}uri" <<EOF
-#!/bin/sh
-exec "${APPDIR}/${APPNAME}/AppRun" -U "\$@"
-EOF
-
- chmod 0755 ${D}/usr/bin/${WRAPPERNAME}
- chmod 0755 ${D}/usr/bin/${WRAPPERNAME}uri
-
- # install rox.xml
- insinto ${MIMEDIR}/packages
- doins rox.xml
-
- # CHOICES system is gone. Now use XDG only
- # these are shell scripts and must be +x.
- exeinto ${MIMECONFDIR}/MIME-types
- doexe Choices/MIME-types/*
-
- insinto /usr/share/pixmaps
- newins ${APPNAME}/.DirIcon ${APPNAME}.png
-
- make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME}.png "System;Utility;Core;ROX"
-}
-
-pkg_postinst() {
- update-mime-database ${MIMEDIR}
- einfo "${APPNAME} has been installed in ${APPDIR}."
- einfo "To run, you may type ${WRAPPERNAME} at a prompt (within a WM) or"
- einfo "add it to an .xinit or other script during WM startup."
-}