summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-05-20 02:58:24 +0000
committerJim Ramsay <lack@gentoo.org>2008-05-20 02:58:24 +0000
commit1b980fc7b52129dc64098c3416553048ea7fbd3b (patch)
treeb597efbe57cc4f681056830bd399f655dbf35820 /rox-base/rox
parentBumped to latest release. Added new dep of dom4j, might be a conditional dep ... (diff)
downloadgentoo-2-1b980fc7b52129dc64098c3416553048ea7fbd3b.tar.gz
gentoo-2-1b980fc7b52129dc64098c3416553048ea7fbd3b.tar.bz2
gentoo-2-1b980fc7b52129dc64098c3416553048ea7fbd3b.zip
New version 2.8 is released
(Portage version: 2.1.4.4)
Diffstat (limited to 'rox-base/rox')
-rw-r--r--rox-base/rox/ChangeLog8
-rw-r--r--rox-base/rox/files/rox-2.8-nostrip.patch20
-rw-r--r--rox-base/rox/rox-2.8.ebuild148
3 files changed, 175 insertions, 1 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index a244df4c7841..0b503b4d28f9 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.56 2008/02/29 20:32:30 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.57 2008/05/20 02:58:23 lack Exp $
+
+*rox-2.8 (20 May 2008)
+
+ 20 May 2008; Jim Ramsay <lack@gentoo.org> +files/rox-2.8-nostrip.patch,
+ +rox-2.8.ebuild:
+ New version 2.8 is released
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> rox-2.6.1.ebuild,
rox-2.7.ebuild:
diff --git a/rox-base/rox/files/rox-2.8-nostrip.patch b/rox-base/rox/files/rox-2.8-nostrip.patch
new file mode 100644
index 000000000000..2a63ce73f160
--- /dev/null
+++ b/rox-base/rox/files/rox-2.8-nostrip.patch
@@ -0,0 +1,20 @@
+Index: ROX-Filer/src/Makefile.in
+===================================================================
+--- ROX-Filer/src/Makefile.in (revision 4834)
++++ ROX-Filer/src/Makefile.in (working copy)
+@@ -51,10 +51,12 @@
+ ${PROG}: ${OBJECTS}
+ ${CC} -o "${PROG}" ${OBJECTS} ${LDFLAGS}
+ mv "${PROG}" "${PLATFORM_DIR}"
++
++${PROG}.dbg: ${PROG}
+ -(cd "${PLATFORM_DIR}" && \
+- objcopy --only-keep-debug ROX-Filer ROX-Filer.dbg && \
+- strip ROX-Filer && \
+- objcopy --add-gnu-debuglink=ROX-Filer.dbg ROX-Filer)
++ objcopy --only-keep-debug ${PROG} ${PROG}.dbg && \
++ strip ${PROG} && \
++ objcopy --add-gnu-debuglink=${PROG}.dbg ${PROG})
+
+ clean:
+ rm -f *.o Makefile.bak
diff --git a/rox-base/rox/rox-2.8.ebuild b/rox-base/rox/rox-2.8.ebuild
new file mode 100644
index 000000000000..4ea5045fae1f
--- /dev/null
+++ b/rox-base/rox/rox-2.8.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.8.ebuild,v 1.1 2008/05/20 02:58:23 lack Exp $
+
+EAPI=1
+inherit eutils multilib
+
+MY_P="rox-filer-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="ROX is a desktop environment and filer based on RISC OS."
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="svg +video"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
+ svg? ( gnome-base/librsvg )"
+
+PDEPEND="rox-base/mime-editor
+ rox-base/thumbs
+ video? ( rox-extra/videothumbnail )"
+
+DEPEND="${RDEPEND}
+ >=rox-base/zeroinstall-injector-0.31-r1
+ >=dev-util/pkgconfig-0.20"
+
+APPNAME="ROX-Filer"
+APPDIR="/usr/$(get_libdir)/rox"
+LIBDIR="/usr/$(get_libdir)/"
+WRAPPERNAME="rox"
+MIMEDIR="/usr/share/mime"
+MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+}
+
+src_compile() {
+
+ cd ${APPNAME}
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
+ ./AppRun --compile || die "make failed"
+
+ # don't need these directories anymore
+ if [ -n "${KEEP_SRC}" ]; then
+ pushd src
+ make clean > /dev/null
+ popd
+ else
+ rm -rf src
+ fi
+ rm -fr build
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
+}
+
+# new streamlined install
+
+src_install() {
+ doman rox.1
+
+ dodir ${APPDIR}
+ cp -r ${APPNAME}/ "${D}/${APPDIR}"
+
+ # add documentation to be proper
+ pushd ${APPNAME}/Help
+ dodoc Changes README README-es TODO
+ popd
+
+ # install shell script
+ dodir /usr/bin
+
+ cat >"${D}/usr/bin/${WRAPPERNAME}" <<EOF
+#!/bin/sh
+if [ "\${LIBDIRPATH}" ]; then
+ export LIBDIRPATH="\${LIBDIRPATH}:${LIBDIR}"
+else
+ export LIBDIRPATH="${LIBDIR}"
+fi
+
+if [ "\${APPDIRPATH}" ]; then
+ export APPDIRPATH="\${APPDIRPATH}:${APPDIR}"
+else
+ export APPDIRPATH="${APPDIR}"
+fi
+exec "${APPDIR}/${APPNAME}/AppRun" "\$@"
+EOF
+
+ cat >"${D}/usr/bin/${WRAPPERNAME}uri" <<EOF
+#!/bin/sh
+exec "${APPDIR}/${APPNAME}/AppRun" -U "\$@"
+EOF
+
+ fperms 0755 "/usr/bin/${WRAPPERNAME}"
+ fperms 0755 "/usr/bin/${WRAPPERNAME}uri"
+
+ # install rox.xml
+ insinto ${MIMEDIR}/packages
+ doins rox.xml
+
+ # CHOICES system is gone. Now use XDG only
+ # these are shell scripts and must be +x.
+ exeinto ${MIMECONFDIR}/MIME-types
+ doexe Choices/MIME-types/*
+
+ insinto /usr/share/pixmaps
+ newins ${APPNAME}/.DirIcon ${APPNAME}.png
+
+ make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME} "System;FileTools;FileManager"
+
+ # Install the 0install feed
+ local NATIVE_FEED_DIR="/usr/share/0install.net/native_feeds"
+ local ICON_CACHE_DIR="/var/cache/0install.net/interface_icons"
+
+ 0distutils ${APPNAME}.xml > tmp.native_feed || die "0distutils feed edit failed"
+ insinto "${APPDIR}/${APPNAME}"
+ newins tmp.native_feed ${APPNAME}.xml
+
+ local feedname
+ feedname=$(0distutils -e tmp.native_feed) || die "0distutils URI escape failed"
+ dosym "${APPDIR}/${APPNAME}/${APPNAME}.xml" "${NATIVE_FEED_DIR}/${feedname}"
+
+ local cachedname
+ cachedname=$(0distutils -c tmp.native_feed) || die "0distutils URI escape failed"
+ dosym "${APPDIR}/${APPNAME}/.DirIcon" "${ICON_CACHE_DIR}/${cachedname}"
+}
+
+pkg_postinst() {
+ update-mime-database ${MIMEDIR}
+ einfo "${APPNAME} has been installed in ${APPDIR}."
+ einfo "To run, you may type ${WRAPPERNAME} at a prompt (within a WM) or"
+ einfo "add it to an .xinit or other script during WM startup."
+}