summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-08-10 11:11:58 +0000
committerTorsten Veller <tove@gentoo.org>2009-08-10 11:11:58 +0000
commitbf326d717cc49559a2aa7ac13c33dd406577ea50 (patch)
tree025d3cf2040e790946244ccd1fffca74ca38c92a /perl-core
parentFix building with GCC 4.4+ wrt #274242. (diff)
downloadgentoo-2-bf326d717cc49559a2aa7ac13c33dd406577ea50.tar.gz
gentoo-2-bf326d717cc49559a2aa7ac13c33dd406577ea50.tar.bz2
gentoo-2-bf326d717cc49559a2aa7ac13c33dd406577ea50.zip
Version bump
(Portage version: 2.2_rc37/cvs/Linux x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Module-Build/ChangeLog8
-rw-r--r--perl-core/Module-Build/Module-Build-0.34.0201.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/perl-core/Module-Build/ChangeLog b/perl-core/Module-Build/ChangeLog
index 506839a0cb7d..5ced3266f28c 100644
--- a/perl-core/Module-Build/ChangeLog
+++ b/perl-core/Module-Build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Module-Build
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.10 2009/07/08 06:31:42 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.11 2009/08/10 11:11:58 tove Exp $
+
+*Module-Build-0.34.0201 (10 Aug 2009)
+
+ 10 Aug 2009; Torsten Veller <tove@gentoo.org>
+ +Module-Build-0.34.0201.ebuild:
+ Version bump
*Module-Build-0.34 (08 Jul 2009)
diff --git a/perl-core/Module-Build/Module-Build-0.34.0201.ebuild b/perl-core/Module-Build/Module-Build-0.34.0201.ebuild
new file mode 100644
index 000000000000..6fe102b3e3d4
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.34.0201.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.34.0201.ebuild,v 1.1 2009/08/10 11:11:58 tove Exp $
+
+inherit versionator
+MODULE_AUTHOR=DAGOLDEN
+MY_P=${PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+inherit perl-module
+
+DESCRIPTION="Build and install Perl modules"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=virtual/perl-ExtUtils-CBuilder-0.15
+ >=virtual/perl-ExtUtils-ParseXS-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=virtual/perl-Archive-Tar-1.09
+ >=virtual/perl-Test-Harness-3.16"
+
+SRC_TEST="do"