summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-09-10 20:40:31 +0000
committerTorsten Veller <tove@gentoo.org>2009-09-10 20:40:31 +0000
commitafb185761213a325ef81da0537afd45ab1e34d34 (patch)
tree9d6d5102231f64a72a33a3b1eec1e3e3ccea725c /perl-core
parentInstall yow.lines in a subdirectory. (diff)
downloadgentoo-2-afb185761213a325ef81da0537afd45ab1e34d34.tar.gz
gentoo-2-afb185761213a325ef81da0537afd45ab1e34d34.tar.bz2
gentoo-2-afb185761213a325ef81da0537afd45ab1e34d34.zip
Version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/CGI/CGI-3.47.ebuild25
-rw-r--r--perl-core/CGI/ChangeLog8
-rw-r--r--perl-core/CGI/files/3.47-fcgi.patch24
3 files changed, 56 insertions, 1 deletions
diff --git a/perl-core/CGI/CGI-3.47.ebuild b/perl-core/CGI/CGI-3.47.ebuild
new file mode 100644
index 000000000000..b05c93e221a5
--- /dev/null
+++ b/perl-core/CGI/CGI-3.47.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/CGI-3.47.ebuild,v 1.1 2009/09/10 20:40:30 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=LDS
+MY_PN=${PN}.pm
+MY_P=${MY_PN}-${PV}
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+#DEPEND="dev-lang/perl"
+# dev-perl/FCGI" #236921
+
+S=${WORKDIR}/${MY_P}
+
+SRC_TEST="do"
+
+PATCHES=( "${FILESDIR}"/3.47-fcgi.patch )
diff --git a/perl-core/CGI/ChangeLog b/perl-core/CGI/ChangeLog
index 866b46aae08d..b0fe7a59ff4d 100644
--- a/perl-core/CGI/ChangeLog
+++ b/perl-core/CGI/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/CGI
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/ChangeLog,v 1.62 2009/08/22 22:19:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/ChangeLog,v 1.63 2009/09/10 20:40:30 tove Exp $
+
+*CGI-3.47 (10 Sep 2009)
+
+ 10 Sep 2009; Torsten Veller <tove@gentoo.org> +files/3.47-fcgi.patch,
+ +CGI-3.47.ebuild:
+ Version bump
*CGI-3.45 (22 Aug 2009)
diff --git a/perl-core/CGI/files/3.47-fcgi.patch b/perl-core/CGI/files/3.47-fcgi.patch
new file mode 100644
index 000000000000..922a577f14b5
--- /dev/null
+++ b/perl-core/CGI/files/3.47-fcgi.patch
@@ -0,0 +1,24 @@
+http://rt.cpan.org/Public/Bug/Display.html?id=49599
+
+--- CGI.pm-3.47/t/fast.t
++++ CGI.pm-3.47/t/fast.t
+@@ -7,16 +7,16 @@
+ $fcgi = $@ ? 0 : 1;
+ }
+
+-use Test::More tests => 10;
++use Test::More tests => 11;
+
+ # Shut up "used only once" warnings.
+ () = $CGI::Q;
+ () = $CGI::Fast::Ext_Request;
+
+ SKIP: {
+- skip( 'FCGI not installed, cannot continue', 7 ) unless $fcgi;
++ skip( 'FCGI not installed, cannot continue', 11 ) unless $fcgi;
+
+- use CGI::Fast;
++ use_ok( CGI::Fast );
+ ok( my $q = CGI::Fast->new(), 'created new CGI::Fast object' );
+ is( $q, $CGI::Q, 'checking to see if the object was stored properly' );
+ is( $q->param(), (), 'no params' );