summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-25 23:08:03 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-25 23:08:03 +0000
commita4c62da7f82a752575d070736cc4ae18b7b031bb (patch)
treeb446bae397b785d68ed14bc05d4973339a663090 /perl-core
parentNew package, dependency of dev-perl/Inline-C (diff)
downloadgentoo-2-a4c62da7f82a752575d070736cc4ae18b7b031bb.tar.gz
gentoo-2-a4c62da7f82a752575d070736cc4ae18b7b031bb.tar.bz2
gentoo-2-a4c62da7f82a752575d070736cc4ae18b7b031bb.zip
Version bump, needed for dev-perl/Inline-C
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/ExtUtils-MakeMaker/ChangeLog11
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0.ebuild48
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch63
3 files changed, 120 insertions, 2 deletions
diff --git a/perl-core/ExtUtils-MakeMaker/ChangeLog b/perl-core/ExtUtils-MakeMaker/ChangeLog
index cf839694b39c..80044568da2d 100644
--- a/perl-core/ExtUtils-MakeMaker/ChangeLog
+++ b/perl-core/ExtUtils-MakeMaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for perl-core/ExtUtils-MakeMaker
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.64 2014/11/08 15:25:52 dilfridge Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.65 2015/02/25 23:08:03 dilfridge Exp $
+
+*ExtUtils-MakeMaker-7.40.0 (25 Feb 2015)
+
+ 25 Feb 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ExtUtils-MakeMaker-7.40.0.ebuild,
+ +files/7.04-delete_packlist_podlocal.patch:
+ Version bump, needed for dev-perl/Inline-C
08 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org>
-ExtUtils-MakeMaker-6.640.0-r1.ebuild:
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0.ebuild
new file mode 100644
index 000000000000..252bac59dfea
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0.ebuild,v 1.1 2015/02/25 23:08:03 dilfridge Exp $
+
+EAPI=5
+MODULE_AUTHOR=BINGOS
+MODULE_VERSION=7.04
+inherit eutils perl-module
+
+DESCRIPTION="Create a module Makefile"
+HOMEPAGE="http://makemaker.org ${HOMEPAGE}"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-ExtUtils-Command-1.160.0
+ >=virtual/perl-ExtUtils-Install-1.540.0
+ >=virtual/perl-ExtUtils-Manifest-1.600.0
+ >=virtual/perl-File-Spec-0.800.0
+"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ >=virtual/perl-CPAN-Meta-2.112.621
+ >=virtual/perl-Parse-CPAN-Meta-1.440.100
+"
+
+PATCHES=(
+ "${FILESDIR}/7.04-delete_packlist_podlocal.patch"
+ "${FILESDIR}/6.58-RUNPATH.patch"
+)
+SRC_TEST=do
+
+src_prepare() {
+ edos2unix "${S}/lib/ExtUtils/MM_Unix.pm"
+ edos2unix "${S}/lib/ExtUtils/MM_Any.pm"
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # remove all the bundled distributions
+ pushd "${D}" >/dev/null
+ find ".${VENDOR_LIB}" -mindepth 1 -maxdepth 1 -not -name "ExtUtils" -exec rm -rfv {} \+
+ popd >/dev/null
+}
diff --git a/perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch
new file mode 100644
index 000000000000..266d5d240c04
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch
@@ -0,0 +1,63 @@
+diff -ruN ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MM_Unix.pm ExtUtils-MakeMaker-7.04/lib/ExtUtils/MM_Unix.pm
+--- ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MM_Unix.pm 2014-12-02 13:44:33.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/lib/ExtUtils/MM_Unix.pm 2015-02-25 23:54:03.373862321 +0100
+@@ -1606,6 +1606,16 @@
+ $self->{FULLEXT} = $self->catdir(split /::/, $self->{NAME});
+
+
++ # Workaround for https://bugs.gentoo.org/show_bug.cgi?id=221179
++ if (!exists($self->{NO_PERLLOCAL})) {
++ $self->{NO_PERLLOCAL} = 1;
++ }
++
++ if (!exists($self->{NO_PACKLIST})) {
++ $self->{NO_PACKLIST} = 1;
++ }
++
++
+ # Copied from DynaLoader:
+
+ my(@modparts) = split(/::/,$self->{NAME});
+diff -ruN ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MakeMaker.pm ExtUtils-MakeMaker-7.04/lib/ExtUtils/MakeMaker.pm
+--- ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MakeMaker.pm 2014-12-02 13:44:33.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/lib/ExtUtils/MakeMaker.pm 2015-02-25 23:54:03.373862321 +0100
+@@ -2348,13 +2348,13 @@
+ When true, suppresses the generation of MYMETA.yml and MYMETA.json module
+ meta-data files during 'perl Makefile.PL'.
+
+-Defaults to false.
++Defaults to true.
+
+ =item NO_PACKLIST
+
+ When true, suppresses the writing of C<packlist> files for installs.
+
+-Defaults to false.
++Defaults to true.
+
+ =item NO_PERLLOCAL
+
+diff -ruN ExtUtils-MakeMaker-7.04.orig/t/INSTALL_BASE.t ExtUtils-MakeMaker-7.04/t/INSTALL_BASE.t
+--- ExtUtils-MakeMaker-7.04.orig/t/INSTALL_BASE.t 2014-11-11 14:50:52.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/t/INSTALL_BASE.t 2015-02-25 23:59:00.383878929 +0100
+@@ -42,7 +42,7 @@
+ ok( chdir('Big-Dummy'), "chdir'd to Big-Dummy") || diag("chdir failed; $!");
+
+ for my $instdir (@INSTDIRS) {
+- my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=$instdir"});
++ my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=$instdir" NO_PERLLOCAL=0 NO_PACKLIST=0});
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||
+ diag(@mpl_out);
+diff -ruN ExtUtils-MakeMaker-7.04.orig/t/basic.t ExtUtils-MakeMaker-7.04/t/basic.t
+--- ExtUtils-MakeMaker-7.04.orig/t/basic.t 2014-11-11 14:50:52.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/t/basic.t 2015-02-25 23:56:51.161871703 +0100
+@@ -59,7 +59,7 @@
+
+ sub extrachar { $] > 5.008 && !$ENV{PERL_CORE} ? utf8::decode(my $c='š') : 's' }
+ my $DUMMYINST = '../dummy-in'.extrachar().'tall';
+-my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=$DUMMYINST"});
++my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=$DUMMYINST" NO_PERLLOCAL=0 NO_PACKLIST=0});
+ END { rmtree $DUMMYINST; }
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||