summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-23 08:59:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-23 08:59:18 +0000
commit22839395ab71175d315b34871f281350f2781787 (patch)
tree7a79043a6ae223add47a5834cf733514c43d26fd /perl-core
parentVersion bump. (diff)
downloadgentoo-2-22839395ab71175d315b34871f281350f2781787.tar.gz
gentoo-2-22839395ab71175d315b34871f281350f2781787.tar.bz2
gentoo-2-22839395ab71175d315b34871f281350f2781787.zip
Version bump.
(Portage version: 2.2_rc18/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Module-Build/ChangeLog8
-rw-r--r--perl-core/Module-Build/Module-Build-0.31.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/perl-core/Module-Build/ChangeLog b/perl-core/Module-Build/ChangeLog
index 7ec063a29859..f4180fcba22e 100644
--- a/perl-core/Module-Build/ChangeLog
+++ b/perl-core/Module-Build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Module-Build
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.2 2008/11/04 10:00:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.3 2008/12/23 08:59:18 robbat2 Exp $
+
+*Module-Build-0.31 (23 Dec 2008)
+
+ 23 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +Module-Build-0.31.ebuild:
+ Version bump.
04 Nov 2008; Mike Frysinger <vapier@gentoo.org>
Module-Build-0.28.08.ebuild, Module-Build-0.30.ebuild:
diff --git a/perl-core/Module-Build/Module-Build-0.31.ebuild b/perl-core/Module-Build/Module-Build-0.31.ebuild
new file mode 100644
index 000000000000..e06e6ece03ce
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.31.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.31.ebuild,v 1.1 2008/12/23 08:59:18 robbat2 Exp $
+
+inherit versionator
+MODULE_AUTHOR=KWILLIAMS
+MY_PN=Module-Build
+MY_P=${MY_PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+inherit perl-module
+
+DESCRIPTION="Build and install Perl modules"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=virtual/perl-ExtUtils-CBuilder-0.15
+ >=virtual/perl-ExtUtils-ParseXS-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=virtual/perl-Archive-Tar-1.09"
+
+SRC_TEST="do"
+
+src_test(){
+ HOME= perl-module_src_test
+}