summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 21:20:48 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 21:20:48 +0000
commit1428fe187c2a0210e0cfbb262a64759236abc24a (patch)
tree1f4a01fc29e04e902effb2386272255ab90cfa3c /perl-core
parentFix compilation with gcc-4.4. Patch by Vistor Ostorga <vostorga AT gentoo DO... (diff)
downloadgentoo-2-1428fe187c2a0210e0cfbb262a64759236abc24a.tar.gz
gentoo-2-1428fe187c2a0210e0cfbb262a64759236abc24a.tar.bz2
gentoo-2-1428fe187c2a0210e0cfbb262a64759236abc24a.zip
Revbump to fix header for gcc-4.4 issue; bug #278155
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/ExtUtils-ParseXS/ChangeLog9
-rw-r--r--perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20-r1.ebuild (renamed from perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20.ebuild)7
-rw-r--r--perl-core/ExtUtils-ParseXS/files/eu-pxs-newXS-const-file.patch19
3 files changed, 33 insertions, 2 deletions
diff --git a/perl-core/ExtUtils-ParseXS/ChangeLog b/perl-core/ExtUtils-ParseXS/ChangeLog
index 3ef07af79976..729961593eea 100644
--- a/perl-core/ExtUtils-ParseXS/ChangeLog
+++ b/perl-core/ExtUtils-ParseXS/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for perl-core/ExtUtils-ParseXS
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-ParseXS/ChangeLog,v 1.3 2009/07/03 05:10:45 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-ParseXS/ChangeLog,v 1.4 2009/07/25 21:20:48 halcy0n Exp $
+
+*ExtUtils-ParseXS-2.20-r1 (25 Jul 2009)
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org>
+ -ExtUtils-ParseXS-2.20.ebuild, +ExtUtils-ParseXS-2.20-r1.ebuild,
+ +files/eu-pxs-newXS-const-file.patch:
+ Revbump to fix header for gcc-4.4 issue; bug #278155
*ExtUtils-ParseXS-2.20 (03 Jul 2009)
diff --git a/perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20.ebuild b/perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20-r1.ebuild
index 6f0cecf7faa7..d3323cb79f5c 100644
--- a/perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20.ebuild
+++ b/perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20.ebuild,v 1.1 2009/07/03 05:10:45 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-ParseXS/ExtUtils-ParseXS-2.20-r1.ebuild,v 1.1 2009/07/25 21:20:48 halcy0n Exp $
EAPI=2
@@ -19,3 +19,8 @@ DEPEND="${RDEPEND}
virtual/perl-Module-Build"
SRC_TEST="do"
+
+PATCHES=(
+ "${FILESDIR}"/eu-pxs-newXS-const-file.patch
+)
+
diff --git a/perl-core/ExtUtils-ParseXS/files/eu-pxs-newXS-const-file.patch b/perl-core/ExtUtils-ParseXS/files/eu-pxs-newXS-const-file.patch
new file mode 100644
index 000000000000..e60e030d9e23
--- /dev/null
+++ b/perl-core/ExtUtils-ParseXS/files/eu-pxs-newXS-const-file.patch
@@ -0,0 +1,19 @@
+--- lib/ExtUtils/ParseXS.pm 2009-07-18 23:23:17.000000000 +0200
++++ lib/ExtUtils/ParseXS.pm 2009-07-23 16:42:34.000000000 +0200
+@@ -976,10 +976,15 @@
+ ##endif
+ EOF
+
++ #Under 5.8.x and lower, newXS is declared in proto.h as expecting a non-const
++ #file name argument. If the wrong qualifier is used, it causes breakage with
++ #C++ compilers and warnings with recent gcc.
++ my $file_decl = ($] < 5.009) ? "char file[]" : "const char* file";
++
+ #-Wall: if there is no $Full_func_name there are no xsubs in this .xs
+ #so `file' is unused
+ print Q(<<"EOF") if $Full_func_name;
+-# const char* file = __FILE__;
++# $file_decl = __FILE__;
+ EOF
+
+ print Q("#\n");