summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-13 20:20:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-13 20:20:45 +0000
commit02052ccbd0ac6003715c8ca06e3c3c2bdbe3279e (patch)
tree0cac6dfadeaee443324fa9802b9a623f4a54b0b5 /perl-core
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-02052ccbd0ac6003715c8ca06e3c3c2bdbe3279e.tar.gz
gentoo-2-02052ccbd0ac6003715c8ca06e3c3c2bdbe3279e.tar.bz2
gentoo-2-02052ccbd0ac6003715c8ca06e3c3c2bdbe3279e.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-05718-g0556e82 x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Module-Build/ChangeLog10
-rw-r--r--perl-core/Module-Build/Module-Build-0.31011.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/perl-core/Module-Build/ChangeLog b/perl-core/Module-Build/ChangeLog
index f4180fcba22e..2a3bd51ad35c 100644
--- a/perl-core/Module-Build/ChangeLog
+++ b/perl-core/Module-Build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Module-Build
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.3 2008/12/23 08:59:18 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.4 2009/01/13 20:20:45 robbat2 Exp $
+
+*Module-Build-0.31011 (13 Jan 2009)
+
+ 13 Jan 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +Module-Build-0.31011.ebuild:
+ Version bump via perl-bump experimental tool.
*Module-Build-0.31 (23 Dec 2008)
diff --git a/perl-core/Module-Build/Module-Build-0.31011.ebuild b/perl-core/Module-Build/Module-Build-0.31011.ebuild
new file mode 100644
index 000000000000..66fc9146b26e
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.31011.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.31011.ebuild,v 1.1 2009/01/13 20:20:45 robbat2 Exp $
+
+inherit versionator
+MODULE_AUTHOR=EWILHELM
+MY_PN=Module-Build
+MY_P=${MY_PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+inherit perl-module
+
+DESCRIPTION="Build and install Perl modules"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=virtual/perl-ExtUtils-CBuilder-0.15
+ >=virtual/perl-ExtUtils-ParseXS-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=virtual/perl-Archive-Tar-1.09"
+
+SRC_TEST="do"
+
+src_test(){
+ HOME= perl-module_src_test
+}