summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-28 23:59:42 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-28 23:59:42 +0000
commitfbc1c546f30b3c7d2537369171e8ea7404f03f2c (patch)
treed1099240d2d143f01a2ec339b8dec3106a2500df /perl-core/Digest-SHA
parentDisable extra optimizations in Digest-SHA, breaks multilib; bug 506818 (diff)
downloadgentoo-2-fbc1c546f30b3c7d2537369171e8ea7404f03f2c.tar.gz
gentoo-2-fbc1c546f30b3c7d2537369171e8ea7404f03f2c.tar.bz2
gentoo-2-fbc1c546f30b3c7d2537369171e8ea7404f03f2c.zip
Version bump, apply CFLAGS patch for bug 506818
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'perl-core/Digest-SHA')
-rw-r--r--perl-core/Digest-SHA/ChangeLog9
-rw-r--r--perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild (renamed from perl-core/Digest-SHA/Digest-SHA-5.850.0.ebuild)6
-rw-r--r--perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch16
3 files changed, 28 insertions, 3 deletions
diff --git a/perl-core/Digest-SHA/ChangeLog b/perl-core/Digest-SHA/ChangeLog
index 33760a452034..60e9af1dce2f 100644
--- a/perl-core/Digest-SHA/ChangeLog
+++ b/perl-core/Digest-SHA/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for perl-core/Digest-SHA
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Digest-SHA/ChangeLog,v 1.53 2014/01/20 20:45:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Digest-SHA/ChangeLog,v 1.54 2014/11/28 23:59:42 dilfridge Exp $
+
+*Digest-SHA-5.880.0 (28 Nov 2014)
+
+ 28 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ -Digest-SHA-5.850.0.ebuild, +Digest-SHA-5.880.0.ebuild,
+ +files/Digest-SHA-5.880.0-CFLAGS.patch:
+ Version bump, apply CFLAGS patch for bug 506818
20 Jan 2014; Mike Frysinger <vapier@gentoo.org> Digest-SHA-5.820.0.ebuild,
Digest-SHA-5.850.0.ebuild:
diff --git a/perl-core/Digest-SHA/Digest-SHA-5.850.0.ebuild b/perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild
index eead04ce2714..4459ebbbfc75 100644
--- a/perl-core/Digest-SHA/Digest-SHA-5.850.0.ebuild
+++ b/perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Digest-SHA/Digest-SHA-5.850.0.ebuild,v 1.2 2014/01/20 20:45:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild,v 1.1 2014/11/28 23:59:42 dilfridge Exp $
EAPI=5
MODULE_AUTHOR=MSHELOR
-MODULE_VERSION=5.85
+MODULE_VERSION=5.88
inherit perl-module
DESCRIPTION="Perl extension for SHA-1/224/256/384/512"
@@ -19,4 +19,6 @@ DEPEND="test? (
dev-perl/Test-Pod-Coverage
)"
+PATCHES=( "${FILESDIR}/${P}-CFLAGS.patch" )
+
SRC_TEST="do"
diff --git a/perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch b/perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch
new file mode 100644
index 000000000000..e2a8d096d22e
--- /dev/null
+++ b/perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch
@@ -0,0 +1,16 @@
+diff -ruN Digest-SHA-5.88.orig/Makefile.PL Digest-SHA-5.88/Makefile.PL
+--- Digest-SHA-5.88.orig/Makefile.PL 2014-03-09 11:36:39.000000000 +0100
++++ Digest-SHA-5.88/Makefile.PL 2014-11-29 00:52:48.089987473 +0100
+@@ -27,12 +27,6 @@
+ }
+ }
+
+- # Enhance performance on Intel when using gcc
+-
+-if ($Config{archname} =~ /^i[3456]86/ && $Config{ccname} eq 'gcc') {
+- push(@extra, OPTIMIZE => '-O1 -fomit-frame-pointer');
+-}
+-
+ my %att = (
+ 'NAME' => 'Digest::SHA',
+ 'VERSION_FROM' => $PM,