summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-10 10:36:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-10 10:36:59 +0000
commitd087bcac802f42d38cce5edf59768ae3c834f254 (patch)
tree05c2435821afae567097c2ac7d496f9f69b73bd4 /perl-core/Compress-Raw-Zlib
parentNo Compress-Raw-Zlib-2.022 from upstream yet, so we are not ready for this. (diff)
downloadgentoo-2-d087bcac802f42d38cce5edf59768ae3c834f254.tar.gz
gentoo-2-d087bcac802f42d38cce5edf59768ae3c834f254.tar.bz2
gentoo-2-d087bcac802f42d38cce5edf59768ae3c834f254.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/Compress-Raw-Zlib')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog8
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.023.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index 89d0fdf176aa..9849b0df2b10 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.13 2009/09/12 05:50:50 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.14 2009/11/10 10:36:59 robbat2 Exp $
+
+*Compress-Raw-Zlib-2.023 (10 Nov 2009)
+
+ 10 Nov 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +Compress-Raw-Zlib-2.023.ebuild:
+ Version bump via perl-bump experimental tool.
12 Sep 2009; Torsten Veller <tove@gentoo.org>
Compress-Raw-Zlib-2.020.ebuild, Compress-Raw-Zlib-2.021.ebuild:
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.023.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.023.ebuild
new file mode 100644
index 000000000000..b2263b58410a
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.023.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.023.ebuild,v 1.1 2009/11/10 10:36:59 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PMQS
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=sys-libs/zlib-1.2.2.1"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = /usr/include
+ LIB = /usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}