summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-06-21 12:46:50 +0000
committerTorsten Veller <tove@gentoo.org>2011-06-21 12:46:50 +0000
commit47dc2775d5b5fc08301795daf7be6e17bea9acaf (patch)
tree18c581fdaba0b328d1a61712162bb5985f80bc47 /perl-core/Compress-Raw-Zlib
parentFix pango dependency, bug 293368. The correct dep is set by the mozconfig-3.e... (diff)
downloadgentoo-2-47dc2775d5b5fc08301795daf7be6e17bea9acaf.tar.gz
gentoo-2-47dc2775d5b5fc08301795daf7be6e17bea9acaf.tar.bz2
gentoo-2-47dc2775d5b5fc08301795daf7be6e17bea9acaf.zip
[bump] perl-core/Compress-Raw-Zlib-2.36.0
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/Compress-Raw-Zlib')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog8
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.36.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index 8a8fc2ee5376..396c8a392e51 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.39 2011/05/12 17:18:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.40 2011/06/21 12:46:50 tove Exp $
+
+*Compress-Raw-Zlib-2.36.0 (21 Jun 2011)
+
+ 21 Jun 2011; Torsten Veller <tove@gentoo.org>
+ +Compress-Raw-Zlib-2.36.0.ebuild:
+ Version bump
*Compress-Raw-Zlib-2.35.0 (12 May 2011)
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.36.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.36.0.ebuild
new file mode 100644
index 000000000000..aeceb91f471b
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.36.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.36.0.ebuild,v 1.1 2011/06/21 12:46:50 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.036
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ perl-module_src_prepare
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = ${EPREFIX}/usr/include
+ LIB = ${EPREFIX}/usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}