summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-04 20:11:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-04 20:11:14 +0000
commitf77abf5a1a43ce65c2e56e3302ffdf461b677f75 (patch)
treec5dcb69109264704bcc249c9fc119da48cf4a115 /net-zope
parentDelete older ebuild. (diff)
downloadgentoo-2-f77abf5a1a43ce65c2e56e3302ffdf461b677f75.tar.gz
gentoo-2-f77abf5a1a43ce65c2e56e3302ffdf461b677f75.tar.bz2
gentoo-2-f77abf5a1a43ce65c2e56e3302ffdf461b677f75.zip
Version bump.
(Portage version: 2.2.0_alpha30_p48/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope-security/ChangeLog10
-rw-r--r--net-zope/zope-security/zope-security-3.8.1.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/net-zope/zope-security/ChangeLog b/net-zope/zope-security/ChangeLog
index e0a0c489b787..6835f038e484 100644
--- a/net-zope/zope-security/ChangeLog
+++ b/net-zope/zope-security/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope-security
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/ChangeLog,v 1.9 2010/12/19 17:43:11 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/ChangeLog,v 1.10 2011/05/04 20:11:14 arfrever Exp $
+
+*zope-security-3.8.1 (04 May 2011)
+
+ 04 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-security-3.8.1.ebuild:
+ Version bump.
*zope-security-3.8.0 (19 Dec 2010)
diff --git a/net-zope/zope-security/zope-security-3.8.1.ebuild b/net-zope/zope-security/zope-security-3.8.1.ebuild
new file mode 100644
index 000000000000..dca915595a82
--- /dev/null
+++ b/net-zope/zope-security/zope-security-3.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/zope-security-3.8.1.ebuild,v 1.1 2011/05/04 20:11:14 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Security Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.security"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytz
+ dev-python/restrictedpython
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-exceptions
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}