summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-24 19:09:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-24 19:09:07 +0000
commitd3b5ca59b422485d6ebf34354f9cccc66ea948bb (patch)
treea1e1377a9484cebbbdc5cc2ac06ba0ca7e775cdb /net-zope
parentStable on alpha, bug #290126 (diff)
downloadgentoo-2-d3b5ca59b422485d6ebf34354f9cccc66ea948bb.tar.gz
gentoo-2-d3b5ca59b422485d6ebf34354f9cccc66ea948bb.tar.bz2
gentoo-2-d3b5ca59b422485d6ebf34354f9cccc66ea948bb.zip
Initial import from python overlay.
(Portage version: 14724-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope-filerepresentation/ChangeLog10
-rw-r--r--net-zope/zope-filerepresentation/metadata.xml6
-rw-r--r--net-zope/zope-filerepresentation/zope-filerepresentation-3.6.0.ebuild30
3 files changed, 46 insertions, 0 deletions
diff --git a/net-zope/zope-filerepresentation/ChangeLog b/net-zope/zope-filerepresentation/ChangeLog
new file mode 100644
index 000000000000..ce08b86b4518
--- /dev/null
+++ b/net-zope/zope-filerepresentation/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-filerepresentation
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-filerepresentation/ChangeLog,v 1.1 2009/10/24 19:09:07 arfrever Exp $
+
+*zope-filerepresentation-3.6.0 (24 Oct 2009)
+
+ 24 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-filerepresentation-3.6.0.ebuild, +metadata.xml:
+ Initial import from python overlay. Ebuild written by me.
+
diff --git a/net-zope/zope-filerepresentation/metadata.xml b/net-zope/zope-filerepresentation/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-filerepresentation/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-filerepresentation/zope-filerepresentation-3.6.0.ebuild b/net-zope/zope-filerepresentation/zope-filerepresentation-3.6.0.ebuild
new file mode 100644
index 000000000000..f0f1aa410a66
--- /dev/null
+++ b/net-zope/zope-filerepresentation/zope-filerepresentation-3.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-filerepresentation/zope-filerepresentation-3.6.0.ebuild,v 1.1 2009/10/24 19:09:07 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="File-system Representation Interfaces"
+HOMEPAGE="http://pypi.python.org/pypi/zope.filerepresentation"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"