summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-18 00:54:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-18 00:54:07 +0000
commitd08293a567223474868e1c43b71a3c29b27d413b (patch)
tree009af901446af3c2e600780ac108c9e6078ec50c /net-zope
parentDelete older ebuild. (diff)
downloadgentoo-2-d08293a567223474868e1c43b71a3c29b27d413b.tar.gz
gentoo-2-d08293a567223474868e1c43b71a3c29b27d413b.tar.bz2
gentoo-2-d08293a567223474868e1c43b71a3c29b27d413b.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zconfig/ChangeLog8
-rw-r--r--net-zope/zconfig/zconfig-2.8.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/net-zope/zconfig/ChangeLog b/net-zope/zconfig/ChangeLog
index 67598222fabe..d135b60ea08c 100644
--- a/net-zope/zconfig/ChangeLog
+++ b/net-zope/zconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zconfig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/ChangeLog,v 1.4 2010/02/10 18:32:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/ChangeLog,v 1.5 2010/04/18 00:54:07 arfrever Exp $
+
+*zconfig-2.8.0 (18 Apr 2010)
+
+ 18 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zconfig-2.7.1.ebuild, +zconfig-2.8.0.ebuild:
+ Version bump.
10 Feb 2010; Raúl Porcel <armin76@gentoo.org> zconfig-2.7.1.ebuild:
Add ~alpha/~sparc wrt #288603
diff --git a/net-zope/zconfig/zconfig-2.8.0.ebuild b/net-zope/zconfig/zconfig-2.8.0.ebuild
new file mode 100644
index 000000000000..d08a748a1466
--- /dev/null
+++ b/net-zope/zconfig/zconfig-2.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/zconfig-2.8.0.ebuild,v 1.1 2010/04/18 00:54:07 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="ZConfig"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Structured Configuration Library"
+HOMEPAGE="http://pypi.python.org/pypi/ZConfig"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? ( net-zope/zope-testing )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+DOCS="NEWS.txt README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.7.1-fix_tests.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ rm -fr "${ED}"usr/$(get_libdir)/python*/site-packages/ZConfig/tests
+}